kernel/modules: package Arabic charsets
authorJohn Crispin <john@openwrt.org>
Sun, 30 Mar 2014 13:08:00 +0000 (13:08 +0000)
committerJohn Crispin <john@openwrt.org>
Sun, 30 Mar 2014 13:08:00 +0000 (13:08 +0000)
Signed-off-by: Daniel Golle <daniel@makrotopia.org>
SVN-Revision: 40334

package/kernel/linux/modules/nls.mk

index daef8b0973833e23e7707a2c9cb34e850cc7b680..224fd0378acf993055c4b6f409b961db9c8e14ff 100644 (file)
@@ -99,6 +99,22 @@ endef
 $(eval $(call KernelPackage,nls-cp862))
 
 
+define KernelPackage/nls-cp864
+  SUBMENU:=Native Language Support
+  TITLE:=Codepage 864 (Arabic)
+  KCONFIG:=CONFIG_NLS_CODEPAGE_864
+  FILES:=$(LINUX_DIR)/fs/nls/nls_cp864.ko
+  AUTOLOAD:=$(call AutoLoad,25,nls_cp864)
+  $(call AddDepends/nls)
+endef
+
+define KernelPackage/nls-cp864/description
+  Kernel module for NLS Codepage 864 (Arabic)
+endef
+
+$(eval $(call KernelPackage,nls-cp864))
+
+
 define KernelPackage/nls-cp866
   SUBMENU:=Native Language Support
   TITLE:=Codepage 866 (Cyrillic)
@@ -179,6 +195,22 @@ endef
 $(eval $(call KernelPackage,nls-iso8859-2))
 
 
+define KernelPackage/nls-iso8859-6
+  SUBMENU:=Native Language Support
+  TITLE:=ISO 8859-6 (Arabic)
+  KCONFIG:=CONFIG_NLS_ISO8859_6
+  FILES:=$(LINUX_DIR)/fs/nls/nls_iso8859-6.ko
+  AUTOLOAD:=$(call AutoLoad,25,nls_iso8859-6)
+  $(call AddDepends/nls)
+endef
+
+define KernelPackage/nls-iso8859-6/description
+ Kernel module for NLS ISO 8859-6 (Arabic)
+endef
+
+$(eval $(call KernelPackage,nls-iso8859-6))
+
+
 define KernelPackage/nls-iso8859-8
   SUBMENU:=Native Language Support
   TITLE:=ISO 8859-8, CP1255 (Hebrew)