refresh 2.6.34 patches
authorFlorian Fainelli <florian@openwrt.org>
Sat, 12 Jun 2010 18:10:09 +0000 (18:10 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sat, 12 Jun 2010 18:10:09 +0000 (18:10 +0000)
SVN-Revision: 21768

target/linux/generic-2.6/patches-2.6.34/020-mips_multi_machine_support.patch
target/linux/generic-2.6/patches-2.6.34/089-mtd-samsung-flash.patch
target/linux/generic-2.6/patches-2.6.34/110-netfilter_match_speedup.patch
target/linux/generic-2.6/patches-2.6.34/150-netfilter_imq.patch
target/linux/generic-2.6/patches-2.6.34/511-yaffs-cvs-2009-04-24.patch
target/linux/generic-2.6/patches-2.6.34/601-phy-add-aneg-done-function.patch
target/linux/generic-2.6/patches-2.6.34/680-phy_ar8216.patch
target/linux/generic-2.6/patches-2.6.34/690-phy_rtl8306.patch
target/linux/generic-2.6/patches-2.6.34/691-phy_rtl8366.patch
target/linux/generic-2.6/patches-2.6.34/971-ocf_20100325.patch
target/linux/generic-2.6/patches-2.6.34/975-ssb_update.patch

index ca0c10b20dbbcf35f71f402f8b4b219f167a3ea7..83e24451c1c952088afd9c4e91b2c65f8707b27e 100644 (file)
  
  unsigned int vced_count, vcei_count;
  
  
  unsigned int vced_count, vcei_count;
  
-@@ -31,8 +32,12 @@ static int show_cpuinfo(struct seq_file 
+@@ -31,8 +32,12 @@ static int show_cpuinfo(struct seq_file
        /*
         * For the first processor also print the system type
         */
        /*
         * For the first processor also print the system type
         */
index eab03db50d0b8cd052b7a4778dfcac90fa60b601..4d1072cd4c4a97c469e1a27f9a352d5f74f1bbb8 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/mtd/chips/cfi_cmdset_0002.c
 +++ b/drivers/mtd/chips/cfi_cmdset_0002.c
 --- a/drivers/mtd/chips/cfi_cmdset_0002.c
 +++ b/drivers/mtd/chips/cfi_cmdset_0002.c
-@@ -374,7 +374,7 @@ struct mtd_info *cfi_cmdset_0002(struct 
+@@ -374,7 +374,7 @@ struct mtd_info *cfi_cmdset_0002(struct
  
                cfi_fixup_major_minor(cfi, extp);
  
  
                cfi_fixup_major_minor(cfi, extp);
  
index 8178a225ee07a0505b2af368291544215f6c01df..41c487b6899719c926cfad1b6e9b33405bbdcddb 100644 (file)
  
                e = (struct ipt_entry *)(loc_cpu_entry + off);
                if (copy_to_user(userptr + off
  
                e = (struct ipt_entry *)(loc_cpu_entry + off);
                if (copy_to_user(userptr + off
-@@ -1001,6 +1041,14 @@ copy_entries_to_user(unsigned int total_
+@@ -1000,6 +1040,14 @@ copy_entries_to_user(unsigned int total_
+                       ret = -EFAULT;
                        goto free_counters;
                }
                        goto free_counters;
                }
++
 +              flags = e->ip.flags & ~IPT_F_NO_DEF_MATCH;
 +              if (copy_to_user(userptr + off
 +                               + offsetof(struct ipt_entry, ip.flags),
 +              flags = e->ip.flags & ~IPT_F_NO_DEF_MATCH;
 +              if (copy_to_user(userptr + off
 +                               + offsetof(struct ipt_entry, ip.flags),
 +                      ret = -EFAULT;
 +                      goto free_counters;
 +              }
 +                      ret = -EFAULT;
 +                      goto free_counters;
 +              }
-+
                for (i = sizeof(struct ipt_entry);
                     i < e->target_offset;
                for (i = sizeof(struct ipt_entry);
                     i < e->target_offset;
-                    i += m->u.match_size) {
index 8a0507fa013bf44ebabc168e5a1059208063750d..d59534687443e996be171bf740fe854d3ebe1b42 100644 (file)
  /* return EBUSY when somebody else is registered, return EEXIST if the
   * same handler is registered, return 0 in case of success. */
  int nf_register_queue_handler(u_int8_t pf, const struct nf_queue_handler *qh)
  /* return EBUSY when somebody else is registered, return EEXIST if the
   * same handler is registered, return 0 in case of success. */
  int nf_register_queue_handler(u_int8_t pf, const struct nf_queue_handler *qh)
-@@ -81,7 +101,7 @@ void nf_unregister_queue_handlers(const 
+@@ -81,7 +101,7 @@ void nf_unregister_queue_handlers(const
  }
  EXPORT_SYMBOL_GPL(nf_unregister_queue_handlers);
  
  }
  EXPORT_SYMBOL_GPL(nf_unregister_queue_handlers);
  
index c40da10d69ff90418909ecf9a37ff8da68375ef4..c334b17d0872a877f52cd9c0e4234ad118df7d09 100644 (file)
 +                      yaffs_UnpackTags2(tags, &pt);
 +              }
 +      }
 +                      yaffs_UnpackTags2(tags, &pt);
 +              }
 +      }
--      if(tags && retval == -EBADMSG && tags->eccResult == YAFFS_ECC_RESULT_NO_ERROR)
--              tags->eccResult = YAFFS_ECC_RESULT_UNFIXED;
++
 +      if (localData)
 +              yaffs_ReleaseTempBuffer(dev, data, __LINE__);
  
 +      if (localData)
 +              yaffs_ReleaseTempBuffer(dev, data, __LINE__);
  
+-      if(tags && retval == -EBADMSG && tags->eccResult == YAFFS_ECC_RESULT_NO_ERROR)
 +      if (tags && retval == -EBADMSG && tags->eccResult == YAFFS_ECC_RESULT_NO_ERROR)
 +      if (tags && retval == -EBADMSG && tags->eccResult == YAFFS_ECC_RESULT_NO_ERROR)
-+              tags->eccResult = YAFFS_ECC_RESULT_UNFIXED;
+               tags->eccResult = YAFFS_ECC_RESULT_UNFIXED;
+-
        if (retval == 0)
                return YAFFS_OK;
        else
        if (retval == 0)
                return YAFFS_OK;
        else
index aac38ff2e78cf7e8f30f63de9d40ef9d7583b62b..8f939a5b7ba9937d756469d2e77a666ade882ce2 100644 (file)
@@ -1,6 +1,6 @@
 --- a/include/linux/phy.h
 +++ b/include/linux/phy.h
 --- a/include/linux/phy.h
 +++ b/include/linux/phy.h
-@@ -393,9 +393,18 @@ struct phy_driver {
+@@ -379,9 +379,18 @@ struct phy_driver {
         */
        int (*config_aneg)(struct phy_device *phydev);
  
         */
        int (*config_aneg)(struct phy_device *phydev);
  
@@ -21,7 +21,7 @@
  
 --- a/drivers/net/phy/phy_device.c
 +++ b/drivers/net/phy/phy_device.c
  
 --- a/drivers/net/phy/phy_device.c
 +++ b/drivers/net/phy/phy_device.c
-@@ -695,6 +695,9 @@ int genphy_update_link(struct phy_device
+@@ -698,6 +698,9 @@ int genphy_update_link(struct phy_device
  {
        int status;
  
  {
        int status;
  
@@ -33,7 +33,7 @@
  
 --- a/drivers/net/phy/phy.c
 +++ b/drivers/net/phy/phy.c
  
 --- a/drivers/net/phy/phy.c
 +++ b/drivers/net/phy/phy.c
-@@ -107,6 +107,9 @@ static inline int phy_aneg_done(struct p
+@@ -106,6 +106,9 @@ static inline int phy_aneg_done(struct p
  {
        int retval;
  
  {
        int retval;
  
index 2bc9d6754d57a2c89fdf64c3280658dc8df10c48..c375a97292ee4c0f2dcf1a5773410e29d8d8f101 100644 (file)
@@ -1,7 +1,7 @@
 --- a/drivers/net/phy/Kconfig
 +++ b/drivers/net/phy/Kconfig
 --- a/drivers/net/phy/Kconfig
 +++ b/drivers/net/phy/Kconfig
-@@ -111,6 +111,10 @@ config IP175C_PHY
-       tristate "Driver for IC+ IP175C/IP178C switches"
+@@ -111,6 +111,10 @@ config IP17XX_PHY
+       tristate "Driver for IC+ IP17xx switches"
        select SWCONFIG
  
 +config AR8216_PHY
        select SWCONFIG
  
 +config AR8216_PHY
@@ -15,7 +15,7 @@
 +++ b/drivers/net/phy/Makefile
 @@ -18,6 +18,7 @@ obj-$(CONFIG_ADM6996_PHY)    += adm6996.o
  obj-$(CONFIG_MVSWITCH_PHY)    += mvswitch.o
 +++ b/drivers/net/phy/Makefile
 @@ -18,6 +18,7 @@ obj-$(CONFIG_ADM6996_PHY)    += adm6996.o
  obj-$(CONFIG_MVSWITCH_PHY)    += mvswitch.o
- obj-$(CONFIG_IP175C_PHY)      += ip175c.o
+ obj-$(CONFIG_IP17XX_PHY)      += ip17xx.o
  obj-$(CONFIG_REALTEK_PHY)     += realtek.o
 +obj-$(CONFIG_AR8216_PHY)      += ar8216.o
  obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
  obj-$(CONFIG_REALTEK_PHY)     += realtek.o
 +obj-$(CONFIG_AR8216_PHY)      += ar8216.o
  obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
index 9e86748a86e973bbf8026d06f795056498196c35..e97b84d48cf7e9affaab44b690293be7cf5c53ed 100644 (file)
@@ -14,7 +14,7 @@
 --- a/drivers/net/phy/Makefile
 +++ b/drivers/net/phy/Makefile
 @@ -19,6 +19,7 @@ obj-$(CONFIG_MVSWITCH_PHY)   += mvswitch.o
 --- a/drivers/net/phy/Makefile
 +++ b/drivers/net/phy/Makefile
 @@ -19,6 +19,7 @@ obj-$(CONFIG_MVSWITCH_PHY)   += mvswitch.o
- obj-$(CONFIG_IP175C_PHY)      += ip175c.o
+ obj-$(CONFIG_IP17XX_PHY)      += ip17xx.o
  obj-$(CONFIG_REALTEK_PHY)     += realtek.o
  obj-$(CONFIG_AR8216_PHY)      += ar8216.o
 +obj-$(CONFIG_RTL8306_PHY)     += rtl8306.o
  obj-$(CONFIG_REALTEK_PHY)     += realtek.o
  obj-$(CONFIG_AR8216_PHY)      += ar8216.o
 +obj-$(CONFIG_RTL8306_PHY)     += rtl8306.o
index ec07636308b73353ebc3e1d93d562a1a59e778c1..34ac10ed399c8824634fea0c7eb7be0858da1d6d 100644 (file)
@@ -32,7 +32,7 @@
  endif # PHYLIB
 --- a/drivers/net/phy/Makefile
 +++ b/drivers/net/phy/Makefile
  endif # PHYLIB
 --- a/drivers/net/phy/Makefile
 +++ b/drivers/net/phy/Makefile
-@@ -20,6 +20,9 @@ obj-$(CONFIG_IP175C_PHY)     += ip175c.o
+@@ -20,6 +20,9 @@ obj-$(CONFIG_IP17XX_PHY)     += ip17xx.o
  obj-$(CONFIG_REALTEK_PHY)     += realtek.o
  obj-$(CONFIG_AR8216_PHY)      += ar8216.o
  obj-$(CONFIG_RTL8306_PHY)     += rtl8306.o
  obj-$(CONFIG_REALTEK_PHY)     += realtek.o
  obj-$(CONFIG_AR8216_PHY)      += ar8216.o
  obj-$(CONFIG_RTL8306_PHY)     += rtl8306.o
index d884348238613a76bc56df9bd4c98483dfe8d34c..c34a7e2657ed36132582d20a4fcfa89650177576 100644 (file)
@@ -24,7 +24,7 @@
   * All of these routines try to estimate how many bits of randomness a
   * particular randomness source.  They do this by keeping track of the
   * first and second order deltas of the event timings.
   * All of these routines try to estimate how many bits of randomness a
   * particular randomness source.  They do this by keeping track of the
   * first and second order deltas of the event timings.
-@@ -714,6 +724,61 @@ void add_disk_randomness(struct gendisk 
+@@ -714,6 +724,61 @@ void add_disk_randomness(struct gendisk
  }
  #endif
  
  }
  #endif
  
index ce2c487bff4baa67816a203c11f2ad6b18195247..245cec18a928150e3661ba25ed95b4c3b42b6f1a 100644 (file)
@@ -40,7 +40,7 @@
  /* Helper to extract some _offset, which is one of the SSB_SPROM_XXX defines. */
  #define SPEX16(_outvar, _offset, _mask, _shift)       \
        out->_outvar = ((in[SPOFF(_offset)] & (_mask)) >> (_shift))
  /* Helper to extract some _offset, which is one of the SSB_SPROM_XXX defines. */
  #define SPEX16(_outvar, _offset, _mask, _shift)       \
        out->_outvar = ((in[SPOFF(_offset)] & (_mask)) >> (_shift))
-@@ -254,7 +254,7 @@ static int sprom_do_read(struct ssb_bus 
+@@ -254,7 +254,7 @@ static int sprom_do_read(struct ssb_bus
        int i;
  
        for (i = 0; i < bus->sprom_size; i++)
        int i;
  
        for (i = 0; i < bus->sprom_size; i++)