lantiq: add support for the Alpha ASL56026
authorAlex Maclean <monkeh@monkeh.net>
Mon, 6 Mar 2017 23:25:37 +0000 (23:25 +0000)
committerMathias Kresin <dev@kresin.me>
Wed, 8 Mar 2017 18:06:04 +0000 (19:06 +0100)
The ASL56026 is a VDSL2 router with dual 100mbit ethernet,
also known as the ECI B-FOCuS V-2FUb/I.

CPU: Lantiq XRX268 v1.1 at 333MHz
Modem: Lantiq VRX208
RAM: 32MiB DDR2 at 167MHz
Flash: 8MiB NOR, Spansion S29GL064N90TF04

UART is at JP1:
Pin 1 TX
Pin 2 GND
Pin 3 +3.3V
Pin 4 NC
Pin 5 RX

Boot selection pins are exposed via several resistor jumpers:
boot_sel0 is at J15, on the rear of the board. Default is high.
boot_sel1 is at J3, next to the flash - it is also the flash CE# pin. Default is low.
boot_sel2 is at J12, directly below the SoC. Default is low.
boot_sel3 is at J16, on the rear of the board. Default is low.

The boot_sel pins should never be shorted, the jumper must be moved or
a lower value resistor used to change the pull (existing resistors are 4k7, 1k should work)

To install with the stock bootloader you must break the built in image selection process
which uses at least the following vars: f_upgrade_addr, f_upgrade2_addr, loadaddr, kernel_addr, activeregion, committedregion
This is done by setting loadaddr and both f_upgrade_addr vars to the same address:

VR9 # setenv loadaddr 0xB0040000
VR9 # setenv f_upgrade_addr 0xB0040000
VR9 # setenv f_upgrade2_addr 0xB0040000
VR9 # saveenv

Then flash the firmware image:

VR9 # tftpboot 0x81000000 lede-lantiq-xrx200-ASL56026-squashfs-sysupgrade.bin
VR9 # erase B0040000 +${filesize}
VR9 # cp.b 0x81000000 0xB0040000 ${filesize}

Signed-off-by: Alex Maclean <monkeh@monkeh.net>
target/linux/lantiq/base-files/etc/board.d/02_network
target/linux/lantiq/dts/ASL56026.dts [new file with mode: 0644]
target/linux/lantiq/image/Makefile

index 576bb7d86bc8f2746e96bde716f51e553a4dd774..3dd5cadc670f1a7960c0ce555c56bce531372023 100755 (executable)
@@ -61,6 +61,13 @@ ARV7519RW22)
                "0:lan:5" "2:lan:3" "3:lan:4" "4:lan:1" "5:lan:2" "6t@eth0"
        ;;
 
+ASL56026)
+       lan_mac=$(mtd_get_mac_ascii uboot_env ethaddr)
+       wan_mac=$(mtd_get_mac_ascii uboot_env wanmac)
+       ucidef_add_switch "switch0"\
+               "2:lan" "3:lan" "6t@eth0"
+       ;;
+
 BTHOMEHUBV2B)
        lan_mac=$(mtd_get_mac_ascii uboot_env ethaddr)
        wan_mac=$(macaddr_add "$lan_mac" 1)
diff --git a/target/linux/lantiq/dts/ASL56026.dts b/target/linux/lantiq/dts/ASL56026.dts
new file mode 100644 (file)
index 0000000..735e6bc
--- /dev/null
@@ -0,0 +1,170 @@
+/dts-v1/;
+
+#include "vr9.dtsi"
+
+#include <dt-bindings/input/input.h>
+
+/ {
+       model = "ASL56026 - BT OpenReach VDSL Modem";
+
+       chosen {
+               bootargs = "console=ttyLTQ0,115200";
+       };
+
+       aliases {
+               led-boot = &power_green;
+               led-failsafe = &power_red;
+               led-running = &power_green;
+
+               led-internet = &dsl;
+       };
+
+       memory@0 {
+               reg = <0x0 0x2000000>;
+       };
+
+       fpi@10000000 {
+               localbus@0 {
+                       nor-boot@0 {
+                               compatible = "lantiq,nor";
+                               bank-width = <2>;
+                               reg = <0 0x0 0x0800000>;
+                               #address-cells = <1>;
+                               #size-cells = <1>;
+
+                               partitions {
+                                       compatible = "fixed-partitions";
+                                       #address-cells = <1>;
+                                       #size-cells = <1>;
+
+                                       partition@0 {
+                                               label = "uboot";
+                                               reg = <0x0 0x30000>;
+                                       };
+
+                                       partition@30000 {
+                                               label = "uboot_env";
+                                               reg = <0x30000 0x10000>;
+                                       };
+
+                                       partition@40000 {
+                                               label = "firmware";
+                                               reg = <0x40000 0x750000>;
+                                       };
+
+                                       partition@790000 {
+                                               label = "ddrconfig";
+                                               reg = <0x790000 0x70000>;
+                                               read-only;
+                                       };
+                               };
+                       };
+               };
+
+               gpio: pinmux@E100B10 {
+                       pinctrl-names = "default";
+                       pinctrl-0 = <&state_default>;
+
+                       state_default: pinmux {
+                               mdio {
+                                       lantiq,groups = "mdio";
+                                       lantiq,function = "mdio";
+                               };
+                       };
+               };
+       };
+
+       gphy-xrx200 {
+               compatible = "lantiq,phy-xrx200";
+               firmware1 = "lantiq/vr9_phy22f_a1x.bin";        /*VR9 1.1*/
+               firmware2 = "lantiq/vr9_phy22f_a2x.bin";        /*VR9 1.2*/
+               phys = [ 00 01 ];
+       };
+
+       gpio-keys-polled {
+               compatible = "gpio-keys-polled";
+               #address-cells = <1>;
+               #size-cells = <0>;
+               poll-interval = <100>;
+
+               reset {
+                       label = "reset";
+                       gpios = <&gpio 40 GPIO_ACTIVE_LOW>;
+                       linux,code = <KEY_RESTART>;
+               };
+       };
+
+       gpio-leds {
+               compatible = "gpio-leds";
+
+               dsl: dsl {
+                       label = "asl56026:green:dsl";
+                       gpios = <&gpio 6 GPIO_ACTIVE_LOW>;
+               };
+
+               /* power-* is a bicolour led */
+               power_green: power_green {
+                       label = "asl56026:green:power";
+                       gpios = <&gpio 17 GPIO_ACTIVE_HIGH>;
+                       default-state = "keep";
+               };
+
+               power_red: power_red {
+                       label = "asl56026:red:power";
+                       gpios = <&gpio 18 GPIO_ACTIVE_HIGH>;
+               };
+       };
+
+       gpio_export {
+               compatible = "gpio-export";
+               #size-cells = <0>;
+
+               power_led_blink {
+                       gpio-export,name = "power_led_blink";
+                       gpio-export,output = <0>;
+                       gpios = <&gpio 16 GPIO_ACTIVE_LOW>;
+               };
+       };
+};
+
+&eth0 {
+       lan: interface@0 {
+               compatible = "lantiq,xrx200-pdi";
+               #address-cells = <1>;
+               #size-cells = <0>;
+               reg = <0>;
+               lantiq,switch;
+
+               ethernet@2 {
+                       compatible = "lantiq,xrx200-pdi-port";
+                       reg = <2>;
+                       phy-mode = "mii";
+                       phy-handle = <&phy11>;
+               };
+
+               ethernet@3 {
+                       compatible = "lantiq,xrx200-pdi-port";
+                       reg = <3>;
+                       phy-mode = "mii";
+                       phy-handle = <&phy14>;
+               };
+
+       };
+
+       mdio@0 {
+               #address-cells = <1>;
+               #size-cells = <0>;
+               compatible = "lantiq,xrx200-mdio";
+
+               phy11: ethernet-phy@11 {
+                       reg = <0x11>;
+                       compatible = "lantiq,phy22f", "ethernet-phy-ieee802.3-c22";
+               };
+
+               phy14: ethernet-phy@14 {
+                       reg = <0x14>;
+                       compatible = "lantiq,phy22f", "ethernet-phy-ieee802.3-c22";
+               };
+
+       };
+};
index 5daab032ee4f90fccc0587a929e814bd31e6b4c5..12763bbdb11974ebd661093b7d03a6c2f2ff650e 100644 (file)
@@ -474,6 +474,12 @@ define Device/ARV7519RW22
 endef
 TARGET_DEVICES += ARV7519RW22
 
+define Device/ASL56026
+  IMAGE_SIZE := 7488k
+  DEVICE_TITLE := BT OpenReach - ECI VDSL Modem V-2FUb/I
+endef
+TARGET_DEVICES += ASL56026
+
 define Device/BTHOMEHUBV5A
   $(Device/NAND)
   DEVICE_TITLE := BT Home Hub 5A