kernel: add a package for bcm-phy-lib.ko, fixes build errors with kmod-phy-broadcom
authorFelix Fietkau <nbd@openwrt.org>
Sat, 23 Jan 2016 20:01:26 +0000 (20:01 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sat, 23 Jan 2016 20:01:26 +0000 (20:01 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
SVN-Revision: 48464

package/kernel/linux/modules/netdevices.mk

index ef3cf85ef87097f78fe438a46f5d27a2ac816d4a..417a6a6114b563bcfa60fc3238afd85dff7fa171 100644 (file)
@@ -148,11 +148,24 @@ endef
 $(eval $(call KernelPackage,gw16083))
 
 
+define KernelPackage/phylib-broadcom
+   SUBMENU:=$(NETWORK_DEVICES_MENU)
+   TITLE:=Broadcom Ethernet PHY library
+   KCONFIG:=CONFIG_BCM_NET_PHYLIB
+   HIDDEN:=1
+   DEPENDS:=+kmod-libphy
+   FILES:=$(LINUX_DIR)/drivers/net/phy/bcm-phy-lib.ko
+   AUTOLOAD:=$(call AutoLoad,17,bcm-phy-lib)
+endef
+
+$(eval $(call KernelPackage,phylib-broadcom))
+
+
 define KernelPackage/phy-broadcom
    SUBMENU:=$(NETWORK_DEVICES_MENU)
    TITLE:=Broadcom Ethernet PHY driver
    KCONFIG:=CONFIG_BROADCOM_PHY
-   DEPENDS:=+kmod-libphy
+   DEPENDS:=+kmod-libphy +kmod-phylib-broadcom
    FILES:=$(LINUX_DIR)/drivers/net/phy/broadcom.ko
    AUTOLOAD:=$(call AutoLoad,18,broadcom)
 endef