kernel: bump 4.14 to 4.14.99
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Wed, 13 Feb 2019 10:30:07 +0000 (11:30 +0100)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Fri, 15 Feb 2019 09:53:17 +0000 (10:53 +0100)
Refreshed all patches.

Compile-tested on: cns3xxx, imx6
Runtime-tested on: cns3xxx, imx6

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
14 files changed:
include/kernel-version.mk
target/linux/gemini/patches-4.14/0016-ARM-dts-Add-TVE-TVC-and-ILI9322-panel-to-DIR-685.patch
target/linux/gemini/patches-4.14/0031-ARM-dts-Add-the-FOTG210-USB-host-to-Gemini.patch
target/linux/gemini/patches-4.14/0905-arm-dts-gemini-dlink-dir-685-add-rtl8366rb.patch
target/linux/generic/hack-4.14/204-module_strip.patch
target/linux/ipq806x/patches-4.14/0048-PM-OPP-HACK-Allow-to-set-regulator-without-opp_list.patch
target/linux/ipq806x/patches-4.14/0049-PM-OPP-Support-adjusting-OPP-voltages-at-runtime.patch
target/linux/ipq806x/patches-4.14/0052-PM-OPP-Update-the-voltage-tolerance-when-adjusting-t.patch
target/linux/mediatek/patches-4.14/0033-dsa-multi-cpu.patch
target/linux/mediatek/patches-4.14/0107-usb-mtu3-support-36-bit-DMA-address.patch
target/linux/mediatek/patches-4.14/0109-usb-mtu3-add-support-for-usb3.1-IP.patch
target/linux/ramips/patches-4.14/0051-serial-add-ugly-custom-baud-rate-hack.patch
target/linux/ramips/patches-4.14/0070-weak_reordering.patch
target/linux/ramips/patches-4.14/101-mt7621-timer.patch

index f1cb1fdab80a84fcdb2eebd4273868edfd22a5c8..279d0e24e54935373e3da35b2757c1d7518f9c3c 100644 (file)
@@ -3,10 +3,10 @@
 LINUX_RELEASE?=1
 
 LINUX_VERSION-4.9 = .156
-LINUX_VERSION-4.14 = .98
+LINUX_VERSION-4.14 = .99
 
 LINUX_KERNEL_HASH-4.9.156 = 5eb1b9ba43370512ab637452089bb93f8c0fdd7d5399e99561d382f74517a816
-LINUX_KERNEL_HASH-4.14.98 = 8f021171b1b1efb41326e603116a45126fc030d06aaa9b0784ae612323010c5f
+LINUX_KERNEL_HASH-4.14.99 = 8ff98caed5b20b733dedcbe99559d71a0e09e239c0c2488b3fd799c96489eb0a
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
index e0cf267cccb9ac6d7ecdfb41a7134e56c7d3ef35..b9779370ba52cb959cd335cb49d45612a672cfbf 100644 (file)
@@ -94,7 +94,7 @@ Signed-off-by: Linus Walleij <linus.walleij@linaro.org>
                        /* 32MB of flash */
                        reg = <0x30000000 0x02000000>;
  
-@@ -242,5 +292,16 @@
+@@ -238,5 +288,16 @@
                ata@63000000 {
                        status = "okay";
                };
index cb6fdb875257e2360d709739f7a038214983248d..66e2b8c705b17dccfc8abe8f8af152d2c94a79fe 100644 (file)
@@ -27,7 +27,7 @@ the patch is only included in the series for context.
 
 --- a/arch/arm/boot/dts/gemini-dlink-dir-685.dts
 +++ b/arch/arm/boot/dts/gemini-dlink-dir-685.dts
-@@ -303,5 +303,13 @@
+@@ -299,5 +299,13 @@
                                };
                        };
                };
index 288b0d878f1d0429b37438a62343a97df6d3e867..8cab32200f90956370f197de7f4f3436cf0c5e44 100644 (file)
@@ -13,7 +13,7 @@
        leds {
                compatible = "gpio-leds";
                led-wps {
-@@ -249,6 +255,47 @@
+@@ -245,6 +251,47 @@
                                                groups = "gpio1bgrp";
                                        };
                                };
@@ -61,7 +61,7 @@
                        };
                };
  
-@@ -290,6 +337,18 @@
+@@ -286,6 +333,18 @@
                                <0x6000 0 0 4 &pci_intc 2>;
                };
  
index db65062fcf7fa67c03460817c1b353fe9fa0fe35..dce9c48473111e192e4505ae388f43555062c4c3 100644 (file)
@@ -114,7 +114,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  config MODULES_TREE_LOOKUP
 --- a/kernel/module.c
 +++ b/kernel/module.c
-@@ -3006,9 +3006,11 @@ static struct module *setup_load_info(st
+@@ -3008,9 +3008,11 @@ static struct module *setup_load_info(st
  
  static int check_modinfo(struct module *mod, struct load_info *info, int flags)
  {
@@ -127,7 +127,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        if (flags & MODULE_INIT_IGNORE_VERMAGIC)
                modmagic = NULL;
  
-@@ -3029,6 +3031,7 @@ static int check_modinfo(struct module *
+@@ -3031,6 +3033,7 @@ static int check_modinfo(struct module *
                                mod->name);
                add_taint_module(mod, TAINT_OOT_MODULE, LOCKDEP_STILL_OK);
        }
@@ -137,7 +137,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  
 --- a/scripts/mod/modpost.c
 +++ b/scripts/mod/modpost.c
-@@ -1982,7 +1982,9 @@ static void read_symbols(char *modname)
+@@ -1984,7 +1984,9 @@ static void read_symbols(char *modname)
                symname = remove_dot(info.strtab + sym->st_name);
  
                handle_modversions(mod, &info, sym, symname);
@@ -147,7 +147,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        }
        if (!is_vmlinux(modname) ||
             (is_vmlinux(modname) && vmlinux_section_warnings))
-@@ -2143,8 +2145,10 @@ static void add_header(struct buffer *b,
+@@ -2145,8 +2147,10 @@ static void add_header(struct buffer *b,
        buf_printf(b, "#include <linux/vermagic.h>\n");
        buf_printf(b, "#include <linux/compiler.h>\n");
        buf_printf(b, "\n");
@@ -158,7 +158,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        buf_printf(b, "\n");
        buf_printf(b, "__visible struct module __this_module\n");
        buf_printf(b, "__attribute__((section(\".gnu.linkonce.this_module\"))) = {\n");
-@@ -2161,8 +2165,10 @@ static void add_header(struct buffer *b,
+@@ -2163,8 +2167,10 @@ static void add_header(struct buffer *b,
  
  static void add_intree_flag(struct buffer *b, int is_intree)
  {
@@ -169,7 +169,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  }
  
  /* Cannot check for assembler */
-@@ -2175,10 +2181,12 @@ static void add_retpoline(struct buffer
+@@ -2177,10 +2183,12 @@ static void add_retpoline(struct buffer
  
  static void add_staging_flag(struct buffer *b, const char *name)
  {
@@ -182,7 +182,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  }
  
  /**
-@@ -2277,11 +2285,13 @@ static void add_depends(struct buffer *b
+@@ -2279,11 +2287,13 @@ static void add_depends(struct buffer *b
  
  static void add_srcversion(struct buffer *b, struct module *mod)
  {
@@ -196,7 +196,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  }
  
  static void write_if_changed(struct buffer *b, const char *fname)
-@@ -2518,7 +2528,9 @@ int main(int argc, char **argv)
+@@ -2520,7 +2530,9 @@ int main(int argc, char **argv)
                add_staging_flag(&buf, mod->name);
                err |= add_versions(&buf, mod);
                add_depends(&buf, mod, modules);
index 4cbb4422ca7fba72a8ffb4d9e18dbb0d4e9f2821..7c78d444f80f850ab13d5f2fbb3e5c9cc9a795a8 100644 (file)
@@ -10,7 +10,7 @@ Signed-off-by: Georgi Djakov <georgi.djakov@linaro.org>
 
 --- a/drivers/base/power/opp/core.c
 +++ b/drivers/base/power/opp/core.c
-@@ -1277,11 +1277,13 @@ struct opp_table *dev_pm_opp_set_regulat
+@@ -1280,11 +1280,13 @@ struct opp_table *dev_pm_opp_set_regulat
        if (!opp_table)
                return ERR_PTR(-ENOMEM);
  
index abcccb277c98adf8b4bfac60e60ade7d4dbae8be..ef48e9f01b89826912e9ebcb22b7c392013c2d06 100644 (file)
@@ -27,7 +27,7 @@ Signed-off-by: Georgi Djakov <georgi.djakov@linaro.org>
 
 --- a/drivers/base/power/opp/core.c
 +++ b/drivers/base/power/opp/core.c
-@@ -1605,6 +1605,83 @@ put_table:
+@@ -1608,6 +1608,83 @@ put_table:
  }
  
  /**
index 6299fcf25783498b859233805651b2ada36e76da..7cde22be0b83b8f3faacb92b20f313147cd805c3 100644 (file)
@@ -17,7 +17,7 @@ Signed-off-by: Georgi Djakov <georgi.djakov@linaro.org>
 
 --- a/drivers/base/power/opp/core.c
 +++ b/drivers/base/power/opp/core.c
-@@ -1649,6 +1649,7 @@ int dev_pm_opp_adjust_voltage(struct dev
+@@ -1652,6 +1652,7 @@ int dev_pm_opp_adjust_voltage(struct dev
        struct opp_table *opp_table;
        struct dev_pm_opp *new_opp, *tmp_opp, *opp = ERR_PTR(-ENODEV);
        int r = 0;
@@ -25,7 +25,7 @@ Signed-off-by: Georgi Djakov <georgi.djakov@linaro.org>
  
        /* keep the node allocated */
        new_opp = kmalloc(sizeof(*new_opp), GFP_KERNEL);
-@@ -1685,6 +1686,10 @@ int dev_pm_opp_adjust_voltage(struct dev
+@@ -1688,6 +1689,10 @@ int dev_pm_opp_adjust_voltage(struct dev
  
        /* plug in new node */
        new_opp->supplies[0].u_volt = u_volt;
index 926e0d84216924e21fd04e4e8b5db3181c6f49e2..0442506977260c60bc145967ac69cdc07dde4ec6 100644 (file)
  
 --- a/net/dsa/slave.c
 +++ b/net/dsa/slave.c
-@@ -1263,7 +1263,7 @@ int dsa_slave_create(struct dsa_port *po
+@@ -1267,7 +1267,7 @@ int dsa_slave_create(struct dsa_port *po
        int ret;
  
        cpu_dp = ds->dst->cpu_dp;
  
        if (!ds->num_tx_queues)
                ds->num_tx_queues = 1;
-@@ -1301,6 +1301,7 @@ int dsa_slave_create(struct dsa_port *po
+@@ -1305,6 +1305,7 @@ int dsa_slave_create(struct dsa_port *po
        p->dp = port;
        INIT_LIST_HEAD(&p->mall_tc_list);
        p->xmit = dst->tag_ops->xmit;
index d2633c1ca83fe9eb92d1c9473b2faa214bd86207..88f52e6f202363ca94cccd0c4340be697e298978 100644 (file)
@@ -74,7 +74,7 @@ Signed-off-by: Felipe Balbi <felipe.balbi@linux.intel.com>
  #include <linux/kernel.h>
  #include <linux/module.h>
  #include <linux/of_address.h>
-@@ -759,7 +760,31 @@ static void mtu3_hw_exit(struct mtu3 *mt
+@@ -761,7 +762,31 @@ static void mtu3_hw_exit(struct mtu3 *mt
        mtu3_mem_free(mtu);
  }
  
@@ -107,7 +107,7 @@ Signed-off-by: Felipe Balbi <felipe.balbi@linux.intel.com>
  
  int ssusb_gadget_init(struct ssusb_mtk *ssusb)
  {
-@@ -820,6 +845,12 @@ int ssusb_gadget_init(struct ssusb_mtk *
+@@ -822,6 +847,12 @@ int ssusb_gadget_init(struct ssusb_mtk *
                return ret;
        }
  
@@ -120,7 +120,7 @@ Signed-off-by: Felipe Balbi <felipe.balbi@linux.intel.com>
        ret = devm_request_irq(dev, mtu->irq, mtu3_irq, 0, dev_name(dev), mtu);
        if (ret) {
                dev_err(dev, "request irq %d failed!\n", mtu->irq);
-@@ -845,6 +876,7 @@ int ssusb_gadget_init(struct ssusb_mtk *
+@@ -847,6 +878,7 @@ int ssusb_gadget_init(struct ssusb_mtk *
  gadget_err:
        device_init_wakeup(dev, false);
  
index c17a77be5c3c3d1c27a64cf1ed10ea7d7232eabc..f44ce4e1554ea312d8db64374a8effd840da3037 100644 (file)
@@ -46,7 +46,7 @@ Signed-off-by: Felipe Balbi <felipe.balbi@linux.intel.com>
        }
  
        dev_info(mtu->dev, "max_speed: %s\n",
-@@ -624,6 +627,10 @@ static irqreturn_t mtu3_link_isr(struct
+@@ -626,6 +629,10 @@ static irqreturn_t mtu3_link_isr(struct
                udev_speed = USB_SPEED_SUPER;
                maxpkt = 512;
                break;
@@ -57,7 +57,7 @@ Signed-off-by: Felipe Balbi <felipe.balbi@linux.intel.com>
        default:
                udev_speed = USB_SPEED_UNKNOWN;
                break;
-@@ -825,14 +832,15 @@ int ssusb_gadget_init(struct ssusb_mtk *
+@@ -827,14 +834,15 @@ int ssusb_gadget_init(struct ssusb_mtk *
        case USB_SPEED_FULL:
        case USB_SPEED_HIGH:
        case USB_SPEED_SUPER:
index 2ad1f6f9f8c5c022226b12afd4e752a0fad8908e..d238ed972800ed4db9921c29a5cf589423e544bf 100644 (file)
@@ -10,7 +10,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
 
 --- a/drivers/tty/serial/serial_core.c
 +++ b/drivers/tty/serial/serial_core.c
-@@ -428,6 +428,9 @@ uart_get_baud_rate(struct uart_port *por
+@@ -431,6 +431,9 @@ uart_get_baud_rate(struct uart_port *por
                break;
        }
  
index 8f8c42c47f0bf331edc31f3baf61801dbcd75d70..52e6641324ffcf5cf3527d58e24e7bdeaacf5e72 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/ralink/Kconfig
 +++ b/arch/mips/ralink/Kconfig
-@@ -57,6 +57,7 @@ choice
+@@ -58,6 +58,7 @@ choice
                select COMMON_CLK
                select CLKSRC_MIPS_GIC
                select HW_HAS_PCI
index ea8be569421729291af9148b54ee947ba2c2a691..60c000b4b3d46b670ba0ed41dacff79ad6809a59 100644 (file)
@@ -69,7 +69,7 @@
        void __iomem *sysc = (void __iomem *) KSEG1ADDR(MT7621_SYSC_BASE);
 --- a/arch/mips/ralink/Kconfig
 +++ b/arch/mips/ralink/Kconfig
-@@ -58,6 +58,7 @@ choice
+@@ -59,6 +59,7 @@ choice
                select CLKSRC_MIPS_GIC
                select HW_HAS_PCI
                select WEAK_REORDERING_BEYOND_LLSC