6in4: - add log entries for update operations - always update tunnel, even if wan...
authorJo-Philipp Wich <jow@openwrt.org>
Tue, 19 Oct 2010 02:07:29 +0000 (02:07 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Tue, 19 Oct 2010 02:07:29 +0000 (02:07 +0000)
SVN-Revision: 23528

package/6in4/Makefile
package/6in4/files/6in4.hotplug

index 1f0573b97ad4b61bd90d5df766cf2a96e1f12ba2..d03d2396ffa38fb6d21ee91b04b50eda47d11f63 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=6in4
-PKG_VERSION:=6
+PKG_VERSION:=7
 PKG_RELEASE:=1
 
 include $(INCLUDE_DIR)/package.mk
index 534682e99a152ca600e2d734c1da654d335a4437..9499296d92c21cad53258a59b41f36f24faa5643 100644 (file)
@@ -17,11 +17,9 @@ if [ "$ACTION" = ifup ]; then
                config_get wandev "$cfg" wan_device "$(find_6in4_wanif)"
                [ "$wandev" = "$DEVICE" ] || return 0
 
-               local oldip
                local wanip=$(find_6in4_wanip "$wandev")
-               config_get oldip "$cfg" ipaddr
 
-               [ -n "$wanip" ] && [ "$oldip" != "$wanip" ] && {
+               [ -n "$wanip" ] && {
                        local tunnelid
                        config_get tunnelid "$cfg" tunnelid
 
@@ -37,7 +35,22 @@ if [ "$ACTION" = ifup ]; then
                                }
                                uci_set_state network "$cfg" ipaddr "$wanip"
 
-                               ( wget -qO/dev/null "http://ipv4.tunnelbroker.net/ipv4_end.php?ipv4b=AUTO&user_id=$username&pass=$password&tunnel_id=$tunnelid" && ifup "$cfg" )&
+                               (
+                                       local url="http://ipv4.tunnelbroker.net/ipv4_end.php?ipv4b=AUTO&user_id=$username&pass=$password&tunnel_id=$tunnelid"
+                                       local try=0
+                                       local max=3
+
+                                       while [ $((++try)) -le $max ]; do
+                                               wget -qO/dev/null "$url" 2>/dev/null && {
+                                                       logger -t 6in4-update "Updated tunnel #$tunnelid endpoint to $wanip"
+                                                       ifup "$cfg"
+                                                       break
+                                               } || {
+                                                       logger -t 6in4-update "Try $try/$max failed, retrying"
+                                                       sleep 1
+                                               }
+                                       done
+                               )&
                        }
                }
        }