rules_mk: don't include wrapped bin with external toolchains
authorChristian Marangi <ansuelsmth@gmail.com>
Sun, 3 Jul 2022 00:06:21 +0000 (02:06 +0200)
committerChristian Marangi <ansuelsmth@gmail.com>
Sun, 4 Dec 2022 15:07:33 +0000 (16:07 +0100)
Don't add wrapped bin to the TARGET_PATH as it does cause compilation
error.

cmake.mk will use the "command -v" and will use the wrapped bin instead
of the external toolchain bin as they have the same name and command
will select the first result.

Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
(cherry picked from commit a90eabf60255773231ed0259e5da5eb6a36fe9ce)

rules.mk

index 7c83d90eda312b565a797ad29f36f8558dd0c5c4..9c694e17ceb351f5e83284f69614f764c1587ddc 100644 (file)
--- a/rules.mk
+++ b/rules.mk
@@ -212,7 +212,6 @@ ifndef DUMP
       ifneq ($(TOOLCHAIN_LIB_DIRS),)
         TARGET_LDFLAGS+= $(patsubst %,-L%,$(TOOLCHAIN_LIB_DIRS))
       endif
-      TARGET_PATH:=$(TOOLCHAIN_DIR)/bin:$(TARGET_PATH)
     endif
   endif
 endif