ar71xx: add profile and build image for the WNR612 v2 board
authorGabor Juhos <juhosg@openwrt.org>
Sun, 28 Jul 2013 10:23:38 +0000 (10:23 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Sun, 28 Jul 2013 10:23:38 +0000 (10:23 +0000)
Signed-off-by: Cezary Jackiewicz <cezary.jackiewicz@gmail.com>
Patchwork: http://patchwork.openwrt.org/patch/3876/
Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
SVN-Revision: 37577

target/linux/ar71xx/generic/profiles/netgear.mk
target/linux/ar71xx/image/Makefile

index 15a20813d078786cd1792c76da4c424ed17bba68..99425ec106de6ca4a3785f0b197bb9b8ae66600d 100644 (file)
@@ -50,3 +50,13 @@ endef
 
 $(eval $(call Profile,WNR2000V3))
 
 
 $(eval $(call Profile,WNR2000V3))
 
+
+define Profile/WNR612V2
+       NAME:=NETGEAR WNR612V2
+endef
+
+define Profile/WNR612V2/Description
+       Package set optimized for the NETGEAR WNR612V2
+endef
+
+$(eval $(call Profile,WNR612V2))
index 4b7da17b47d2a099d857e5cc7c17e320100c618d..a9f1f9e5a02b0528328be1e552e8ef50b4f6d657 100644 (file)
@@ -922,6 +922,7 @@ $(eval $(call SingleProfile,MyLoader,$(fs_64k),WPE72_16M,wpe72,,ttyS0,115200,0x1
 # This is used with AthGzip profile for now
 $(eval $(call SingleProfile,AthGzip,$(fs_64k),WNDAP360,wndap360,WNDAP360,ttyS0,9600,$$(wndap360_mtdlayout),1769472,6160384,KRuImage))
 $(eval $(call SingleProfile,Netgear,$(fs_64k),WNR2000V3,wnr2000v3,WNR2000V3,ttyS0,115200,$$(wnr2000v3_mtdlayout),2003,WNR2000V3,"" NA,))
 # This is used with AthGzip profile for now
 $(eval $(call SingleProfile,AthGzip,$(fs_64k),WNDAP360,wndap360,WNDAP360,ttyS0,9600,$$(wndap360_mtdlayout),1769472,6160384,KRuImage))
 $(eval $(call SingleProfile,Netgear,$(fs_64k),WNR2000V3,wnr2000v3,WNR2000V3,ttyS0,115200,$$(wnr2000v3_mtdlayout),2003,WNR2000V3,"" NA,))
+$(eval $(call SingleProfile,Netgear,$(fs_64k),WNR612V2,wnr612v2,WNR612V2,ttyS0,115200,$$(wnr2000v3_mtdlayout),2061,WNR612V2,"",))
 $(eval $(call SingleProfile,Netgear,$(fs_64k),WNDR3700V1,wndr3700,WNDR3700,ttyS0,115200,$$(wndr3700_mtdlayout),3700,WNDR3700,"" NA,))
 $(eval $(call SingleProfile,Netgear,$(fs_64k),WNDR3700V2,wndr3700v2,WNDR3700,ttyS0,115200,$$(wndr3700v2_mtdlayout),3701,WNDR3700v2,"",-H 29763654+16+64))
 $(eval $(call SingleProfile,Netgear,$(fs_64k),WNDR3800,wndr3800,WNDR3700,ttyS0,115200,$$(wndr3700v2_mtdlayout),3701,WNDR3800,"",-H 29763654+16+128))
 $(eval $(call SingleProfile,Netgear,$(fs_64k),WNDR3700V1,wndr3700,WNDR3700,ttyS0,115200,$$(wndr3700_mtdlayout),3700,WNDR3700,"" NA,))
 $(eval $(call SingleProfile,Netgear,$(fs_64k),WNDR3700V2,wndr3700v2,WNDR3700,ttyS0,115200,$$(wndr3700v2_mtdlayout),3701,WNDR3700v2,"",-H 29763654+16+64))
 $(eval $(call SingleProfile,Netgear,$(fs_64k),WNDR3800,wndr3800,WNDR3700,ttyS0,115200,$$(wndr3700v2_mtdlayout),3701,WNDR3800,"",-H 29763654+16+128))