gpiodev should be in drivers/char, not in drivers/gpio..
authorImre Kaloz <kaloz@openwrt.org>
Fri, 30 May 2008 10:20:36 +0000 (10:20 +0000)
committerImre Kaloz <kaloz@openwrt.org>
Fri, 30 May 2008 10:20:36 +0000 (10:20 +0000)
SVN-Revision: 11294

target/linux/generic-2.6/files-2.6.25/drivers/char/gpio_dev.c [new file with mode: 0644]
target/linux/generic-2.6/files-2.6.25/drivers/gpio/gpio_dev.c [deleted file]
target/linux/generic-2.6/patches-2.6.25/420-gpiodev.patch

diff --git a/target/linux/generic-2.6/files-2.6.25/drivers/char/gpio_dev.c b/target/linux/generic-2.6/files-2.6.25/drivers/char/gpio_dev.c
new file mode 100644 (file)
index 0000000..48ef76f
--- /dev/null
@@ -0,0 +1,201 @@
+/*
+ * character device wrapper for generic gpio layer
+ *
+ * This program is free software; you can redistribute it and/or modify
+ * it under the terms of the GNU General Public License as published by
+ * the Free Software Foundation; either version 2 of the License, or
+ * (at your option) any later version.
+ *
+ * This program is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ * GNU General Public License for more details.
+ *
+ * You should have received a copy of the GNU General Public License
+ * along with this program; if not, write to the Free Software
+ * Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA02111-1307USA
+ *
+ * Feedback, Bugs...  blogic@openwrt.org
+ *
+ */
+
+#include <linux/module.h>
+#include <linux/errno.h>
+#include <linux/init.h>
+#include <asm/uaccess.h>
+#include <asm/io.h>
+#include <asm/gpio.h>
+#include <asm/atomic.h>
+#include <linux/init.h>
+#include <linux/genhd.h>
+#include <linux/device.h>
+#include <linux/platform_device.h>
+#include <linux/gpio_dev.h>
+
+#define DRVNAME                "gpiodev"
+#define DEVNAME                "gpio"
+
+static int dev_major;
+static unsigned int gpio_access_mask;
+static struct class *gpio_class;
+
+/* Counter is 1, if the device is not opened and zero (or less) if opened. */
+static atomic_t gpio_open_cnt = ATOMIC_INIT(1);
+
+static int
+gpio_ioctl(struct inode * inode, struct file * file, unsigned int cmd, unsigned long arg)
+{
+       int retval = 0;
+
+       if (((1 << arg) & gpio_access_mask) != (1 << arg))
+       {
+               retval = -EINVAL;
+               goto out;
+       }
+
+       switch (cmd)
+       {
+       case GPIO_GET:
+               retval = gpio_get_value(arg);
+               break;
+
+       case GPIO_SET:
+               gpio_set_value(arg, 1);
+               break;
+
+       case GPIO_CLEAR:
+               gpio_set_value(arg, 0);
+               break;
+
+       case GPIO_DIR_IN:
+               gpio_direction_input(arg);
+               break;
+
+       case GPIO_DIR_OUT:
+               gpio_direction_output(arg, 0);
+               break;
+
+       default:
+               retval = -EINVAL;
+               break;
+       }
+
+out:
+       return retval;
+}
+
+static int
+gpio_open(struct inode *inode, struct file *file)
+{
+       int result = 0;
+       unsigned int dev_minor = MINOR(inode->i_rdev);
+
+       if (dev_minor != 0)
+       {
+               printk(KERN_ERR DRVNAME ": trying to access unknown minor device -> %d\n", dev_minor);
+               result = -ENODEV;
+               goto out;
+       }
+
+       /* FIXME: We should really allow multiple applications to open the device
+        *        at the same time, as long as the apps access different IO pins.
+        *        The generic gpio-registration functions can be used for that.
+        *        Two new IOCTLs have to be introduced for that. Need to check userspace
+        *        compatibility first. --mb */
+       if (!atomic_dec_and_test(&gpio_open_cnt)) {
+               atomic_inc(&gpio_open_cnt);
+               printk(KERN_ERR DRVNAME ": Device with minor ID %d already in use\n", dev_minor);
+               result = -EBUSY;
+               goto out;
+       }
+
+out:
+       return result;
+}
+
+static int
+gpio_close(struct inode * inode, struct file * file)
+{
+       smp_mb__before_atomic_inc();
+       atomic_inc(&gpio_open_cnt);
+
+       return 0;
+}
+
+struct file_operations gpio_fops = {
+       ioctl:          gpio_ioctl,
+       open:           gpio_open,
+       release:        gpio_close
+};
+
+static int
+gpio_probe(struct platform_device *dev)
+{
+       int result = 0;
+
+       dev_major = register_chrdev(0, DEVNAME, &gpio_fops);
+       if (!dev_major)
+       {
+               printk(KERN_ERR DRVNAME ": Error whilst opening %s \n", DEVNAME);
+               result = -ENODEV;
+               goto out;
+       }
+
+       gpio_class = class_create(THIS_MODULE, DEVNAME);
+       class_device_create(gpio_class, NULL, MKDEV(dev_major, 0), NULL, DEVNAME);
+
+       printk(KERN_INFO DRVNAME ": gpio device registered with major %d\n", dev_major);
+
+       if (dev->num_resources != 1)
+       {
+               printk(KERN_ERR DRVNAME ": device may only have 1 resource\n");
+               result = -ENODEV;
+               goto out;
+       }
+
+       gpio_access_mask = dev->resource[0].start;
+
+       printk(KERN_INFO DRVNAME ": gpio platform device registered with access mask %08X\n", gpio_access_mask);
+out:
+       return result;
+}
+
+static int
+gpio_remove(struct platform_device *dev)
+{
+       unregister_chrdev(dev_major, DEVNAME);
+       return 0;
+}
+
+static struct
+platform_driver gpio_driver = {
+       .probe = gpio_probe,
+       .remove = gpio_remove,
+       .driver = {
+               .name = "GPIODEV",
+               .owner = THIS_MODULE,
+       },
+};
+
+static int __init
+gpio_mod_init(void)
+{
+       int ret = platform_driver_register(&gpio_driver);
+       if (ret)
+               printk(KERN_INFO DRVNAME ": Error registering platfom driver!");
+
+       return ret;
+}
+
+static void __exit
+gpio_mod_exit(void)
+{
+       platform_driver_unregister(&gpio_driver);
+}
+
+module_init (gpio_mod_init);
+module_exit (gpio_mod_exit);
+
+MODULE_LICENSE("GPL");
+MODULE_AUTHOR("John Crispin / OpenWrt");
+MODULE_DESCRIPTION("Character device for for generic gpio api");
diff --git a/target/linux/generic-2.6/files-2.6.25/drivers/gpio/gpio_dev.c b/target/linux/generic-2.6/files-2.6.25/drivers/gpio/gpio_dev.c
deleted file mode 100644 (file)
index 48ef76f..0000000
+++ /dev/null
@@ -1,201 +0,0 @@
-/*
- * character device wrapper for generic gpio layer
- *
- * This program is free software; you can redistribute it and/or modify
- * it under the terms of the GNU General Public License as published by
- * the Free Software Foundation; either version 2 of the License, or
- * (at your option) any later version.
- *
- * This program is distributed in the hope that it will be useful,
- * but WITHOUT ANY WARRANTY; without even the implied warranty of
- * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
- * GNU General Public License for more details.
- *
- * You should have received a copy of the GNU General Public License
- * along with this program; if not, write to the Free Software
- * Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA02111-1307USA
- *
- * Feedback, Bugs...  blogic@openwrt.org
- *
- */
-
-#include <linux/module.h>
-#include <linux/errno.h>
-#include <linux/init.h>
-#include <asm/uaccess.h>
-#include <asm/io.h>
-#include <asm/gpio.h>
-#include <asm/atomic.h>
-#include <linux/init.h>
-#include <linux/genhd.h>
-#include <linux/device.h>
-#include <linux/platform_device.h>
-#include <linux/gpio_dev.h>
-
-#define DRVNAME                "gpiodev"
-#define DEVNAME                "gpio"
-
-static int dev_major;
-static unsigned int gpio_access_mask;
-static struct class *gpio_class;
-
-/* Counter is 1, if the device is not opened and zero (or less) if opened. */
-static atomic_t gpio_open_cnt = ATOMIC_INIT(1);
-
-static int
-gpio_ioctl(struct inode * inode, struct file * file, unsigned int cmd, unsigned long arg)
-{
-       int retval = 0;
-
-       if (((1 << arg) & gpio_access_mask) != (1 << arg))
-       {
-               retval = -EINVAL;
-               goto out;
-       }
-
-       switch (cmd)
-       {
-       case GPIO_GET:
-               retval = gpio_get_value(arg);
-               break;
-
-       case GPIO_SET:
-               gpio_set_value(arg, 1);
-               break;
-
-       case GPIO_CLEAR:
-               gpio_set_value(arg, 0);
-               break;
-
-       case GPIO_DIR_IN:
-               gpio_direction_input(arg);
-               break;
-
-       case GPIO_DIR_OUT:
-               gpio_direction_output(arg, 0);
-               break;
-
-       default:
-               retval = -EINVAL;
-               break;
-       }
-
-out:
-       return retval;
-}
-
-static int
-gpio_open(struct inode *inode, struct file *file)
-{
-       int result = 0;
-       unsigned int dev_minor = MINOR(inode->i_rdev);
-
-       if (dev_minor != 0)
-       {
-               printk(KERN_ERR DRVNAME ": trying to access unknown minor device -> %d\n", dev_minor);
-               result = -ENODEV;
-               goto out;
-       }
-
-       /* FIXME: We should really allow multiple applications to open the device
-        *        at the same time, as long as the apps access different IO pins.
-        *        The generic gpio-registration functions can be used for that.
-        *        Two new IOCTLs have to be introduced for that. Need to check userspace
-        *        compatibility first. --mb */
-       if (!atomic_dec_and_test(&gpio_open_cnt)) {
-               atomic_inc(&gpio_open_cnt);
-               printk(KERN_ERR DRVNAME ": Device with minor ID %d already in use\n", dev_minor);
-               result = -EBUSY;
-               goto out;
-       }
-
-out:
-       return result;
-}
-
-static int
-gpio_close(struct inode * inode, struct file * file)
-{
-       smp_mb__before_atomic_inc();
-       atomic_inc(&gpio_open_cnt);
-
-       return 0;
-}
-
-struct file_operations gpio_fops = {
-       ioctl:          gpio_ioctl,
-       open:           gpio_open,
-       release:        gpio_close
-};
-
-static int
-gpio_probe(struct platform_device *dev)
-{
-       int result = 0;
-
-       dev_major = register_chrdev(0, DEVNAME, &gpio_fops);
-       if (!dev_major)
-       {
-               printk(KERN_ERR DRVNAME ": Error whilst opening %s \n", DEVNAME);
-               result = -ENODEV;
-               goto out;
-       }
-
-       gpio_class = class_create(THIS_MODULE, DEVNAME);
-       class_device_create(gpio_class, NULL, MKDEV(dev_major, 0), NULL, DEVNAME);
-
-       printk(KERN_INFO DRVNAME ": gpio device registered with major %d\n", dev_major);
-
-       if (dev->num_resources != 1)
-       {
-               printk(KERN_ERR DRVNAME ": device may only have 1 resource\n");
-               result = -ENODEV;
-               goto out;
-       }
-
-       gpio_access_mask = dev->resource[0].start;
-
-       printk(KERN_INFO DRVNAME ": gpio platform device registered with access mask %08X\n", gpio_access_mask);
-out:
-       return result;
-}
-
-static int
-gpio_remove(struct platform_device *dev)
-{
-       unregister_chrdev(dev_major, DEVNAME);
-       return 0;
-}
-
-static struct
-platform_driver gpio_driver = {
-       .probe = gpio_probe,
-       .remove = gpio_remove,
-       .driver = {
-               .name = "GPIODEV",
-               .owner = THIS_MODULE,
-       },
-};
-
-static int __init
-gpio_mod_init(void)
-{
-       int ret = platform_driver_register(&gpio_driver);
-       if (ret)
-               printk(KERN_INFO DRVNAME ": Error registering platfom driver!");
-
-       return ret;
-}
-
-static void __exit
-gpio_mod_exit(void)
-{
-       platform_driver_unregister(&gpio_driver);
-}
-
-module_init (gpio_mod_init);
-module_exit (gpio_mod_exit);
-
-MODULE_LICENSE("GPL");
-MODULE_AUTHOR("John Crispin / OpenWrt");
-MODULE_DESCRIPTION("Character device for for generic gpio api");
index 215fc533444a731abafdb932dd99f2adc2af0bb0..ea7c244557ebe31135c2ffc3a9afdbc564e73400 100644 (file)
@@ -1,10 +1,9 @@
-Index: linux-2.6.25.4/drivers/gpio/Kconfig
-===================================================================
---- linux-2.6.25.4.orig/drivers/gpio/Kconfig
-+++ linux-2.6.25.4/drivers/gpio/Kconfig
-@@ -2,6 +2,13 @@
- # GPIO infrastructure and expanders
- #
+diff -Nur linux-2.6.25/drivers/char/Kconfig linux-2.6.25-owrt/drivers/char/Kconfig
+--- linux-2.6.25/drivers/char/Kconfig  2008-05-15 17:00:12.000000000 +0200
++++ linux-2.6.25-owrt/drivers/char/Kconfig     2008-05-30 11:58:39.000000000 +0200
+@@ -955,6 +955,13 @@
+         If compiled as a module, it will be called cs5535_gpio.
  
 +config GPIO_DEVICE
 +      tristate "GPIO device support"
@@ -13,15 +12,17 @@ Index: linux-2.6.25.4/drivers/gpio/Kconfig
 +        Say Y to enable Linux GPIO device support.  This allows control of
 +        GPIO pins using a character device
 +
- config HAVE_GPIO_LIB
-       bool
-       help
-Index: linux-2.6.25.4/drivers/gpio/Makefile
-===================================================================
---- linux-2.6.25.4.orig/drivers/gpio/Makefile
-+++ linux-2.6.25.4/drivers/gpio/Makefile
-@@ -7,3 +7,4 @@ obj-$(CONFIG_HAVE_GPIO_LIB)    += gpiolib.o
- obj-$(CONFIG_GPIO_MCP23S08)   += mcp23s08.o
- obj-$(CONFIG_GPIO_PCA953X)    += pca953x.o
- obj-$(CONFIG_GPIO_PCF857X)    += pcf857x.o
+ config GPIO_VR41XX
+       tristate "NEC VR4100 series General-purpose I/O Unit support"
+       depends on CPU_VR41XX
+diff -Nur linux-2.6.25/drivers/char/Makefile linux-2.6.25-owrt/drivers/char/Makefile
+--- linux-2.6.25/drivers/char/Makefile 2008-05-15 17:00:12.000000000 +0200
++++ linux-2.6.25-owrt/drivers/char/Makefile    2008-05-30 11:57:33.000000000 +0200
+@@ -94,6 +94,7 @@
+ obj-$(CONFIG_PC8736x_GPIO)    += pc8736x_gpio.o
+ obj-$(CONFIG_NSC_GPIO)                += nsc_gpio.o
+ obj-$(CONFIG_CS5535_GPIO)     += cs5535_gpio.o
 +obj-$(CONFIG_GPIO_DEVICE)     += gpio_dev.o
+ obj-$(CONFIG_GPIO_VR41XX)     += vr41xx_giu.o
+ obj-$(CONFIG_GPIO_TB0219)     += tb0219.o
+ obj-$(CONFIG_TELCLOCK)                += tlclk.o