samba36: Disable external libtdb and libtevent
authorRosen Penev <rosenp@gmail.com>
Sun, 1 Jul 2018 00:02:52 +0000 (17:02 -0700)
committerJo-Philipp Wich <jo@mein.io>
Tue, 18 Dec 2018 08:44:02 +0000 (09:44 +0100)
This was causing issues recently as samba36 is not API compatible with the
libtdb in the packages repo. It shouldn't be using it anyway. Nor tevent.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
(backported from 1f2612a4ddbb83af0c6daf3719ab74c3b7db6590)

package/network/services/samba36/Makefile

index 39bfcc6..75705d0 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=samba
 PKG_VERSION:=3.6.25
-PKG_RELEASE:=10
+PKG_RELEASE:=11
 
 PKG_SOURCE_URL:=https://download.samba.org/pub/samba \
                https://download.samba.org/pub/samba/stable
@@ -108,6 +108,8 @@ CONFIGURE_ARGS += \
        --disable-avahi \
        --disable-cups \
        --disable-external-libtalloc \
+       --disable-external-libtdb \
+       --disable-external-libtevent \
        --disable-pie \
        --disable-relro \
        --disable-static \