Add vncrepeater, with uClibc++ linking, needs therefore testing
authorFlorian Fainelli <florian@openwrt.org>
Mon, 10 Apr 2006 14:42:25 +0000 (14:42 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Mon, 10 Apr 2006 14:42:25 +0000 (14:42 +0000)
SVN-Revision: 3605

openwrt/package/Config.in
openwrt/package/Makefile
openwrt/package/depend.mk
openwrt/package/vncrepeater/Config.in [new file with mode: 0644]
openwrt/package/vncrepeater/Makefile [new file with mode: 0644]
openwrt/package/vncrepeater/ipkg/vncrepeater.control [new file with mode: 0644]
openwrt/package/vncrepeater/patches/01-uclibcxx_linking.patch [new file with mode: 0644]

index 619578024e360fac87185791353c00b646021854..05e7da6385725c785a50e13494881b7d4b797748 100644 (file)
@@ -172,6 +172,7 @@ source "package/udp-broadcast-relay/Config.in"
 source "package/ulogd/Config.in"
 source "package/updatedd/Config.in"
 source "package/vgp/Config.in"
+source "package/vncrepeater/Config.in"
 source "package/vnc-reflector/Config.in"
 source "package/vnstat/Config.in"
 source "package/vpnc/Config.in"
index fa78d4ad110a0e4a68b9cf8b1229917d5557d598..0004c0e4cb78ccd7c3c36ebc9fb03f5ebe555b46 100644 (file)
@@ -260,6 +260,7 @@ package-$(BR2_COMPILE_UTIL_LINUX) += util-linux
 package-$(BR2_PACKAGE_UDEV) += udev
 package-$(BR2_PACKAGE_VIM) += vim
 package-$(BR2_PACKAGE_VGP) += vgp
+package-$(BR2_PACKAGE_VNCREPEATER) += vncrepeater
 package-$(BR2_PACKAGE_VNC_REFLECTOR) += vnc-reflector
 package-$(BR2_PACKAGE_VNSTAT) += vnstat
 package-$(BR2_PACKAGE_VPNC) += vpnc
index 6ed55179bd4bad48e00428acd446baf5f4bdee88..8e4eb567171a69d7a1b29e6a5556f0918e19ad74 100644 (file)
@@ -102,6 +102,7 @@ tinc-compile: zlib-compile openssl-compile liblzo-compile
 tor-compile: libevent-compile openssl-compile zlib-compile
 usbutils-compile: libusb-compile
 vim-compile: ncurses-compile
+vncrepeater-compile: uclibc++-compile
 vnc-reflector-compile: jpeg-compile zlib-compile
 vpnc-compile: libgcrypt-compile libgpg-error-compile
 vtun-compile: zlib-compile openssl-compile liblzo-compile
diff --git a/openwrt/package/vncrepeater/Config.in b/openwrt/package/vncrepeater/Config.in
new file mode 100644 (file)
index 0000000..418f485
--- /dev/null
@@ -0,0 +1,17 @@
+config BR2_PACKAGE_VNCREPEATER
+       prompt "vncrepeater....................... UltraVNC repeater for Linux"
+       tristate
+       default m if CONFIG_DEVEL
+       select BR2_PACKAGE_UCLIBCXX
+       help
+         Viewer can be behind Nat router or directly connected to the internet
+
+         Instead of forwarding serveral ports, you only need to forward 1 port
+
+         If the PC that runs the Repeater has access to the local DNS server, 
+         you can use your local DNS names instead of 10.10.10.12.
+
+         This could be handy when you have a dynamic DHCP server allocating 
+         ip adresses for your PC.
+
+         http://ultravnc.sourceforge.net/addons/repeater.html
diff --git a/openwrt/package/vncrepeater/Makefile b/openwrt/package/vncrepeater/Makefile
new file mode 100644 (file)
index 0000000..52b2420
--- /dev/null
@@ -0,0 +1,39 @@
+# $Id: Makefile 3112 2006-02-01 23:53:19Z mbm $
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=vncrepeater
+PKG_VERSION:=0.007
+PKG_RELEASE:=1
+PKG_MD5SUM:=7e13b0b784d683473d418f7295aff500
+
+PKG_SOURCE_URL:=http://downloads.openwrt.org
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_CAT:=zcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+include $(TOPDIR)/package/rules.mk
+
+$(eval $(call PKG_template,VNCREPEATER,$(PKG_NAME),$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+
+$(PKG_BUILD_DIR)/.configured:
+       touch $@
+
+$(PKG_BUILD_DIR)/.built:
+       rm -rf $(PKG_INSTALL_DIR)
+       mkdir -p $(PKG_INSTALL_DIR)
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               CC=$(TARGET_CC) \
+               CFLAGS="$(TARGET_CFLAGS)" \
+               DESTDIR="$(PKG_INSTALL_DIR)" \
+               repeater
+       touch $@
+
+$(IPKG_VNCREPEATER):
+       install -d -m0755 $(IDIR_VNCREPEATER)/usr/sbin
+       $(CP) $(PKG_BUILD_DIR)/repeater $(IDIR_VNCREPEATER)/usr/sbin/$(PKG_NAME)
+       $(RSTRIP) $(IDIR_VNCREPEATER)
+       $(IPKG_BUILD) $(IDIR_VNCREPEATER) $(PACKAGE_DIR)
+
diff --git a/openwrt/package/vncrepeater/ipkg/vncrepeater.control b/openwrt/package/vncrepeater/ipkg/vncrepeater.control
new file mode 100644 (file)
index 0000000..3996c86
--- /dev/null
@@ -0,0 +1,5 @@
+Package: vncrepeater
+Section: net
+Depends: uclibc++
+Priority: optional
+Description: UltraVNC repeater for Linux
diff --git a/openwrt/package/vncrepeater/patches/01-uclibcxx_linking.patch b/openwrt/package/vncrepeater/patches/01-uclibcxx_linking.patch
new file mode 100644 (file)
index 0000000..7df92a0
--- /dev/null
@@ -0,0 +1,23 @@
+diff -urN vncrepeater-0.007/Makefile vncrepeater-0.007.new/Makefile
+--- vncrepeater-0.007/Makefile 2005-10-03 20:22:48.000000000 +0200
++++ vncrepeater-0.007.new/Makefile     2006-04-10 16:15:50.495599944 +0200
+@@ -1,15 +1,15 @@
+ CFLAGS=-Wall
+ repeater: repeater.o repeaterproc.o openbsd_stringfuncs.o
+-      g++ $(CFLAGS) -o repeater repeater.o repeaterproc.o openbsd_stringfuncs.o
++      $(CC) $(CFLAGS) -o repeater repeater.o repeaterproc.o openbsd_stringfuncs.o -nodefaultlibs -L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib -luClibc++
+ repeater.o: repeater.cpp
+-      g++ $(CFLAGS) -c repeater.cpp
++      $(CC) $(CFLAGS) -c repeater.cpp
+ repeaterproc.o: repeaterproc.cpp
+-      g++ $(CFLAGS) -c repeaterproc.cpp
++      $(CC) $(CFLAGS) -c repeaterproc.cpp
+ openbsd_stringfuncs.o: openbsd_stringfuncs.cpp
+-      g++ $(CFLAGS) -c openbsd_stringfuncs.cpp
++      $(CC) $(CFLAGS) -c openbsd_stringfuncs.cpp
+ clean:
+       rm -f *.o repeater