create generic subtarget
authorFlorian Fainelli <florian@openwrt.org>
Sun, 11 Nov 2012 16:11:29 +0000 (16:11 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sun, 11 Nov 2012 16:11:29 +0000 (16:11 +0000)
Signed-off-by: Daniel Golle <dgolle@allnet.de>
Signed-off-by: Florian Fainelli <florian@openwrt.org>
SVN-Revision: 34147

12 files changed:
target/linux/ar7/Makefile
target/linux/ar7/config-3.3
target/linux/ar7/generic/config-default [new file with mode: 0644]
target/linux/ar7/generic/profiles/100-Annex-A.mk [new file with mode: 0644]
target/linux/ar7/generic/profiles/110-Annex-B.mk [new file with mode: 0644]
target/linux/ar7/generic/profiles/200-Texas.mk [new file with mode: 0644]
target/linux/ar7/generic/profiles/210-None.mk [new file with mode: 0644]
target/linux/ar7/generic/target.mk [new file with mode: 0644]
target/linux/ar7/profiles/100-Annex-A.mk [deleted file]
target/linux/ar7/profiles/110-Annex-B.mk [deleted file]
target/linux/ar7/profiles/200-Texas.mk [deleted file]
target/linux/ar7/profiles/210-None.mk [deleted file]

index da3e252440b35ee4abe2312a394c366ffdf3705c..ead26d99659292d038aaab0623e0ab917ead0d68 100644 (file)
@@ -11,6 +11,7 @@ BOARD:=ar7
 BOARDNAME:=TI AR7
 FEATURES:=squashfs jffs2 atm
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
+SUBTARGETS:=generic ac49x
 
 LINUX_VERSION:=3.3.8
 
index 8ff39e2c916ef32729ec2ef3458e92eb488c3b41..db264031f5c51df869f3073bf427daf4fb50735f 100644 (file)
@@ -75,7 +75,6 @@ CONFIG_MIPS=y
 CONFIG_MIPS_L1_CACHE_SHIFT=5
 # CONFIG_MIPS_MACHINE is not set
 CONFIG_MIPS_MT_DISABLED=y
-CONFIG_MTD_AR7_PARTS=y
 CONFIG_MTD_CFI_STAA=y
 CONFIG_MTD_PHYSMAP=y
 CONFIG_MVSWITCH_PHY=y
diff --git a/target/linux/ar7/generic/config-default b/target/linux/ar7/generic/config-default
new file mode 100644 (file)
index 0000000..b3b9a93
--- /dev/null
@@ -0,0 +1,6 @@
+# CONFIG_AR7_AC49X is not set
+CONFIG_AR7_TI=y
+# CONFIG_AR7_TYPE_AC49X is not set
+CONFIG_AR7_TYPE_TI=y
+# CONFIG_MTD_AC49X_PARTS is not set
+CONFIG_MTD_AR7_PARTS=y
diff --git a/target/linux/ar7/generic/profiles/100-Annex-A.mk b/target/linux/ar7/generic/profiles/100-Annex-A.mk
new file mode 100644 (file)
index 0000000..3d74b5d
--- /dev/null
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Annex-A
+  NAME:=Annex-A DSL firmware (default)
+  PACKAGES:=kmod-sangam-atm-annex-a
+endef
+
+define Profile/Annex-A/Description
+       Package set compatible with Annex-A DSL lines (most countries).
+endef
+$(eval $(call Profile,Annex-A))
+
diff --git a/target/linux/ar7/generic/profiles/110-Annex-B.mk b/target/linux/ar7/generic/profiles/110-Annex-B.mk
new file mode 100644 (file)
index 0000000..66692e7
--- /dev/null
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Annex-B
+  NAME:=Annex-B DSL firmware
+  PACKAGES:=kmod-sangam-atm-annex-b
+endef
+
+define Profile/Annex-B/Description
+       Package set compatible with Annex-B DSL lines (Germany).
+endef
+$(eval $(call Profile,Annex-B))
+
diff --git a/target/linux/ar7/generic/profiles/200-Texas.mk b/target/linux/ar7/generic/profiles/200-Texas.mk
new file mode 100644 (file)
index 0000000..7d868bd
--- /dev/null
@@ -0,0 +1,18 @@
+#
+# Copyright (C) 2006-2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Texas
+  NAME:=Texas Instruments WiFi (mac80211)
+  PACKAGES:=kmod-acx-mac80211
+endef
+
+define Profile/Texas/Description
+       Package set compatible with hardware using Texas Instruments WiFi cards
+       using the mac80211 driver.
+endef
+$(eval $(call Profile,Texas))
+
diff --git a/target/linux/ar7/generic/profiles/210-None.mk b/target/linux/ar7/generic/profiles/210-None.mk
new file mode 100644 (file)
index 0000000..2fcfacd
--- /dev/null
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/None
+  NAME:=No WiFi
+  PACKAGES:=
+endef
+
+define Profile/None/Description
+       Package set without WiFi support
+endef
+$(eval $(call Profile,None))
+
diff --git a/target/linux/ar7/generic/target.mk b/target/linux/ar7/generic/target.mk
new file mode 100644 (file)
index 0000000..1595c1a
--- /dev/null
@@ -0,0 +1,10 @@
+#
+# Copyright (C) 2012 OpenWrt.org
+#
+
+SUBTARGET:=generic
+BOARDNAME:=Texas Instruments AR7 boards
+
+define Target/Description
+       Build firmware images for TI AR7 based routers.
+endef
diff --git a/target/linux/ar7/profiles/100-Annex-A.mk b/target/linux/ar7/profiles/100-Annex-A.mk
deleted file mode 100644 (file)
index 3d74b5d..0000000
+++ /dev/null
@@ -1,17 +0,0 @@
-#
-# Copyright (C) 2009 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/Annex-A
-  NAME:=Annex-A DSL firmware (default)
-  PACKAGES:=kmod-sangam-atm-annex-a
-endef
-
-define Profile/Annex-A/Description
-       Package set compatible with Annex-A DSL lines (most countries).
-endef
-$(eval $(call Profile,Annex-A))
-
diff --git a/target/linux/ar7/profiles/110-Annex-B.mk b/target/linux/ar7/profiles/110-Annex-B.mk
deleted file mode 100644 (file)
index 66692e7..0000000
+++ /dev/null
@@ -1,17 +0,0 @@
-#
-# Copyright (C) 2009 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/Annex-B
-  NAME:=Annex-B DSL firmware
-  PACKAGES:=kmod-sangam-atm-annex-b
-endef
-
-define Profile/Annex-B/Description
-       Package set compatible with Annex-B DSL lines (Germany).
-endef
-$(eval $(call Profile,Annex-B))
-
diff --git a/target/linux/ar7/profiles/200-Texas.mk b/target/linux/ar7/profiles/200-Texas.mk
deleted file mode 100644 (file)
index 7d868bd..0000000
+++ /dev/null
@@ -1,18 +0,0 @@
-#
-# Copyright (C) 2006-2009 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/Texas
-  NAME:=Texas Instruments WiFi (mac80211)
-  PACKAGES:=kmod-acx-mac80211
-endef
-
-define Profile/Texas/Description
-       Package set compatible with hardware using Texas Instruments WiFi cards
-       using the mac80211 driver.
-endef
-$(eval $(call Profile,Texas))
-
diff --git a/target/linux/ar7/profiles/210-None.mk b/target/linux/ar7/profiles/210-None.mk
deleted file mode 100644 (file)
index 2fcfacd..0000000
+++ /dev/null
@@ -1,17 +0,0 @@
-#
-# Copyright (C) 2006 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/None
-  NAME:=No WiFi
-  PACKAGES:=
-endef
-
-define Profile/None/Description
-       Package set without WiFi support
-endef
-$(eval $(call Profile,None))
-