kernel: Added required dependencies for socket match.
authorOldřich Jedlička <oldium.pro@gmail.com>
Tue, 29 Jan 2019 21:25:33 +0000 (22:25 +0100)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 17 Feb 2019 18:22:39 +0000 (19:22 +0100)
This applies to kernel 4.10 and newer.

See https://github.com/torvalds/linux/commit/8db4c5be88f62ffd7a552f70687a10c614dc697b

The above commit added to kernel 4.10 added new dependency
for building the NETFILTER_XT_MATCH_SOCKET (xt_socket.ko)
module. The NF_SOCKET_IPVx options (both of them) need to
be enabled in order to build the NETFILTER_XT_MATCH_SOCKET
module. Without the change the module is not built.

Signed-off-by: Oldřich Jedlička <oldium.pro@gmail.com>
package/kernel/linux/modules/netfilter.mk

index ef8b5a33c14443d0e3abfd4d6f1d37f7be917ab0..6c78394297be189fea9f1215f71aad92584bdbef 100644 (file)
@@ -647,6 +647,8 @@ define KernelPackage/ipt-tproxy
   TITLE:=Transparent proxying support
   DEPENDS+=+kmod-ipt-conntrack +IPV6:kmod-nf-conntrack6 +IPV6:kmod-ip6tables
   KCONFIG:= \
+       CONFIG_NF_SOCKET_IPV4 \
+       CONFIG_NF_SOCKET_IPV6 \
        CONFIG_NETFILTER_XT_MATCH_SOCKET \
        CONFIG_NETFILTER_XT_TARGET_TPROXY
   FILES:= \