wprobe: mask as BROKEN on cris
authorNicolas Thill <nico@openwrt.org>
Tue, 22 Dec 2009 06:10:30 +0000 (06:10 +0000)
committerNicolas Thill <nico@openwrt.org>
Tue, 22 Dec 2009 06:10:30 +0000 (06:10 +0000)
SVN-Revision: 18883

package/wprobe/Makefile

index 786a39d124aa31c1f29b99eab4240ed7a961a705..85667b771b13b30d5caf93cbec5fb55959d94a16 100644 (file)
@@ -18,8 +18,12 @@ PKG_CONFIG_DEPENDS = \
 
 include $(INCLUDE_DIR)/package.mk
 
+# XXX: build failure on cris
+# wprobe-lib.c:145: error: 'packed' attribute ignored for field of type 'struct <anonymous>'
+# wprobe-lib.c:149: error: 'packed' attribute ignored for field of type 'struct <anonymous>'
+
 define Package/wprobe/Default
-  DEPENDS:=@LINUX_2_6 @(!(TARGET_ps3||TARGET_pxcab)||BROKEN)
+  DEPENDS:=@LINUX_2_6 @(!(TARGET_ps3||TARGET_pxcab||cris)||BROKEN)
 endef
 
 define KernelPackage/wprobe