config: remove options for including kernel/dtb in rootfs
authorFelix Fietkau <nbd@nbd.name>
Tue, 19 Jul 2016 15:01:28 +0000 (17:01 +0200)
committerFelix Fietkau <nbd@nbd.name>
Wed, 20 Jul 2016 08:13:50 +0000 (10:13 +0200)
These options were a big design flaw to begin with

Signed-off-by: Felix Fietkau <nbd@nbd.name>
config/Config-images.in

index f81931e47fa680065077bc94c8651c3a98f31a4f..c990b87605a429945d4ec4d87ac2158a89c30dc2 100644 (file)
@@ -271,45 +271,4 @@ menu "Target Images"
                  it will be mounted by PARTUUID which makes the kernel find the
                  appropriate disk automatically.
 
-
-       menuconfig TARGET_ROOTFS_INCLUDE_KERNEL
-               bool "Include kernel in root filesystem"
-               depends on TARGET_ROOTFS_UBIFS || TARGET_ROOTFS_EXT4FS
-               default n
-               help
-                 Include the kernel image in the rootfs. Typically, the image is placed
-                 below /boot.
-
-               config TARGET_ROOTFS_INCLUDE_UIMAGE
-                       bool "include uImage" if TARGET_ROOTFS_INCLUDE_KERNEL
-                       default y
-                       help
-                         This option might not apply to all targets. Make sure
-                         to check target/linux/<your_target>/image/Makefile to
-                         see if this option will have any effect.
-
-               config TARGET_ROOTFS_INCLUDE_ZIMAGE
-                       bool "include zImage" if TARGET_ROOTFS_INCLUDE_KERNEL
-                       default y
-                       help
-                         This option might not apply to all targets. Make sure
-                         to check target/linux/<your_target>/image/Makefile to
-                         see if this option will have any effect.
-
-               config TARGET_ROOTFS_INCLUDE_FIT
-                       bool "include FIT" if TARGET_ROOTFS_INCLUDE_KERNEL
-                       default y
-                       help
-                         This option might not apply to all targets. Make sure
-                         to check target/linux/<your_target>/image/Makefile to
-                         see if this option will have any effect.
-
-       config TARGET_ROOTFS_INCLUDE_DTB
-               bool "Include DTB in root filesystem"
-               depends on USES_DEVICETREE && (TARGET_ROOTFS_UBIFS || TARGET_ROOTFS_EXT4FS)
-               default n
-               help
-                 Include the device tree blob file(s) in the rootfs. Typically the DTBs
-                 are placed below /boot.
-
 endmenu