ppp: add config options to tune discovery timeout and attempts
authorHans Dedecker <dedeckeh@gmail.com>
Wed, 29 May 2019 16:51:20 +0000 (18:51 +0200)
committerHans Dedecker <dedeckeh@gmail.com>
Fri, 31 May 2019 07:43:10 +0000 (09:43 +0200)
Upstream PPP project has added in commit 8e77984 options to tune discovery
timeout and attempts in the rp-pppoe plugin.

Expose these options in the uci datamodel for pppoe:
padi_attempts: Number of discovery attempts
padi_timeout: Initial timeout for discovery packets in seconds

Signed-off-by: Hans Dedecker <dedeckeh@gmail.com>
package/network/services/ppp/Makefile
package/network/services/ppp/files/ppp.sh

index 3b36444289bcad995fe94ce097d0af2e407dddef..c8016dc619470d42015cb04599522b2f3085ad8f 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=ppp
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=https://github.com/paulusmack/ppp
index 2d9ca6d284838a7575c0732b1d4c13435fe71b0b..b553effd889e7662f366793665c789ed0d0c0ff2 100755 (executable)
@@ -210,6 +210,9 @@ proto_pppoe_init_config() {
        proto_config_add_string "ac"
        proto_config_add_string "service"
        proto_config_add_string "host_uniq"
+       proto_config_add_int "padi_attempts"
+       proto_config_add_int "padi_timeout"
+
        lasterror=1
 }
 
@@ -227,12 +230,16 @@ proto_pppoe_setup() {
        json_get_var ac ac
        json_get_var service service
        json_get_var host_uniq host_uniq
+       json_get_var padi_attempts padi_attempts
+       json_get_var padi_timeout padi_timeout
 
        ppp_generic_setup "$config" \
                plugin rp-pppoe.so \
                ${ac:+rp_pppoe_ac "$ac"} \
                ${service:+rp_pppoe_service "$service"} \
                ${host_uniq:+host-uniq "$host_uniq"} \
+               ${padi_attempts:+pppoe-padi-attempts $padi_attempts} \
+               ${padi_timeout:+pppoe-padi-timeout $padi_timeout} \
                "nic-$iface"
 }