mvebu: cortexa9: correct cpu subtype
authorTomasz Maciej Nowak <tomek_n@o2.pl>
Wed, 18 Mar 2020 18:04:12 +0000 (19:04 +0100)
committerHauke Mehrtens <hauke@hauke-m.de>
Fri, 17 Apr 2020 22:18:13 +0000 (00:18 +0200)
Armada 370  processors have only 16 double-precision registers. The
change introduced by 8dcc1087602e ("toolchain: ARM: Fix toolchain
compilation for gcc 8.x") switched accidentally the toolchain for mvebu
cortexa9 subtarget to cpu type with 32 double-precision registers. This
stems from gcc defaults which assume "vfpv3-d32" if only "vfpv3" as mfpu
is specified. That change resulted in unusable image, in which kernel
will kill userspace as soon as it causing "Illegal instruction".

Ref: https://forum.openwrt.org/t/gcc-was-broken-on-mvebu-armada-370-device-after-commit-on-2019-03-25/43272
Fixes: 8dcc1087602e ("toolchain: ARM: Fix toolchain compilation for
gcc 8.x")
Signed-off-by: Tomasz Maciej Nowak <tomek_n@o2.pl>
(cherry picked from commit 2d61f8821c7cf99354e904139226c132554ba180)

target/linux/mvebu/cortexa9/target.mk

index 2a75599bc9a36a9aef7e37f9011409ac8a941249..cdd4d86e493668f455f6de6edb11cfc81e54f8af 100644 (file)
@@ -10,5 +10,5 @@ include $(TOPDIR)/rules.mk
 ARCH:=arm
 BOARDNAME:=Marvell Armada 37x/38x/XP
 CPU_TYPE:=cortex-a9
-CPU_SUBTYPE:=vfpv3
+CPU_SUBTYPE:=vfpv3-d16
 KERNELNAME:=zImage dtbs