ramips: add alternative device name for Wiflyer WF3526-P
authorShiji Yang <yangshiji66@qq.com>
Sun, 19 Feb 2023 01:06:32 +0000 (09:06 +0800)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 19 Feb 2023 17:37:55 +0000 (18:37 +0100)
Wiflyer WF3526-P and Zbtlink ZBT-WE1326 have the same circuit design.
Installing the misunderstading firmware of ZBT-WE3526 will cause Wi-Fi
not work due to allocate the wrong pcie port. Add alternative name to
help users easily build or download the correct firmware.

Signed-off-by: Shiji Yang <yangshiji66@qq.com>
target/linux/ramips/image/mt7621.mk

index d295f2f8c7d4a7000b16bb3e2a8170a43a16f0ec..28f6fef68173f02d1b81d79fc7440526f07a63fd 100644 (file)
@@ -2611,6 +2611,8 @@ define Device/zbtlink_zbt-we1326
   IMAGE_SIZE := 16064k
   DEVICE_VENDOR := Zbtlink
   DEVICE_MODEL := ZBT-WE1326
+  DEVICE_ALT0_VENDOR := Wiflyer
+  DEVICE_ALT0_MODEL := WF3526-P
   DEVICE_PACKAGES := kmod-mt7603 kmod-mt76x2 kmod-usb3 kmod-sdhci-mt7620
   SUPPORTED_DEVICES += zbt-we1326
 endef