drop support for eglibc version trunk/HEAD
authorMirko Vogt <mirko@openwrt.org>
Sat, 28 Apr 2012 20:47:48 +0000 (20:47 +0000)
committerMirko Vogt <mirko@openwrt.org>
Sat, 28 Apr 2012 20:47:48 +0000 (20:47 +0000)
When selecting a specific eglibc version, it comes with a specific SVN
revision that should not be modified as it (more or less) correspond to
a tagged release. This patch disable the possibility to select a specific
SVN revision on known eglib versions.

This patch also disables the possibility to select the trunk branch of
eglibc. There are multiple reasons for that:

* trunk/HEAD may not even compile

* the OpenWrt built system makes using trunk/HEAD a difficult thing, as
OpenWRT fetches the source tree and store it in a compressed tar archive.
Subsequent build get the source from the tar archive - not from SVN,
making the use of trunk/HEAD largelly innefective.

* we cannot know the corresponding version of trunk/HEAD, meaning that
we'll face compiling issues when we'll try to copy the libc files -
unless the build system is fixed with this specific issue in mind.

Signed-off-by: Emmanuel Deloget <logout@free.fr>
SVN-Revision: 31502

toolchain/eglibc/Config.in
toolchain/eglibc/Config.version
toolchain/eglibc/Makefile

index a8d3de6f5316eb39df825d5dc802d58daf6440b8..f7df171a55001388d57f1fdd336a3f5fc88d6225 100644 (file)
@@ -13,9 +13,6 @@ choice
                bool "eglibc 2.14"
                depends !GCC_VERSION_LLVM
 
                bool "eglibc 2.14"
                depends !GCC_VERSION_LLVM
 
-       config EGLIBC_VERSION_TRUNK
-               bool "eglibc trunk"
-
 endchoice
 
 config EGLIBC_REVISION
 endchoice
 
 config EGLIBC_REVISION
@@ -24,7 +21,6 @@ config EGLIBC_REVISION
        depends on TOOLCHAINOPTS && USE_EGLIBC
        default "15508" if EGLIBC_VERSION_2_13
        default "16488" if EGLIBC_VERSION_2_14
        depends on TOOLCHAINOPTS && USE_EGLIBC
        default "15508" if EGLIBC_VERSION_2_13
        default "16488" if EGLIBC_VERSION_2_14
-       default "HEAD"  if EGLIBC_VERSION_TRUNK
        default ""
 
 menu "eglibc configuration"
        default ""
 
 menu "eglibc configuration"
index b081cec538a6251091752a60c74c935785ee2caa..6f2e6a9a79bb7230d3275144f79e0b7776f79249 100644 (file)
@@ -1,6 +1,6 @@
 config EGLIBC_VERSION
        string
        depends on USE_EGLIBC
 config EGLIBC_VERSION
        string
        depends on USE_EGLIBC
-       default "2.13"   if EGLIBC_VERSION_2_13
-       default "2.14.1"   if EGLIBC_VERSION_2_14
-       default "trunk"
+       default "2.13" if EGLIBC_VERSION_2_13
+       default "2.14.1" if EGLIBC_VERSION_2_14
+       default "2.13"
index fbd9daa03310a946ae91171456ef82486959ccc0..5623fcbcb8e751d0f38e2cf8217b17f61cc8c408 100644 (file)
@@ -21,9 +21,6 @@ endif
 ifneq ($(CONFIG_EGLIBC_VERSION_2_14),)
   PKG_SOURCE_URL:=svn://svn.eglibc.org/branches/eglibc-2_14
 endif
 ifneq ($(CONFIG_EGLIBC_VERSION_2_14),)
   PKG_SOURCE_URL:=svn://svn.eglibc.org/branches/eglibc-2_14
 endif
-ifneq ($(CONFIG_EGLIBC_VERSION_TRUNK),)
-  PKG_SOURCE_URL:=svn://svn.eglibc.org/trunk
-endif
 
 PATCH_DIR:=./patches/$(PKG_VERSION)
 
 
 PATCH_DIR:=./patches/$(PKG_VERSION)