ar71xx/image: provide lzma compressed elf kernel image
authorGabor Juhos <juhosg@openwrt.org>
Tue, 20 Nov 2012 12:17:43 +0000 (12:17 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Tue, 20 Nov 2012 12:17:43 +0000 (12:17 +0000)
This will be used on the RB4xx/RB7xx/RB2011 boards.

Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
SVN-Revision: 34272

target/linux/ar71xx/image/Makefile

index dbda865ec61984af18302bcc4fc514d28ef94ab5..f4d66b97ccb6e070cdebe7f5cfb1015c931ec494 100644 (file)
@@ -192,6 +192,7 @@ define Image/BuildKernel
        dd if=$(KDIR)/vmlinux.bin.gz of=$(VMLINUX).gz bs=65536 conv=sync
        $(call MkuImage,gzip,,$(KDIR)/vmlinux.bin.gz,$(UIMAGE)-gzip.bin)
        $(call MkuImage,lzma,,$(KDIR)/vmlinux.bin.lzma,$(UIMAGE)-lzma.bin)
        dd if=$(KDIR)/vmlinux.bin.gz of=$(VMLINUX).gz bs=65536 conv=sync
        $(call MkuImage,gzip,,$(KDIR)/vmlinux.bin.gz,$(UIMAGE)-gzip.bin)
        $(call MkuImage,lzma,,$(KDIR)/vmlinux.bin.lzma,$(UIMAGE)-lzma.bin)
+       cp $(KDIR)/loader-generic.elf $(VMLINUX)-lzma.elf
        -mkdir -p $(KDIR_TMP)
        $(call Image/Build/Initramfs)
 endef
        -mkdir -p $(KDIR_TMP)
        $(call Image/Build/Initramfs)
 endef
@@ -945,6 +946,7 @@ endef
 define Image/Prepare
        gzip -9 -c $(KDIR)/vmlinux > $(KDIR)/vmlinux.bin.gz
        $(call CompressLzma,$(KDIR)/vmlinux,$(KDIR)/vmlinux.bin.lzma)
 define Image/Prepare
        gzip -9 -c $(KDIR)/vmlinux > $(KDIR)/vmlinux.bin.gz
        $(call CompressLzma,$(KDIR)/vmlinux,$(KDIR)/vmlinux.bin.lzma)
+       $(call Image/BuildLoader,generic,elf)
        $(call Image/Build/Profile/$(if $(CONFIG_IB),Default,$(PROFILE)),loader)
 endef
 
        $(call Image/Build/Profile/$(if $(CONFIG_IB),Default,$(PROFILE)),loader)
 endef