kernel: bump 4.19 to 4.19.95
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Tue, 14 Jan 2020 15:34:24 +0000 (16:34 +0100)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Mon, 20 Jan 2020 12:41:49 +0000 (13:41 +0100)
Refreshed all patches.

Compile-tested on: cns3xxx
Runtime-tested on: cns3xxx

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
15 files changed:
include/kernel-version.mk
target/linux/ath79/patches-4.19/910-unaligned_access_hacks.patch
target/linux/brcm2708/patches-4.19/950-0122-gpiolib-Don-t-prevent-IRQ-usage-of-output-GPIOs.patch
target/linux/brcm2708/patches-4.19/950-0127-net-lan78xx-Disable-TCP-Segmentation-Offload-TSO.patch
target/linux/brcm2708/patches-4.19/950-0261-lan78xx-Debounce-link-events-to-minimize-poll-storm.patch
target/linux/brcm2708/patches-4.19/950-0415-lan78xx-use-default-alignment-for-rx-buffers.patch
target/linux/brcm2708/patches-4.19/950-0429-Bluetooth-Check-key-sizes-only-when-Secure-Simple-Pa.patch
target/linux/brcm2708/patches-4.19/950-0700-regulator-gpio-Allow-nonexclusive-GPIO-access.patch
target/linux/brcm2708/patches-4.19/950-0701-gpio-Enable-nonexclusive-gpiods-from-DT-nodes.patch
target/linux/brcm63xx/patches-4.19/143-gpio-fix-device-tree-gpio-hogs-on-dual-role-gpio-pin.patch
target/linux/generic/hack-4.19/721-phy_packets.patch
target/linux/generic/pending-4.19/640-netfilter-nf_flow_table-add-hardware-offload-support.patch
target/linux/generic/pending-4.19/642-net-8021q-support-hardware-flow-table-offload.patch
target/linux/generic/pending-4.19/680-NET-skip-GRO-for-foreign-MAC-addresses.patch
target/linux/generic/pending-4.19/834-ledtrig-libata.patch

index 48ccef53636efbf4134158fbd7a80f679671f6c8..fdec85dd9e9a1a65a0578dc142ce8e9e4b476676 100644 (file)
@@ -7,10 +7,10 @@ ifdef CONFIG_TESTING_KERNEL
 endif
 
 LINUX_VERSION-4.14 = .164
-LINUX_VERSION-4.19 = .93
+LINUX_VERSION-4.19 = .95
 
 LINUX_KERNEL_HASH-4.14.164 = a2031061f3f1472b7fa929f7d0274dd985c8d03ca847acfec1c47847fb7deb4b
-LINUX_KERNEL_HASH-4.19.93 = 2af5d23f82a8bf69a6e4d8407579293b7beeebd3054dc464d48bdb5d2d7f5834
+LINUX_KERNEL_HASH-4.19.95 = 4aedca32eec13ac5103fc23e141f9221dfe120d1c0651c0a2efe7de2182f4fb0
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
index dba7df5f3a6910ce514c8211a68a0b9be17b4fdb..201ad740f183c0a6c76df79ca6f42ea3ad9b0b75 100644 (file)
  EXPORT_SYMBOL(xfrm_parse_spi);
 --- a/net/ipv4/tcp_input.c
 +++ b/net/ipv4/tcp_input.c
-@@ -3891,14 +3891,16 @@ static bool tcp_parse_aligned_timestamp(
+@@ -3894,14 +3894,16 @@ static bool tcp_parse_aligned_timestamp(
  {
        const __be32 *ptr = (const __be32 *)(th + 1);
  
index 17867c330ae4ddb6f502b19330d52aaa98575fea..5cec38351b4ccde56b228006ef0233b6f91c1496 100644 (file)
@@ -26,7 +26,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
  /* Device and char device-related information */
  static DEFINE_IDA(gpio_ida);
  static dev_t gpio_devt;
-@@ -2654,7 +2656,7 @@ int gpiod_direction_output(struct gpio_d
+@@ -2662,7 +2664,7 @@ int gpiod_direction_output(struct gpio_d
                value = !!value;
  
        /* GPIOs used for IRQs shall not be set as output */
@@ -35,7 +35,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
                gpiod_err(desc,
                          "%s: tried to set a GPIO tied to an IRQ as output\n",
                          __func__);
-@@ -3353,7 +3355,7 @@ int gpiochip_lock_as_irq(struct gpio_chi
+@@ -3361,7 +3363,7 @@ int gpiochip_lock_as_irq(struct gpio_chi
                }
        }
  
index ef1bbaac692338f712da53333d427662f3ca5c5f..28515c9d0925893edab532f31e46d43d7c9be5c9 100644 (file)
@@ -37,7 +37,7 @@ Signed-off-by: Dave Stevenson <dave.stevenson@raspberrypi.org>
  static int lan78xx_read_reg(struct lan78xx_net *dev, u32 index, u32 *data)
  {
        u32 *buf = kmalloc(sizeof(u32), GFP_KERNEL);
-@@ -3012,8 +3021,14 @@ static int lan78xx_bind(struct lan78xx_n
+@@ -3009,8 +3018,14 @@ static int lan78xx_bind(struct lan78xx_n
        if (DEFAULT_RX_CSUM_ENABLE)
                dev->net->features |= NETIF_F_RXCSUM;
  
index b552cc0b97e03ca9834c8abf7956abab33165b30..b481294674ff621ce2d2cd32d7e1a8c36871b54b 100644 (file)
@@ -28,7 +28,7 @@ See: https://github.com/raspberrypi/linux/issues/2447
  static int lan78xx_read_reg(struct lan78xx_net *dev, u32 index, u32 *data)
  {
        u32 *buf = kmalloc(sizeof(u32), GFP_KERNEL);
-@@ -3825,7 +3830,12 @@ static int lan78xx_probe(struct usb_inte
+@@ -3822,7 +3827,12 @@ static int lan78xx_probe(struct usb_inte
        dev->pipe_intr = usb_rcvintpipe(dev->udev,
                                        dev->ep_intr->desc.bEndpointAddress &
                                        USB_ENDPOINT_NUMBER_MASK);
index f5313aec375dd279bba00177c5fb8dc3437e0776..c5eca2e076957f8ff6a3b9c87354300c28b603e3 100644 (file)
@@ -12,7 +12,7 @@ in both dwc_otg and in ipv6 processing.
 
 --- a/drivers/net/usb/lan78xx.c
 +++ b/drivers/net/usb/lan78xx.c
-@@ -3259,7 +3259,7 @@ static int rx_submit(struct lan78xx_net
+@@ -3256,7 +3256,7 @@ static int rx_submit(struct lan78xx_net
        size_t size = dev->rx_urb_size;
        int ret = 0;
  
index 7bbee63f415d64ed2c865245a43423e0ffcff096..ac7a9aea39957a17bb84341df055d32984970672 100644 (file)
@@ -21,7 +21,7 @@ Cc: stable@vger.kernel.org
 
 --- a/net/bluetooth/hci_conn.c
 +++ b/net/bluetooth/hci_conn.c
-@@ -1280,8 +1280,13 @@ int hci_conn_check_link_mode(struct hci_
+@@ -1282,8 +1282,13 @@ int hci_conn_check_link_mode(struct hci_
                        return 0;
        }
  
index e0ffaae209b9d5481b8db5aa92810a92abdf6e71..6bcfab0ea9b06b0aa6380f68e208505353043829 100644 (file)
@@ -41,7 +41,7 @@ Signed-off-by: Mark Brown <broonie@kernel.org>
 
 --- a/drivers/gpio/gpiolib.c
 +++ b/drivers/gpio/gpiolib.c
-@@ -3979,8 +3979,23 @@ struct gpio_desc *__must_check gpiod_get
+@@ -3987,8 +3987,23 @@ struct gpio_desc *__must_check gpiod_get
         * the device name as label
         */
        status = gpiod_request(desc, con_id ? con_id : devname);
index e8e63a2798ca9a667d15b26b01869046563aa5ff..8e79dae6af5709bf692f3a73432e141fc7194c58 100644 (file)
@@ -23,7 +23,7 @@ Signed-off-by: Mark Brown <broonie@kernel.org>
 
 --- a/drivers/gpio/gpiolib.c
 +++ b/drivers/gpio/gpiolib.c
-@@ -4053,6 +4053,8 @@ struct gpio_desc *gpiod_get_from_of_node
+@@ -4061,6 +4061,8 @@ struct gpio_desc *gpiod_get_from_of_node
        transitory = flags & OF_GPIO_TRANSITORY;
  
        ret = gpiod_request(desc, label);
index 395b17c8de66021ab6157ca6bf762085dff42a0b..13225beae62b017ce0e8a1918a623067a3e11859 100644 (file)
@@ -89,7 +89,7 @@ Signed-off-by: Jonas Gorski <jonas.gorski@gmail.com>
  
 --- a/drivers/gpio/gpiolib.c
 +++ b/drivers/gpio/gpiolib.c
-@@ -2197,7 +2197,8 @@ int gpiochip_add_pingroup_range(struct g
+@@ -2205,7 +2205,8 @@ int gpiochip_add_pingroup_range(struct g
  
        list_add_tail(&pin_range->node, &gdev->pin_ranges);
  
@@ -99,7 +99,7 @@ Signed-off-by: Jonas Gorski <jonas.gorski@gmail.com>
  }
  EXPORT_SYMBOL_GPL(gpiochip_add_pingroup_range);
  
-@@ -2254,7 +2255,7 @@ int gpiochip_add_pin_range(struct gpio_c
+@@ -2262,7 +2263,7 @@ int gpiochip_add_pin_range(struct gpio_c
  
        list_add_tail(&pin_range->node, &gdev->pin_ranges);
  
index b6cbef1e492935d8e838b533ff715b3e30cff79c..1ad7d46764540fcd2f50e75074eddfbc26e47551 100644 (file)
@@ -31,7 +31,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  
  /**
   *    struct net_device - The DEVICE structure.
-@@ -1844,6 +1846,11 @@ struct net_device {
+@@ -1846,6 +1848,11 @@ struct net_device {
        const struct tlsdev_ops *tlsdev_ops;
  #endif
  
@@ -43,7 +43,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        const struct header_ops *header_ops;
  
        unsigned int            flags;
-@@ -1924,6 +1931,10 @@ struct net_device {
+@@ -1928,6 +1935,10 @@ struct net_device {
        struct mpls_dev __rcu   *mpls_ptr;
  #endif
  
@@ -101,7 +101,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        help
 --- a/net/core/dev.c
 +++ b/net/core/dev.c
-@@ -3252,10 +3252,20 @@ static int xmit_one(struct sk_buff *skb,
+@@ -3253,10 +3253,20 @@ static int xmit_one(struct sk_buff *skb,
        if (!list_empty(&ptype_all) || !list_empty(&dev->ptype_all))
                dev_queue_xmit_nit(skb, dev);
  
index 0a1e017f895281b0783d69be17e5d1735229d49f..d9274012cb6f4943945a9609ac2a993bc4f27bd4 100644 (file)
@@ -506,7 +506,7 @@ Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
 +MODULE_ALIAS("nf-flow-table-hw");
 --- a/net/netfilter/nf_tables_api.c
 +++ b/net/netfilter/nf_tables_api.c
-@@ -5470,6 +5470,13 @@ static int nf_tables_flowtable_parse_hoo
+@@ -5478,6 +5478,13 @@ static int nf_tables_flowtable_parse_hoo
        if (err < 0)
                return err;
  
@@ -520,7 +520,7 @@ Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
        ops = kcalloc(n, sizeof(struct nf_hook_ops), GFP_KERNEL);
        if (!ops)
                return -ENOMEM;
-@@ -5601,10 +5608,19 @@ static int nf_tables_newflowtable(struct
+@@ -5609,10 +5616,19 @@ static int nf_tables_newflowtable(struct
        }
  
        flowtable->data.type = type;
@@ -540,7 +540,7 @@ Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
        err = nf_tables_flowtable_parse_hook(&ctx, nla[NFTA_FLOWTABLE_HOOK],
                                             flowtable);
        if (err < 0)
-@@ -5730,7 +5746,8 @@ static int nf_tables_fill_flowtable_info
+@@ -5738,7 +5754,8 @@ static int nf_tables_fill_flowtable_info
            nla_put_string(skb, NFTA_FLOWTABLE_NAME, flowtable->name) ||
            nla_put_be32(skb, NFTA_FLOWTABLE_USE, htonl(flowtable->use)) ||
            nla_put_be64(skb, NFTA_FLOWTABLE_HANDLE, cpu_to_be64(flowtable->handle),
index 724f1c46caedeb50fbce9e517d1d99526f6017b2..7547c14beded64e44f4aede63f10ec108ccbd533 100644 (file)
@@ -20,7 +20,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  
  #include "vlan.h"
  #include "vlanproc.h"
-@@ -770,6 +774,27 @@ static int vlan_dev_get_iflink(const str
+@@ -771,6 +775,27 @@ static int vlan_dev_get_iflink(const str
        return real_dev->ifindex;
  }
  
@@ -48,7 +48,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  static const struct ethtool_ops vlan_ethtool_ops = {
        .get_link_ksettings     = vlan_ethtool_get_link_ksettings,
        .get_drvinfo            = vlan_ethtool_get_drvinfo,
-@@ -807,6 +832,9 @@ static const struct net_device_ops vlan_
+@@ -808,6 +833,9 @@ static const struct net_device_ops vlan_
        .ndo_fix_features       = vlan_dev_fix_features,
        .ndo_get_lock_subclass  = vlan_dev_get_lock_subclass,
        .ndo_get_iflink         = vlan_dev_get_iflink,
index 1e52d2f2a7041405efb3dd67181031cf402796eb..ad7ccdb048df1cf7acb3df08baf2310447693a7e 100644 (file)
@@ -11,7 +11,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
 
 --- a/include/linux/netdevice.h
 +++ b/include/linux/netdevice.h
-@@ -1887,6 +1887,8 @@ struct net_device {
+@@ -1891,6 +1891,8 @@ struct net_device {
        struct netdev_hw_addr_list      mc;
        struct netdev_hw_addr_list      dev_addrs;
  
@@ -32,7 +32,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        __u16                   tc_index;       /* traffic control index */
 --- a/net/core/dev.c
 +++ b/net/core/dev.c
-@@ -5482,6 +5482,9 @@ static enum gro_result dev_gro_receive(s
+@@ -5483,6 +5483,9 @@ static enum gro_result dev_gro_receive(s
        int same_flow;
        int grow;
  
@@ -42,7 +42,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        if (netif_elide_gro(skb->dev))
                goto normal;
  
-@@ -6976,6 +6979,48 @@ static void __netdev_adjacent_dev_unlink
+@@ -7141,6 +7144,48 @@ static void __netdev_adjacent_dev_unlink
                                           &upper_dev->adj_list.lower);
  }
  
@@ -91,7 +91,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  static int __netdev_upper_dev_link(struct net_device *dev,
                                   struct net_device *upper_dev, bool master,
                                   void *upper_priv, void *upper_info,
-@@ -7023,6 +7068,7 @@ static int __netdev_upper_dev_link(struc
+@@ -7191,6 +7236,7 @@ static int __netdev_upper_dev_link(struc
        if (ret)
                return ret;
  
@@ -99,15 +99,15 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        ret = call_netdevice_notifiers_info(NETDEV_CHANGEUPPER,
                                            &changeupper_info.info);
        ret = notifier_to_errno(ret);
-@@ -7109,6 +7155,7 @@ void netdev_upper_dev_unlink(struct net_
+@@ -7283,6 +7329,7 @@ void netdev_upper_dev_unlink(struct net_
  
        __netdev_adjacent_dev_unlink_neighbour(dev, upper_dev);
  
 +      netdev_update_addr_mask(dev);
        call_netdevice_notifiers_info(NETDEV_CHANGEUPPER,
                                      &changeupper_info.info);
- }
-@@ -7733,6 +7780,7 @@ int dev_set_mac_address(struct net_devic
+@@ -7913,6 +7960,7 @@ int dev_set_mac_address(struct net_devic
        if (err)
                return err;
        dev->addr_assign_type = NET_ADDR_SET;
index de029fafe5a677aefee767713712a1ecb35d031b..f1dc0e5995485096c1648cef444d730eabf9e0e6 100644 (file)
@@ -75,7 +75,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
  
        qc = __ata_qc_from_tag(ap, tag);
        qc->tag = qc->hw_tag = tag;
-@@ -6044,6 +6060,9 @@ struct ata_port *ata_port_alloc(struct a
+@@ -6068,6 +6084,9 @@ struct ata_port *ata_port_alloc(struct a
        ap->stats.unhandled_irq = 1;
        ap->stats.idle_irq = 1;
  #endif
@@ -85,7 +85,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
        ata_sff_port_init(ap);
  
        return ap;
-@@ -6079,6 +6098,12 @@ static void ata_host_release(struct kref
+@@ -6103,6 +6122,12 @@ static void ata_host_release(struct kref
  
                kfree(ap->pmp_link);
                kfree(ap->slave_link);
@@ -98,7 +98,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
                kfree(ap);
                host->ports[i] = NULL;
        }
-@@ -6542,7 +6567,23 @@ int ata_host_register(struct ata_host *h
+@@ -6566,7 +6591,23 @@ int ata_host_register(struct ata_host *h
                host->ports[i]->print_id = atomic_inc_return(&ata_print_id);
                host->ports[i]->local_port_no = i + 1;
        }