ar71xx: Add Support for the Bitmain Antminer S1
authorJohn Crispin <john@openwrt.org>
Thu, 18 Jun 2015 18:21:05 +0000 (18:21 +0000)
committerJohn Crispin <john@openwrt.org>
Thu, 18 Jun 2015 18:21:05 +0000 (18:21 +0000)
This patch adds support for the Bitmain Antminer S1 Cryptocurrency Miner

http://wiki.openwrt.org/toh/bitmain/s1

Signed-off-by: L. D. Pinney <ldpinney@gmail.com>
Acked-by: James Hilliard <james.hilliard1@gmail.com>
SVN-Revision: 46044

target/linux/ar71xx/base-files/etc/diag.sh
target/linux/ar71xx/base-files/etc/uci-defaults/01_leds
target/linux/ar71xx/base-files/etc/uci-defaults/02_network
target/linux/ar71xx/base-files/lib/ar71xx.sh
target/linux/ar71xx/config-3.18
target/linux/ar71xx/files/arch/mips/ath79/mach-antminer-s1.c [new file with mode: 0644]
target/linux/ar71xx/generic/profiles/antminer.mk [new file with mode: 0644]
target/linux/ar71xx/image/Makefile
target/linux/ar71xx/patches-3.18/904-MIPS-ath79-bitmain-antminer-s1-support.patch [new file with mode: 0644]
tools/firmware-utils/src/mktplinkfw.c

index 055325179be2faf913786dc1771fbd1d5e665c72..f6e4a875fc1a7043933b5b91cf5ae669f8f3cc5b 100644 (file)
@@ -12,6 +12,9 @@ get_status_led() {
        all0305)
                status_led="eap7660d:green:ds4"
                ;;
+       antminer-s1)
+               status_led="bitmain:green:system"
+               ;;
        ap132)
                status_led="ap132:green:status"
                ;;
index 41eeeebe321be8e62cbe1ea96e8521325a3a74df..19814f4e4a5a5b95b154b9d1720630c26df41f0f 100644 (file)
@@ -31,6 +31,11 @@ all0315n)
        ucidef_set_led_rssi "rssihigh" "RSSIHIGH" "all0315n:green:rssihigh" "wlan0" "70" "100" "-69" "8"
        ;;
 
+antminer-s1)
+       ucidef_set_led_default "sys" "SYS" "bitmain:green:sys" "0"
+       ucidef_set_led_wlan "wlan" "WLAN" "bitmain:green:wlan" "phy0tpt"
+       ;;
+
 ap113)
        ucidef_set_led_usbdev "usb" "USB" "ap113:green:usb" "1-1"
        ;;
index f5c68652400bdcc286506ab9212abdc2a65b0b16..9fdaca07212d39213a812abb432708eb07f654cc 100644 (file)
@@ -343,6 +343,7 @@ wp543)
        ucidef_set_interface_lan "eth0"
        ;;
 
+antminer-s1 |\
 dir-505-a1)
        ucidef_set_interface_lan "eth1"
        ;;
index b13be1e5f9f5c4a76eadbacbbd56a3f90edb0f94..4a4101de3342d2aa73c1a6106d6a2227587dcba1 100755 (executable)
@@ -107,6 +107,9 @@ tplink_board_detect() {
        "015300"*)
                model="EasyLink EL-MINI"
                ;;
+       "04440001"*)
+               model="BITMAIN ANTMINER S1"
+               ;;
        "120000"*)
                model="MERCURY MAC1200R"
                ;;
index 543b77e9fb758100390f8cb51daf0101e139f3a5..196006016f933c9816271cfc29ccc2c13a7d8059 100644 (file)
@@ -40,6 +40,7 @@ CONFIG_ATH79_MACH_AP83=y
 CONFIG_ATH79_MACH_AP96=y
 CONFIG_ATH79_MACH_ARCHER_C7=y
 CONFIG_ATH79_MACH_AW_NR580=y
+CONFIG_ATH79_MACH_ANTMINER_S1=y
 CONFIG_ATH79_MACH_BHU_BXU2000N2_A=y
 CONFIG_ATH79_MACH_CAP4200AG=y
 CONFIG_ATH79_MACH_CARAMBOLA2=y
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/mach-antminer-s1.c b/target/linux/ar71xx/files/arch/mips/ath79/mach-antminer-s1.c
new file mode 100644 (file)
index 0000000..27ed760
--- /dev/null
@@ -0,0 +1,98 @@
+/*
+ *   Bitmain Antminer S1 board support
+ *
+ *  Copyright (C) 2015 L. D. Pinney <ldpinney@gmail.com>
+ *
+ *  This program is free software; you can redistribute it and/or modify it
+ *  under the terms of the GNU General Public License version 2 as published
+ *  by the Free Software Foundation.
+ */
+
+#include <linux/gpio.h>
+
+#include <asm/mach-ath79/ath79.h>
+#include <asm/mach-ath79/ar71xx_regs.h>
+
+#include "common.h"
+#include "dev-eth.h"
+#include "dev-gpio-buttons.h"
+#include "dev-leds-gpio.h"
+#include "dev-m25p80.h"
+#include "dev-wmac.h"
+#include "machtypes.h"
+#include "dev-usb.h"
+
+#define ANTMINER_S1_GPIO_BTN_RESET             11
+
+#define ANTMINER_S1_GPIO_LED_SYSTEM            23
+#define ANTMINER_S1_GPIO_LED_WLAN              0
+#define ANTMINER_S1_GPIO_USB_POWER             8
+
+#define ANTMINER_S1_KEYSPOLL_INTERVAL  20      /* msecs */
+#define ANTMINER_S1_KEYSDEBOUNCE_INTERVAL (3 * ANTMINER_S1_KEYSPOLL_INTERVAL)
+
+static const char *ANTMINER_S1_part_probes[] = {
+       "tp-link",
+       NULL,
+};
+
+static struct flash_platform_data ANTMINER_S1_flash_data = {
+       .part_probes    = ANTMINER_S1_part_probes,
+};
+
+static struct gpio_led ANTMINER_S1_leds_gpio[] __initdata = {
+       {
+               .name           = "bitmain:green:system",
+               .gpio           = ANTMINER_S1_GPIO_LED_SYSTEM,
+               .active_low     = 0,
+       },{
+               .name           = "bitmain:green:wlan",
+               .gpio           = ANTMINER_S1_GPIO_LED_WLAN,
+               .active_low     = 0,
+       },
+};
+
+static struct gpio_keys_button ANTMINER_S1_GPIO_keys[] __initdata = {
+       {
+               .desc           = "reset",
+               .type           = EV_KEY,
+               .code           = KEY_RESTART,
+               .debounce_interval = ANTMINER_S1_KEYSDEBOUNCE_INTERVAL,
+               .gpio           = ANTMINER_S1_GPIO_BTN_RESET,
+               .active_low     = 0,
+       },
+};
+
+static void __init antminer_s1_setup(void)
+{
+       u8 *mac = (u8 *) KSEG1ADDR(0x1f01fc00);
+       u8 *ee = (u8 *) KSEG1ADDR(0x1fff1000);
+
+       /* disable PHY_SWAP and PHY_ADDR_SWAP bits */
+       ath79_setup_ar933x_phy4_switch(false, false);
+
+       ath79_register_leds_gpio(-1, ARRAY_SIZE(ANTMINER_S1_leds_gpio),
+                                ANTMINER_S1_leds_gpio);
+
+       ath79_register_gpio_keys_polled(-1, ANTMINER_S1_KEYSPOLL_INTERVAL,
+                                       ARRAY_SIZE(ANTMINER_S1_GPIO_keys),
+                                       ANTMINER_S1_GPIO_keys);
+
+       gpio_request_one(ANTMINER_S1_GPIO_USB_POWER,
+                        GPIOF_OUT_INIT_HIGH | GPIOF_EXPORT_DIR_FIXED,
+                        "USB power");
+       ath79_register_usb();
+
+       ath79_register_m25p80(&ANTMINER_S1_flash_data);
+       ath79_init_mac(ath79_eth0_data.mac_addr, mac, 1);
+       ath79_init_mac(ath79_eth1_data.mac_addr, mac, -1);
+
+       ath79_register_mdio(0, 0x0);
+       ath79_register_eth(0);
+       ath79_register_eth(1);
+
+       ath79_register_wmac(ee, mac);
+}
+
+MIPS_MACHINE(ATH79_MACH_ANTMINER_S1, "ANTMINER-S1",
+            "Bitmain Antminer S1", antminer_s1_setup);
diff --git a/target/linux/ar71xx/generic/profiles/antminer.mk b/target/linux/ar71xx/generic/profiles/antminer.mk
new file mode 100644 (file)
index 0000000..366982c
--- /dev/null
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/ANTMINER_S1
+       NAME:=Antminer S1
+       PACKAGES:=kmod-usb-core kmod-usb2 kmod-crypto-manager kmod-i2c-gpio-custom kmod-usb-hid
+endef
+
+
+define Profile/ANTMINER_S1/Description
+       Package set optimized for the Bitmain Antminer S1.
+endef
+$(eval $(call Profile,ANTMINER_S1))
index 0e46194e751161ec079a447bdb6e4f857cdbf3e9..5a82b7caf0b754d273afa8bc7958e60e4135c3f4 100644 (file)
@@ -330,6 +330,14 @@ define Device/archer-c7-v2
 endef
 TARGET_DEVICES += archer-c5 archer-c7-v1 archer-c7-v2
 
+define Device/antminer-s1
+       $(Device/tplink-8mlzma)
+       BOARDNAME := ANTMINER-S1
+       DEVICE_PROFILE := ANTMINER_S1
+       TPLINK_HWID := 0x04440001
+       CONSOLE := ttyATH0,115200
+endef
+
 define Device/el-m150
     $(Device/tplink-8mlzma)
     BOARDNAME := EL-M150
@@ -345,7 +353,7 @@ define Device/el-mini
     TPLINK_HWID := 0x01530001
     CONSOLE := ttyATH0,115200
 endef
-TARGET_DEVICES += el-m150 el-mini
+TARGET_DEVICES += antminer-s1 el-m150 el-mini
 
 define Device/gl-inet-6408A-v1
     $(Device/tplink-8mlzma)
diff --git a/target/linux/ar71xx/patches-3.18/904-MIPS-ath79-bitmain-antminer-s1-support.patch b/target/linux/ar71xx/patches-3.18/904-MIPS-ath79-bitmain-antminer-s1-support.patch
new file mode 100644 (file)
index 0000000..dfecc82
--- /dev/null
@@ -0,0 +1,39 @@
+--- a/arch/mips/ath79/machtypes.h
++++ b/arch/mips/ath79/machtypes.h
+@@ -21,6 +21,7 @@
+       ATH79_MACH_ALL0258N,            /* Allnet ALL0258N */
+       ATH79_MACH_ALL0305,             /* Allnet ALL0305 */
+       ATH79_MACH_ALL0315N,            /* Allnet ALL0315N */
++      ATH79_MACH_ANTMINER_S1, /* Bitmain Antminer S1 */
+       ATH79_MACH_AP113,               /* Atheros AP113 reference board */
+       ATH79_MACH_AP121,               /* Atheros AP121 reference board */
+       ATH79_MACH_AP121_MINI,          /* Atheros AP121-MINI reference board */
+--- a/arch/mips/ath79/Kconfig
++++ b/arch/mips/ath79/Kconfig
+@@ -56,6 +56,16 @@
+       select ATH79_DEV_LEDS_GPIO
+       select ATH79_DEV_M25P80
+
++config ATH79_MACH_ANTMINER_S1
++      bool "Bitmain Antminer S1 support"
++      select SOC_AR933X
++      select ATH79_DEV_ETH
++      select ATH79_DEV_GPIO_BUTTONS
++      select ATH79_DEV_LEDS_GPIO
++      select ATH79_DEV_M25P80
++      select ATH79_DEV_USB
++      select ATH79_DEV_WMAC
++
+ config ATH79_MACH_AP113
+       bool "Atheros AP113 board support"
+       select SOC_AR724X
+--- a/arch/mips/ath79/Makefile
++++ b/arch/mips/ath79/Makefile
+@@ -42,6 +42,7 @@
+ obj-$(CONFIG_ATH79_MACH_ALFA_NX)      += mach-alfa-nx.o
+ obj-$(CONFIG_ATH79_MACH_ALL0258N)     += mach-all0258n.o
+ obj-$(CONFIG_ATH79_MACH_ALL0315N)     += mach-all0315n.o
++obj-$(CONFIG_ATH79_MACH_ANTMINER_S1)+= mach-antminer-s1.o
+ obj-$(CONFIG_ATH79_MACH_AP113)                += mach-ap113.o
+ obj-$(CONFIG_ATH79_MACH_AP121)                += mach-ap121.o
+ obj-$(CONFIG_ATH79_MACH_AP132)                += mach-ap132.o
index 80db8f8c2578d5033434aa4a855617f6196433e0..87340db2404f7d00407633f6493d144dd26aba81 100644 (file)
@@ -30,6 +30,7 @@
 #define ALIGN(x,a) ({ typeof(a) __a = (a); (((x) + __a - 1) & ~(__a - 1)); })
 
 #define HEADER_VERSION_V1      0x01000000
+#define HWID_ANTMINER_S1       0x04440001
 #define HWID_GL_INET_V1                0x08000001
 #define HWID_GS_OOLITE_V1      0x3C000101
 #define HWID_TL_MR10U_V1       0x00100101
@@ -411,6 +412,11 @@ static struct board_info boards[] = {
                .hw_id          = HWID_GS_OOLITE_V1,
                .hw_rev         = 1,
                .layout_id      = "16Mlzma",
+       }, {
+               .id             = "ANTMINER-S1",
+               .hw_id          = HWID_ANTMINER_S1,
+               .hw_rev         = 1,
+               .layout_id      = "8Mlzma",
        }, {
                /* terminating entry */
        }