ramips: Add support for Netgear EX3800
authorThibaut VARENE <hacks@slashdirt.org>
Sun, 30 Jul 2017 10:17:44 +0000 (12:17 +0200)
committerMathias Kresin <dev@kresin.me>
Wed, 2 Aug 2017 22:11:25 +0000 (00:11 +0200)
The Netgear EX3800 is essentially an EX3700 with a mains output socket.

Both devices use the exact same firmware image (original firmware is named
EX3700-EX3800-version.chk).

This patch adds suport by renaming the EX3700 device to EX3700/EX3800 and
updating the necessary glue.

Signed-off-by: Thibaut VARENE <hacks@slashdirt.org>
target/linux/ramips/base-files/lib/ramips.sh
target/linux/ramips/dts/EX3700.dts
target/linux/ramips/image/mt7620.mk

index 1dc1391800ec3021a0c13c4b49a51cb315da9e94..0087f2003bb802b83c95670004a963d5517a423c 100755 (executable)
@@ -181,7 +181,7 @@ ramips_board_detect() {
        *"EX2700")
                name="ex2700";
                ;;
        *"EX2700")
                name="ex2700";
                ;;
-       *"EX3700")
+       *"EX3700/EX3800")
                name="ex3700"
                ;;
        *"F5D8235 v1")
                name="ex3700"
                ;;
        *"F5D8235 v1")
index 72aeb6152d0ec3f973be2f154f35c7a4e8507b53..2cf1c0b3e8d76ca81bcdbeab14a65bcbe74c8091 100644 (file)
@@ -9,7 +9,7 @@
 
 / {
        compatible = "ralink,mt7620a-soc";
 
 / {
        compatible = "ralink,mt7620a-soc";
-       model = "Netgear EX3700";
+       model = "Netgear EX3700/EX3800";
 
        chosen {
                bootargs = "console=ttyS0,57600";
 
        chosen {
                bootargs = "console=ttyS0,57600";
index 84999f08de9b6dc5315afb260da0047b008cb25d..f9a9fdb84cee323023657700434170d41c7175ef 100644 (file)
@@ -140,7 +140,7 @@ define Device/ex2700
 endef
 TARGET_DEVICES += ex2700
 
 endef
 TARGET_DEVICES += ex2700
 
-define Device/ex3700
+define Device/ex3700-ex3800
   NETGEAR_BOARD_ID := U12H319T00_NETGEAR
   DTS := EX3700
   BLOCKSIZE := 4k
   NETGEAR_BOARD_ID := U12H319T00_NETGEAR
   DTS := EX3700
   BLOCKSIZE := 4k
@@ -148,9 +148,10 @@ define Device/ex3700
   IMAGES += factory.chk
   IMAGE/factory.chk := $$(sysupgrade_bin) | check-size $$$$(IMAGE_SIZE) | netgear-chk
   DEVICE_PACKAGES := -kmod-mt76 kmod-mt76x2
   IMAGES += factory.chk
   IMAGE/factory.chk := $$(sysupgrade_bin) | check-size $$$$(IMAGE_SIZE) | netgear-chk
   DEVICE_PACKAGES := -kmod-mt76 kmod-mt76x2
-  DEVICE_TITLE := Netgear EX3700
+  DEVICE_TITLE := Netgear EX3700/EX3800
+  SUPPORTED_DEVICES := ex3700
 endef
 endef
-TARGET_DEVICES += ex3700
+TARGET_DEVICES += ex3700-ex3800
 
 define Device/gl-mt300a
   DTS := GL-MT300A
 
 define Device/gl-mt300a
   DTS := GL-MT300A