6rd: delete tunnel on interface teardown
authorDavid Lam <david@thedavid.net>
Mon, 20 Sep 2021 05:42:14 +0000 (22:42 -0700)
committerStijn Tintel <stijn@linux-ipv6.be>
Tue, 21 Sep 2021 22:45:33 +0000 (01:45 +0300)
Delete tunnel on 6rd interface teardown.
Should solve problem related to tunnel stuck on restart loop
with "Unknown Command" on tunnel restart due to wan connection drop.

This patch is similar to the one written by Ansuel on Aug 2, 2021
but the 6rd teardown produces the same symptoms when the network
service is restarted.

Signed-off-by: David Lam <david@thedavid.net>
package/network/ipv6/6rd/Makefile
package/network/ipv6/6rd/files/6rd.sh

index 9836ae9361c7f26385ff0ea9ec998fc37fb214be..f9c4c6f7a56f76266771bb62958070e65e8e1e3e 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=6rd
-PKG_RELEASE:=10
+PKG_RELEASE:=11
 PKG_LICENSE:=GPL-2.0
 
 include $(INCLUDE_DIR)/package.mk
index 62a20314d9322b56a3785f9f4b5adf7523a2460d..3c913e54f1665ca59c6a9d17ed660b2b6b9dff8d 100644 (file)
@@ -82,6 +82,8 @@ proto_6rd_setup() {
 
 proto_6rd_teardown() {
        local cfg="$1"
+       local link="6rd-$cfg"
+       ip link del $link
 }
 
 proto_6rd_init_config() {