tools: quilt: fix perl interpreter line (#20802)
authorJo-Philipp Wich <jow@openwrt.org>
Mon, 26 Oct 2015 15:28:05 +0000 (15:28 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Mon, 26 Oct 2015 15:28:05 +0000 (15:28 +0000)
When using '/usr/bin/env' in a shebang it is not possible to specify
additional flags for the interpreter. Remove '-w' switches and add
'use warnings;' instead.

Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
SVN-Revision: 47278

tools/quilt/patches/000-relocatable.patch

index 9309fc4..aedb914 100644 (file)
        export QUILTRC
 --- a/quilt/scripts/edmail.in
 +++ b/quilt/scripts/edmail.in
-@@ -29,7 +29,7 @@ BEGIN {
+@@ -1,4 +1,6 @@
+-#! @PERL@ -w
++#! @PERL@
++
++use warnings;
+ # RFCs important for this script:
+ #
+@@ -29,7 +31,7 @@ BEGIN {
  }
  
  setlocale(LC_MESSAGES, "");
  : ${LC_MESSAGES:=$LANG}
 --- a/quilt/scripts/remove-trailing-ws.in
 +++ b/quilt/scripts/remove-trailing-ws.in
-@@ -31,7 +31,7 @@ BEGIN {
+@@ -1,4 +1,6 @@
+-#! @PERL@ -w
++#! @PERL@
++
++use warnings;
+ # Remove trailing whitespace from modified lines in working files.
+ #
+@@ -31,7 +33,7 @@ BEGIN {
  }
  
  setlocale(LC_MESSAGES, "");
  . $QUILT_DIR/scripts/utilfns
  
  ensure_nolinks()
+--- a/bin/guards.in
++++ b/bin/guards.in
+@@ -1,4 +1,6 @@
+-#!@PERL@ -w
++#!@PERL@
++
++use warnings;
+ #  This script is free software; you can redistribute it and/or modify
+ #  it under the terms of the GNU General Public License version 2 as
+--- a/compat/date.in
++++ b/compat/date.in
+@@ -1,4 +1,6 @@
+-#! @PERL@ -w
++#! @PERL@
++
++use warnings;
+ #  This script is free software; you can redistribute it and/or modify
+ #  it under the terms of the GNU General Public License version 2 as
+--- a/compat/getopt.in
++++ b/compat/getopt.in
+@@ -1,4 +1,6 @@
+-#! @PERL@ -w
++#! @PERL@
++
++use warnings;
+ #  This script is free software; you can redistribute it and/or modify
+ #  it under the terms of the GNU General Public License version 2 as
+--- a/quilt/scripts/dependency-graph.in
++++ b/quilt/scripts/dependency-graph.in
+@@ -1,4 +1,6 @@
+-#!@PERL@ -w
++#!@PERL@
++
++use warnings;
+ #  This script is free software; you can redistribute it and/or modify
+ #  it under the terms of the GNU General Public License version 2 as