package/elfutils: add CFLAG -Wno-format-nonliteral
authorAlexander Couzens <lynxis@fe80.eu>
Fri, 4 Aug 2017 11:09:12 +0000 (13:09 +0200)
committerAlexander Couzens <lynxis@fe80.eu>
Mon, 13 Nov 2017 00:11:12 +0000 (01:11 +0100)
When a library is using fortify-packages GCC will complain about
"error: format not a string literal, argument types not checked".

Signed-off-by: Alexander Couzens <lynxis@fe80.eu>
package/libs/elfutils/Makefile

index 869513f16f218c3372edc89c63160037342790e2..a726691d3ac0f5414d69e6a5182acc10b0f4dfd1 100644 (file)
@@ -68,7 +68,7 @@ endif
 CONFIGURE_ARGS += \
        --without-lzma
 
-TARGET_CFLAGS += -D_GNU_SOURCE -Wno-unused-result
+TARGET_CFLAGS += -D_GNU_SOURCE -Wno-unused-result -Wno-format-nonliteral
 
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/include