Fix the r8169 kernel module (#2554)
authorFlorian Fainelli <florian@openwrt.org>
Wed, 24 Oct 2007 19:23:47 +0000 (19:23 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Wed, 24 Oct 2007 19:23:47 +0000 (19:23 +0000)
SVN-Revision: 9436

package/kernel/modules/network.mk
target/linux/x86/config-2.6.23

index 4794941ef5db7ce25c50338053fe19ac14ebe02d..715051379f6733652e904ef5e932e9c38edcec7a 100644 (file)
@@ -681,22 +681,6 @@ endef
 $(eval $(call KernelPackage,e1000))
 
 
-define KernelPackage/r8169
-  SUBMENU:=$(NETWORK_DEVICES_MENU)
-  TITLE:=Realtek 8169 gigabit ethernet support
-  DEPENDS:=@TARGET_x86
-  KCONFIG:=CONFIG_R8169
-  FILES:=$(LINUX_DIR)/drivers/net/r8169.$(LINUX_KMOD_SUFFIX)
-  AUTOLOAD:=$(call AutoLoad,50,r8169)
-endef
-
-define KernelPackage/r8169/description
- Kernel modules for Realtek 8169 gigabit ethernet support.
-endef
-
-$(eval $(call KernelPackage,r8169))
-
-
 define KernelPackage/3c59x
   SUBMENU:=$(NETWORK_DEVICES_MENU)
   TITLE:=3Com 3c590/3c900 series (592/595/597) Vortex/Boomerang
index 3be125911a0816c0f24e23ce9174a163c59d88a6..963069675c62db1b1235614cc7a334b1d3ddc20a 100644 (file)
@@ -288,9 +288,6 @@ CONFIG_PNP=y
 # CONFIG_PNP_DEBUG is not set
 CONFIG_PREEMPT_BKL=y
 CONFIG_QUICKLIST=y
-CONFIG_R8169=m
-CONFIG_R8169_NAPI=y
-# CONFIG_R8169_VLAN is not set
 # CONFIG_RELOCATABLE is not set
 CONFIG_RTC=y
 CONFIG_RWSEM_GENERIC_SPINLOCK=y