package/kernel: fix dependency modules
authorAlexandros C. Couloumbis <alex@ozo.com>
Fri, 11 Jun 2010 15:04:04 +0000 (15:04 +0000)
committerAlexandros C. Couloumbis <alex@ozo.com>
Fri, 11 Jun 2010 15:04:04 +0000 (15:04 +0000)
SVN-Revision: 21758

package/kernel/modules/crypto.mk

index 781182bd439dfa5f25aaa2bb84c69c5ac6b72d69..66f6e0cdbdf1e291ad426597102557e9eb4c862b 100644 (file)
@@ -278,7 +278,7 @@ endef
 define KernelPackage/crypto-misc/2.6
   FILES+= \
        $(LINUX_DIR)/crypto/camellia.$(LINUX_KMOD_SUFFIX) \
-       $(LINUX_DIR)/crypto/crc32c.$(LINUX_KMOD_SUFFIX) \
+       $(if $(findstring y,$(CONFIG_CRYPTO_CRC32C)),,$(LINUX_DIR)/crypto/crc32c.$(LINUX_KMOD_SUFFIX) \
        $(LINUX_DIR)/crypto/fcrypt.$(LINUX_KMOD_SUFFIX) \
        $(LINUX_DIR)/crypto/tgr192.$(LINUX_KMOD_SUFFIX) \
        $(LINUX_DIR)/crypto/twofish_common.$(LINUX_KMOD_SUFFIX)