kernel: bump 4.14 to 4.14.111
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Mon, 8 Apr 2019 11:52:02 +0000 (13:52 +0200)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Mon, 8 Apr 2019 12:54:48 +0000 (14:54 +0200)
Refreshed all patches.

Compile-tested on: cns3xxx, imx6
Runtime-tested on: cns3xxx, imx6

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
include/kernel-version.mk
target/linux/apm821xx/patches-4.14/021-0004-crypto-crypto4xx-kill-MODULE_NAME.patch
target/linux/generic/backport-4.14/293-v4.16-netfilter-reduce-size-of-hook-entry-point-locations.patch
target/linux/generic/backport-4.14/320-v4.16-netfilter-nf_conntrack-add-IPS_OFFLOAD-status-bit.patch
target/linux/generic/backport-4.14/370-netfilter-nf_flow_table-fix-offloaded-connection-tim.patch
target/linux/generic/hack-4.14/902-debloat_proc.patch

index 20ba2f32af42598286b15c81fb083d647abcc5ea..71a4b2aa1a90c1a7ef6f90f470a368d5b11b6f38 100644 (file)
@@ -3,10 +3,10 @@
 LINUX_RELEASE?=1
 
 LINUX_VERSION-4.9 = .168
-LINUX_VERSION-4.14 = .110
+LINUX_VERSION-4.14 = .111
 
 LINUX_KERNEL_HASH-4.9.168 = 4d451c21effad77de323edc9bfeae095aa1faed1a801ef427d66f5763bef091e
-LINUX_KERNEL_HASH-4.14.110 = 99ea359464dc8a7ab9862195934a1f3504c38a32af5fa424e3ae56244dd59e72
+LINUX_KERNEL_HASH-4.14.111 = f8197d56553f864d1d2e97abbe4fca50f8ab5e72089c292d22f0e4395340a6e8
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
index 4ee99f44cfd1cb397b698f86fc5cde53d2d6861d..87d7a3e67473701fb0223e840f26a4d8873169e0 100644 (file)
@@ -36,7 +36,7 @@ Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
  #define PPC460EX_SDR0_SRST                      0x201
 --- a/drivers/crypto/amcc/crypto4xx_trng.c
 +++ b/drivers/crypto/amcc/crypto4xx_trng.c
-@@ -92,7 +92,7 @@ void ppc4xx_trng_probe(struct crypto4xx_
+@@ -94,7 +94,7 @@ void ppc4xx_trng_probe(struct crypto4xx_
        if (!rng)
                goto err_out;
  
index fcf54e9858da10ef9963e6e204f82581d52e41ac..007b8315e529dc8afd1f73464b1ecbd422701c13 100644 (file)
@@ -92,7 +92,7 @@ Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
  #endif
 --- a/net/bridge/br_netfilter_hooks.c
 +++ b/net/bridge/br_netfilter_hooks.c
-@@ -992,7 +992,7 @@ int br_nf_hook_thresh(unsigned int hook,
+@@ -987,7 +987,7 @@ int br_nf_hook_thresh(unsigned int hook,
        unsigned int i;
        int ret;
  
index 00303f90a1ae1e54ba70890b2f46888512015e42..53993ffe56372e215aff1b3ec94a6a2b23609a6a 100644 (file)
@@ -47,7 +47,7 @@ Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
  };
 --- a/net/netfilter/nf_conntrack_core.c
 +++ b/net/netfilter/nf_conntrack_core.c
-@@ -917,6 +917,9 @@ static unsigned int early_drop_list(stru
+@@ -925,6 +925,9 @@ static unsigned int early_drop_list(stru
        hlist_nulls_for_each_entry_rcu(h, n, head, hnnode) {
                tmp = nf_ct_tuplehash_to_ctrack(h);
  
@@ -57,7 +57,7 @@ Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
                if (nf_ct_is_expired(tmp)) {
                        nf_ct_gc_expired(tmp);
                        continue;
-@@ -994,6 +997,18 @@ static bool gc_worker_can_early_drop(con
+@@ -1002,6 +1005,18 @@ static bool gc_worker_can_early_drop(con
        return false;
  }
  
@@ -76,7 +76,7 @@ Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
  static void gc_worker(struct work_struct *work)
  {
        unsigned int min_interval = max(HZ / GC_MAX_BUCKETS_DIV, 1u);
-@@ -1030,6 +1045,11 @@ static void gc_worker(struct work_struct
+@@ -1038,6 +1053,11 @@ static void gc_worker(struct work_struct
                        tmp = nf_ct_tuplehash_to_ctrack(h);
  
                        scanned++;
index 166b7219d592b5d653775056c96f30ae9fc6d0a3..22fdebb3a8fad9558e6ac382f467440f4d3ae19f 100644 (file)
@@ -21,7 +21,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
 
 --- a/net/netfilter/nf_conntrack_core.c
 +++ b/net/netfilter/nf_conntrack_core.c
-@@ -997,18 +997,6 @@ static bool gc_worker_can_early_drop(con
+@@ -1005,18 +1005,6 @@ static bool gc_worker_can_early_drop(con
        return false;
  }
  
@@ -40,7 +40,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  static void gc_worker(struct work_struct *work)
  {
        unsigned int min_interval = max(HZ / GC_MAX_BUCKETS_DIV, 1u);
-@@ -1045,10 +1033,8 @@ static void gc_worker(struct work_struct
+@@ -1053,10 +1041,8 @@ static void gc_worker(struct work_struct
                        tmp = nf_ct_tuplehash_to_ctrack(h);
  
                        scanned++;
index 6b46c054d3e68098970579724055e1454c69d699..c44eb164128d51186e36874c4768c4f014d88fd8 100644 (file)
@@ -233,7 +233,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
                return -ENOMEM;
 --- a/mm/vmalloc.c
 +++ b/mm/vmalloc.c
-@@ -2770,6 +2770,8 @@ static const struct file_operations proc
+@@ -2774,6 +2774,8 @@ static const struct file_operations proc
  
  static int __init proc_vmalloc_init(void)
  {