base-files: apply new sysctl.conf at postinst
authorYousong Zhou <yszhou4tech@gmail.com>
Thu, 20 Jun 2019 10:29:53 +0000 (10:29 +0000)
committerJo-Philipp Wich <jo@mein.io>
Wed, 4 Sep 2019 11:18:19 +0000 (13:18 +0200)
This is mainly for kmod-br-netfilter.  To turn off
bridge-netfilter-call-xxx immediately after installation

While at it

 - Define filelist="/usr/lib/opkg/info/${pkgname}.list"
 - Reuse "[ -z "$root" ]"
 - Grep with "-m1"

Fixes FS#2300

Reported-by: Marco Sartorius <tidbits@ormoorgmen.info>
Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
(cherry picked from commit 3dc4f59eabaed5135cd4eed8d1846248d5f1b37c)

package/base-files/Makefile
package/base-files/files/lib/functions.sh

index 91d677acb3bec0e8ef40d722a80c4a435192a110..a6dee5aa5a8aec1c072812fd5ed36107478080bd 100644 (file)
@@ -12,7 +12,7 @@ include $(INCLUDE_DIR)/version.mk
 include $(INCLUDE_DIR)/feeds.mk
 
 PKG_NAME:=base-files
 include $(INCLUDE_DIR)/feeds.mk
 
 PKG_NAME:=base-files
-PKG_RELEASE:=198
+PKG_RELEASE:=199
 PKG_FLAGS:=nonshared
 
 PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
 PKG_FLAGS:=nonshared
 
 PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
index edce75e8ff877aa28adea5b58463a95b19f8f7e2..860fc045100f15a0725e47a38f28f9855835291a 100755 (executable)
@@ -213,6 +213,7 @@ add_group_and_user() {
 default_postinst() {
        local root="${IPKG_INSTROOT}"
        local pkgname="$(basename ${1%.*})"
 default_postinst() {
        local root="${IPKG_INSTROOT}"
        local pkgname="$(basename ${1%.*})"
+       local filelist="/usr/lib/opkg/info/${pkgname}.list"
        local ret=0
 
        add_group_and_user "${pkgname}"
        local ret=0
 
        add_group_and_user "${pkgname}"
@@ -227,23 +228,29 @@ default_postinst() {
                rm -fR $root/rootfs-overlay/
        fi
 
                rm -fR $root/rootfs-overlay/
        fi
 
-       if [ -z "$root" ] && grep -q -s "^/etc/modules.d/" "/usr/lib/opkg/info/${pkgname}.list"; then
-               kmodloader
-       fi
+       if [ -z "$root" ]; then
+               if grep -m1 -q -s "^/etc/modules.d/" "$filelist"; then
+                       kmodloader
+               fi
 
 
-       if [ -z "$root" ] && grep -q -s "^/etc/uci-defaults/" "/usr/lib/opkg/info/${pkgname}.list"; then
-               . /lib/functions/system.sh
-               [ -d /tmp/.uci ] || mkdir -p /tmp/.uci
-               for i in $(grep -s "^/etc/uci-defaults/" "/usr/lib/opkg/info/${pkgname}.list"); do
-                       ( [ -f "$i" ] && cd "$(dirname $i)" && . "$i" ) && rm -f "$i"
-               done
-               uci commit
-       fi
+               if grep -m1 -q -s "^/etc/sysctl.d/" "$filelist"; then
+                       /etc/init.d/sysctl restart
+               fi
 
 
-       [ -n "$root" ] || rm -f /tmp/luci-indexcache 2>/dev/null
+               if grep -m1 -q -s "^/etc/uci-defaults/" "$filelist"; then
+                       . /lib/functions/system.sh
+                       [ -d /tmp/.uci ] || mkdir -p /tmp/.uci
+                       for i in $(grep -s "^/etc/uci-defaults/" "$filelist"); do
+                               ( [ -f "$i" ] && cd "$(dirname $i)" && . "$i" ) && rm -f "$i"
+                       done
+                       uci commit
+               fi
+
+               rm -f /tmp/luci-indexcache
+       fi
 
        local shell="$(which bash)"
 
        local shell="$(which bash)"
-       for i in $(grep -s "^/etc/init.d/" "$root/usr/lib/opkg/info/${pkgname}.list"); do
+       for i in $(grep -s "^/etc/init.d/" "$root$filelist"); do
                if [ -n "$root" ]; then
                        ${shell:-/bin/sh} "$root/etc/rc.common" "$root$i" enable
                else
                if [ -n "$root" ]; then
                        ${shell:-/bin/sh} "$root/etc/rc.common" "$root$i" enable
                else