adjust default profile, and add an evalboard one
authorImre Kaloz <kaloz@openwrt.org>
Tue, 1 Jul 2014 09:43:38 +0000 (09:43 +0000)
committerImre Kaloz <kaloz@openwrt.org>
Tue, 1 Jul 2014 09:43:38 +0000 (09:43 +0000)
Signed-off-by: Imre Kaloz <kaloz@openwrt.org>
SVN-Revision: 41435

target/linux/mvebu/profiles/100-Generic.mk
target/linux/mvebu/profiles/200-Evalboards.mk [new file with mode: 0644]

index bf1b68e06c34ac44edbb06dcda5368d69254d467..a6923118d3ad8a89ed9d3e1d65988b72c39af931 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2013 OpenWrt.org
+# Copyright (C) 2013-2014 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,14 +8,17 @@
 define Profile/Generic
   NAME:=Generic (default)
   PACKAGES:= \
-       kmod-mmc kmod-mvsdio kmod-usb2 kmod-usb-storage \
+       kmod-usb2 kmod-usb3 kmod-usb-storage \
        kmod-of-i2c kmod-i2c-core kmod-i2c-mv64xxx \
        kmod-ata-core kmod-ata-marvell-sata \
-       kmod-rtc-marvell kmod-thermal-armada
+       kmod-rtc-marvell kmod-thermal-armada \
+       kmod-gpio-button-hotplug kmod-hwmon-tmp421 \
+       kmod-hwmon-gpiofan kmod-leds-tlc59116 \
+       kmod-ledtrig-usbdev
 endef
 
 define Profile/Generic/Description
- Package set compatible with most Marvell Armada 370/XP based boards.
+ Package set compatible with most supported Marvell Armada 370/XP based boards.
 endef
 
 $(eval $(call Profile,Generic))
diff --git a/target/linux/mvebu/profiles/200-Evalboards.mk b/target/linux/mvebu/profiles/200-Evalboards.mk
new file mode 100644 (file)
index 0000000..52d0b98
--- /dev/null
@@ -0,0 +1,21 @@
+#
+# Copyright (C) 2013-2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Evalboards
+  NAME:=Evaluation / Development boards
+  PACKAGES:= \
+       kmod-mmc kmod-mvsdio kmod-usb2 kmod-usb-storage \
+       kmod-of-i2c kmod-i2c-core kmod-i2c-mv64xxx \
+       kmod-ata-core kmod-ata-marvell-sata \
+       kmod-rtc-marvell kmod-thermal-armada
+endef
+
+define Profile/Evalboards/Description
+ Package set compatible with most Marvell Armada 370/XP development based boards.
+endef
+
+$(eval $(call Profile,Evalboards))