kernel: mark kmod-usb-serial-wwan as hidden
authorYousong Zhou <yszhou4tech@gmail.com>
Wed, 30 Oct 2019 12:41:34 +0000 (12:41 +0000)
committerYousong Zhou <yszhou4tech@gmail.com>
Wed, 30 Oct 2019 12:47:17 +0000 (12:47 +0000)
The kconfig symbol is an invisible one since its introduction.  It is
not supposed to be enabled on its own.

Resolves FS#1821

Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
(cherry picked from commit 4bf9bec361699e1c033460964158531adf15d7ee)

package/kernel/linux/modules/usb.mk

index 0c5bb33f3897cf46670cc1f2d7a72ef724aab660..2bd5b390d2133095f4c22a49b301de461604185c 100644 (file)
@@ -852,6 +852,7 @@ define KernelPackage/usb-serial-wwan
   TITLE:=Support for GSM and CDMA modems
   KCONFIG:=CONFIG_USB_SERIAL_WWAN
   FILES:=$(LINUX_DIR)/drivers/usb/serial/usb_wwan.ko
+  HIDDEN:=1
   AUTOLOAD:=$(call AutoProbe,usb_wwan)
   $(call AddDepends/usb-serial)
 endef
@@ -865,11 +866,10 @@ $(eval $(call KernelPackage,usb-serial-wwan))
 
 define KernelPackage/usb-serial-option
   TITLE:=Support for Option HSDPA modems
-  DEPENDS:=+kmod-usb-serial-wwan
   KCONFIG:=CONFIG_USB_SERIAL_OPTION
   FILES:=$(LINUX_DIR)/drivers/usb/serial/option.ko
   AUTOLOAD:=$(call AutoProbe,option)
-  $(call AddDepends/usb-serial)
+  $(call AddDepends/usb-serial,+kmod-usb-serial-wwan)
 endef
 
 define KernelPackage/usb-serial-option/description