kernel: fix kmod-wireguard package fields
authorIlya Lipnitskiy <ilya.lipnitskiy@gmail.com>
Thu, 25 Feb 2021 18:20:11 +0000 (10:20 -0800)
committerHauke Mehrtens <hauke@hauke-m.de>
Sat, 10 Apr 2021 12:21:32 +0000 (14:21 +0200)
Use NETWORK_SUPPORT_MENU like all other modules in netsupport.mk. Drop
SECTION and CATEGORY fields as they are set by default and to match
other packages in netsupport.mk. Use better TITLE for kmod-wireguard
(taken from upstream drivers/net/Kconfig).

Signed-off-by: Ilya Lipnitskiy <ilya.lipnitskiy@gmail.com>
(cherry picked from commit 0b53d6f7fa8cc35cec5b22e1c64a2407fab6dfe3)

package/kernel/linux/modules/netsupport.mk

index 13f2283944535c9980418f23cd0fac86aeeef271..6bc8ba664a526109d7bf01163734169ab2fdefeb 100644 (file)
@@ -1253,10 +1253,8 @@ $(eval $(call KernelPackage,netlink-diag))
 
 
 define KernelPackage/wireguard
-  SECTION:=kernel
-  CATEGORY:=Kernel modules
-  SUBMENU:=Network Support
-  TITLE:=WireGuard kernel module
+  SUBMENU:=$(NETWORK_SUPPORT_MENU)
+  TITLE:=WireGuard secure network tunnel
   DEPENDS:= \
          +kmod-crypto-lib-blake2s \
          +kmod-crypto-lib-chacha20poly1305 \