openvpn: update to 2.4.11
authorMagnus Kroken <mkroken@gmail.com>
Wed, 21 Apr 2021 20:10:58 +0000 (22:10 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 2 May 2021 12:43:52 +0000 (14:43 +0200)
Fixes two related security vulnerabilities (CVE-2020-15078) which under
very specific circumstances allow tricking a server using delayed
authentication (plugin or management) into returning a PUSH_REPLY before
the AUTH_FAILED message, which can possibly be used to gather
information about a VPN setup.

This release also includes other bug fixes and improvements.

Signed-off-by: Magnus Kroken <mkroken@gmail.com>
package/network/services/openvpn/Makefile
package/network/services/openvpn/patches/110-openssl-dont-use-deprecated-ssleay-symbols.patch

index 5f102d967d9f7ccc46fe5b901f7122d9f97060ad..33da5688c77b2688b183d4e97f9715df93f6ce7a 100644 (file)
@@ -9,14 +9,14 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=openvpn
 
-PKG_VERSION:=2.4.9
+PKG_VERSION:=2.4.11
 PKG_RELEASE:=1
 
 PKG_SOURCE_URL:=\
        https://build.openvpn.net/downloads/releases/ \
        https://swupdate.openvpn.net/community/releases/
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
-PKG_HASH:=641f3add8694b2ccc39fd4fd92554e4f089ad16a8db6d2b473ec284839a5ebe2
+PKG_HASH:=e579eff218ab1d765965e64a917927504d8324717afdfcd56850f6b83ba8441b
 
 PKG_MAINTAINER:=Felix Fietkau <nbd@nbd.name>
 
index c7faf7c0c09ce831493ddea6d38b73ecd843fd44..a8ad6868c4425e1acecaac1f1433f70807727143 100644 (file)
@@ -47,7 +47,7 @@ Signed-off-by: Gert Doering <gert@greenie.muc.de>
  #endif
 --- a/src/openvpn/ssl_openssl.c
 +++ b/src/openvpn/ssl_openssl.c
-@@ -2008,7 +2008,7 @@ get_highest_preference_tls_cipher(char *
+@@ -2018,7 +2018,7 @@ get_highest_preference_tls_cipher(char *
  const char *
  get_ssl_library_version(void)
  {