resync patches
authorImre Kaloz <kaloz@openwrt.org>
Sun, 13 Jul 2008 22:31:24 +0000 (22:31 +0000)
committerImre Kaloz <kaloz@openwrt.org>
Sun, 13 Jul 2008 22:31:24 +0000 (22:31 +0000)
SVN-Revision: 11814

target/linux/ixp4xx/patches-2.6.26/090-increase_entropy_pools.patch
target/linux/ixp4xx/patches-2.6.26/120-compex_support.patch
target/linux/ixp4xx/patches-2.6.26/130-wrt300nv2_support.patch
target/linux/ixp4xx/patches-2.6.26/150-lanready_ap1000_support.patch
target/linux/ixp4xx/patches-2.6.26/180-tw5334_support.patch

index 55e065edb794ac7fcb460ea93bbdbf82151d32b4..ec5b6810b619a19ac690bd12c1cceb1198dbacb3 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/char/random.c
 +++ b/drivers/char/random.c
-@@ -248,9 +248,9 @@
+@@ -258,9 +258,9 @@
  /*
   * Configuration information
   */
index 76111fd53b45bbf4864dd9ed4a4285a88411ac6a..0076db28995a25397c4482525d41be116befe786 100644 (file)
@@ -1,8 +1,8 @@
 --- a/arch/arm/mach-ixp4xx/Kconfig
 +++ b/arch/arm/mach-ixp4xx/Kconfig
-@@ -81,6 +81,14 @@
- config MACH_PRONGHORNMETRO
-       def_bool MACH_PRONGHORN
+@@ -89,6 +89,14 @@
+         Engineering Sidewinder board. For more information on this
+         platform, see http://www.adiengineering.com
  
 +config MACH_COMPEX
 +      bool "Compex WP18 / NP18A"
        help
 --- a/arch/arm/mach-ixp4xx/Makefile
 +++ b/arch/arm/mach-ixp4xx/Makefile
-@@ -18,6 +18,7 @@
- obj-pci-$(CONFIG_MACH_WG302V2)                += wg302v2-pci.o
+@@ -19,6 +19,7 @@
  obj-pci-$(CONFIG_MACH_FSG)            += fsg-pci.o
  obj-pci-$(CONFIG_MACH_PRONGHORN)      += pronghorn-pci.o
+ obj-pci-$(CONFIG_MACH_SIDEWINDER)     += sidewinder-pci.o
 +obj-pci-$(CONFIG_MACH_COMPEX)         += ixdp425-pci.o
  
  obj-y += common.o
  
-@@ -34,6 +35,7 @@
- obj-$(CONFIG_MACH_WG302V2)    += wg302v2-setup.o
+@@ -36,6 +37,7 @@
  obj-$(CONFIG_MACH_FSG)                += fsg-setup.o
  obj-$(CONFIG_MACH_PRONGHORN)  += pronghorn-setup.o
+ obj-$(CONFIG_MACH_SIDEWINDER) += sidewinder-setup.o
 +obj-$(CONFIG_MACH_COMPEX)     += compex-setup.o
  
  obj-$(CONFIG_PCI)             += $(obj-pci-$(CONFIG_PCI)) common-pci.o
index edd68ecd68dc0e6648bfc1016bc656c3f8139708..4b2693355fdd936a243c807888ff0e199694a3cb 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/arm/mach-ixp4xx/Kconfig
 +++ b/arch/arm/mach-ixp4xx/Kconfig
-@@ -89,6 +89,14 @@
+@@ -97,6 +97,14 @@
          WP18 or NP18A boards. For more information on this
          platform, see http://openwrt.org
  
        help
 --- a/arch/arm/mach-ixp4xx/Makefile
 +++ b/arch/arm/mach-ixp4xx/Makefile
-@@ -19,6 +19,7 @@
- obj-pci-$(CONFIG_MACH_FSG)            += fsg-pci.o
+@@ -20,6 +20,7 @@
  obj-pci-$(CONFIG_MACH_PRONGHORN)      += pronghorn-pci.o
+ obj-pci-$(CONFIG_MACH_SIDEWINDER)     += sidewinder-pci.o
  obj-pci-$(CONFIG_MACH_COMPEX)         += ixdp425-pci.o
 +obj-pci-$(CONFIG_MACH_WRT300NV2)              += wrt300nv2-pci.o
  
  obj-y += common.o
  
-@@ -36,6 +37,7 @@
- obj-$(CONFIG_MACH_FSG)                += fsg-setup.o
+@@ -38,6 +39,7 @@
  obj-$(CONFIG_MACH_PRONGHORN)  += pronghorn-setup.o
+ obj-$(CONFIG_MACH_SIDEWINDER) += sidewinder-setup.o
  obj-$(CONFIG_MACH_COMPEX)     += compex-setup.o
 +obj-$(CONFIG_MACH_WRT300NV2)  += wrt300nv2-setup.o
  
index 9a00273551d2aee069f36329b9ce19ee2a584ac9..564a56b93e48762e02e1edcbb1028c93aafcd2c8 100644 (file)
 --- a/arch/arm/mach-ixp4xx/Makefile
 +++ b/arch/arm/mach-ixp4xx/Makefile
 @@ -21,6 +21,7 @@
+ obj-pci-$(CONFIG_MACH_SIDEWINDER)     += sidewinder-pci.o
  obj-pci-$(CONFIG_MACH_COMPEX)         += ixdp425-pci.o
  obj-pci-$(CONFIG_MACH_WRT300NV2)              += wrt300nv2-pci.o
- obj-pci-$(CONFIG_MACH_SIDEWINDER)             += sidewinder-pci.o
 +obj-pci-$(CONFIG_MACH_AP1000)         += ixdp425-pci.o
  
  obj-y += common.o
  
 @@ -40,6 +41,7 @@
+ obj-$(CONFIG_MACH_SIDEWINDER) += sidewinder-setup.o
  obj-$(CONFIG_MACH_COMPEX)     += compex-setup.o
  obj-$(CONFIG_MACH_WRT300NV2)  += wrt300nv2-setup.o
- obj-$(CONFIG_MACH_SIDEWINDER) += sidewinder-setup.o
 +obj-$(CONFIG_MACH_AP1000)     += ap1000-setup.o
  
  obj-$(CONFIG_PCI)             += $(obj-pci-$(CONFIG_PCI)) common-pci.o
index 40724203c12b681c25cb74337beb01b2a4a9804a..1439985116584be03a17664ba2ea79d316a0e935 100644 (file)
 --- a/arch/arm/mach-ixp4xx/Makefile
 +++ b/arch/arm/mach-ixp4xx/Makefile
 @@ -22,6 +22,7 @@
+ obj-pci-$(CONFIG_MACH_COMPEX)         += ixdp425-pci.o
  obj-pci-$(CONFIG_MACH_WRT300NV2)              += wrt300nv2-pci.o
- obj-pci-$(CONFIG_MACH_SIDEWINDER)             += sidewinder-pci.o
  obj-pci-$(CONFIG_MACH_AP1000)         += ixdp425-pci.o
 +obj-pci-$(CONFIG_MACH_TW5334)         += tw5334-pci.o
  
  obj-y += common.o
  
 @@ -42,6 +43,7 @@
+ obj-$(CONFIG_MACH_COMPEX)     += compex-setup.o
  obj-$(CONFIG_MACH_WRT300NV2)  += wrt300nv2-setup.o
- obj-$(CONFIG_MACH_SIDEWINDER) += sidewinder-setup.o
  obj-$(CONFIG_MACH_AP1000)     += ap1000-setup.o
 +obj-$(CONFIG_MACH_TW5334)     += tw5334-setup.o