kernel: add ath3k module package
authorJohn Crispin <john@openwrt.org>
Mon, 19 Oct 2015 10:10:20 +0000 (10:10 +0000)
committerJohn Crispin <john@openwrt.org>
Mon, 19 Oct 2015 10:10:20 +0000 (10:10 +0000)
Adds a package for the ath3k kernel module, present in 3.18/4.0/4.1 kernels

Signed-off-by: Pushpal Sidhu <psidhu@gateworks.com>
SVN-Revision: 47223

package/kernel/linux/modules/other.mk

index d438fbe7dfbf91833ba8c2bf5837ecde8c574ad4..9ff291dd0fade787ad410997e53a44ae172fa6e3 100644 (file)
@@ -78,6 +78,25 @@ endef
 
 $(eval $(call KernelPackage,bluetooth))
 
 
 $(eval $(call KernelPackage,bluetooth))
 
+define KernelPackage/ath3k
+  SUBMENU:=$(OTHER_MENU)
+  TITLE:=ATH3K Kernel Module support
+  DEPENDS:=+kmod-bluetooth +ar3k-firmware
+  KCONFIG:= \
+       CONFIG_BT_ATH3K \
+       CONFIG_BT_HCIUART_ATH3K
+  $(call AddDepends/bluetooth)
+  FILES:= \
+       $(LINUX_DIR)/drivers/bluetooth/ath3k.ko
+  AUTOLOAD:=$(call AutoProbe,ath3k)
+endef
+
+define KernelPackage/ath3k/description
+ Kernel support for ATH3K Module
+endef
+
+$(eval $(call KernelPackage,ath3k))
+
 
 define KernelPackage/bluetooth_6lowpan
   SUBMENU:=$(OTHER_MENU)
 
 define KernelPackage/bluetooth_6lowpan
   SUBMENU:=$(OTHER_MENU)