build: unbreak fakeroot in SDK
authorDaniel Golle <daniel@makrotopia.org>
Tue, 1 Sep 2020 03:08:47 +0000 (04:08 +0100)
committerDaniel Golle <daniel@makrotopia.org>
Tue, 1 Sep 2020 03:10:41 +0000 (04:10 +0100)
Using fakeroot without passing the paths to libfakeroot.sh and faked
causes havoc. Use the $(FAKEROOT) Make variable which includes them.

Fixes: 353ce2e521 ("build: ipkg-build use fakeroot with PKG_FILE_MODES")
Signed-off-by: Daniel Golle <daniel@makrotopia.org>
include/image.mk

index 3a12db367658e630ad06522903ad360239f138e5..703aeb6816254abc1698c87e2cc72faeee6832eb 100644 (file)
@@ -250,7 +250,7 @@ define Image/mkfs/squashfs
             "$(call mkfs_target_dir,$(1))" > $@.fakeroot-script
        echo "$(Image/mkfs/squashfs-common)" >> $@.fakeroot-script
        chmod +x $@.fakeroot-script
             "$(call mkfs_target_dir,$(1))" > $@.fakeroot-script
        echo "$(Image/mkfs/squashfs-common)" >> $@.fakeroot-script
        chmod +x $@.fakeroot-script
-       $(STAGING_DIR_HOST)/bin/fakeroot $@.fakeroot-script
+       $(FAKEROOT) "$@.fakeroot-script"
 endef
 else
 define Image/mkfs/squashfs
 endef
 else
 define Image/mkfs/squashfs