add libtool to tools/
authorFelix Fietkau <nbd@openwrt.org>
Tue, 25 Dec 2007 00:27:36 +0000 (00:27 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Tue, 25 Dec 2007 00:27:36 +0000 (00:27 +0000)
SVN-Revision: 9902

tools/Makefile
tools/libtool/Makefile [new file with mode: 0644]
tools/libtool/patches/001-force_dlopen_deplibs.patch [new file with mode: 0644]

index 83244fa60939b88581319b1f5f4d90c5b21c6a0b..fcde46e41118a1a046fe328e19bc78bea50389c1 100644 (file)
@@ -9,7 +9,7 @@
 curdir:=tools
 
 # subdirectories to descend into
 curdir:=tools
 
 # subdirectories to descend into
-$(curdir)/builddirs := sed sstrip ipkg-utils genext2fs squashfs mtd-utils lzma mkimage firmware-utils patch-cmdline pkg-config automake $(if $(CONFIG_CCACHE),ccache)
+$(curdir)/builddirs := sed sstrip ipkg-utils genext2fs squashfs mtd-utils lzma mkimage firmware-utils patch-cmdline pkg-config automake libtool $(if $(CONFIG_CCACHE),ccache)
 
 # builddir dependencies
 $(curdir)/squashfs/compile := $(curdir)/lzma/install
 
 # builddir dependencies
 $(curdir)/squashfs/compile := $(curdir)/lzma/install
diff --git a/tools/libtool/Makefile b/tools/libtool/Makefile
new file mode 100644 (file)
index 0000000..ad2bcd4
--- /dev/null
@@ -0,0 +1,43 @@
+# 
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=libtool
+PKG_VERSION:=1.5.22
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=@GNU/libtool
+PKG_MD5SUM:=8e0ac9797b62ba4dcc8a2fb7936412b0
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+
+include $(INCLUDE_DIR)/host-build.mk
+
+define Build/Configure
+       $(call Build/Configure/Default, \
+               --disable-shared \
+               --disable-static \
+       )
+endef
+
+define Build/Compile
+       $(MAKE) -C $(PKG_BUILD_DIR)
+endef
+
+define Build/Install
+       $(MAKE) -C $(PKG_BUILD_DIR) install
+endef
+
+define Build/Clean
+       $(MAKE) -C $(PKG_BUILD_DIR) uninstall clean 
+       $(call Build/Clean/Default)
+endef
+
+$(eval $(call HostBuild))
diff --git a/tools/libtool/patches/001-force_dlopen_deplibs.patch b/tools/libtool/patches/001-force_dlopen_deplibs.patch
new file mode 100644 (file)
index 0000000..dfcf56b
--- /dev/null
@@ -0,0 +1,14 @@
+diff -urN libtool-1.5.14/libltdl/acinclude.m4 libtool-1.5.14.new/libltdl/acinclude.m4
+--- libtool-1.5.14/libltdl/acinclude.m4        2005-02-12 13:20:02.000000000 +0100
++++ libtool-1.5.14.new/libltdl/acinclude.m4    2006-04-17 23:00:24.000000000 +0200
+@@ -6228,10 +6228,8 @@
+     ;;
+   esac
+   ])
+-if test "$libltdl_cv_sys_dlopen_deplibs" != yes; then
+  AC_DEFINE([LTDL_DLOPEN_DEPLIBS], [1],
+     [Define if the OS needs help to load dependent libraries for dlopen().])
+-fi
+ ])# AC_LTDL_SYS_DLOPEN_DEPLIBS