add support for user9102 boards (#4537)
authorFlorian Fainelli <florian@openwrt.org>
Sat, 31 Jan 2009 16:01:20 +0000 (16:01 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sat, 31 Jan 2009 16:01:20 +0000 (16:01 +0000)
SVN-Revision: 14305

target/linux/brcm63xx/files/arch/mips/bcm63xx/boards/board_bcm963xx.c
target/linux/brcm63xx/image/Makefile

index 7dd77f00823f788440574b2e0e4a4301294fe331..76dd54013f5c1b5b1eb13aa80918abf0a1b84237 100644 (file)
@@ -184,6 +184,27 @@ static struct board_info __initdata board_DV201AMR = {
         .has_ehci0 = 1,
 };
 
+static struct board_info __initdata board_96348gw_a = {
+       .name                           = "96348GW-A",
+       .expected_cpu_id                = 0x6348,
+
+       .has_enet0                      = 1,
+       .has_enet1                      = 1,
+       .has_pci                        = 1,
+
+       .enet0 = {
+               .has_phy                = 1,
+               .use_internal_phy       = 1,
+       },
+       .enet1 = {
+               .force_speed_100        = 1,
+               .force_duplex_full      = 1,
+       },
+
+       .has_ohci0 = 1,
+};
+
+
 #endif
 
 /*
@@ -253,6 +274,7 @@ static const struct board_info __initdata *bcm963xx_boards[] = {
        &board_96348gw_11,
        &board_FAST2404,
        &board_DV201AMR,
+       &board_96348gw_a,
 #endif
 
 #ifdef CONFIG_BCM63XX_CPU_6358
index c9a728bbf294a9be956f81ce53a9f9b03f0153cd..6cb7a34c01d72d7aadfc862f8a6c5b443734f4b9 100644 (file)
@@ -96,6 +96,8 @@ define Image/Build
        $(call Image/Build/CFE,$(1),96348GW-11,6348)
        # Davolink DV201AMR
        $(call Image/Build/CFEOLD,$(1),DV201AMR,6348)
+       # USR 9108
+       $(call Image/Build/CFE,$(1),96348GW-A,6348)
        # DG834GT
        $(call Image/Build/CFE,$(1),96348GW-10,6348)
        # Sagem F@ST2404