acx-mac80211: update to 20122204
authorFlorian Fainelli <florian@openwrt.org>
Tue, 24 Apr 2012 08:05:46 +0000 (08:05 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Tue, 24 Apr 2012 08:05:46 +0000 (08:05 +0000)
Upstream commit id: 15bbffea

SVN-Revision: 31455

package/acx-mac80211/Makefile
package/acx-mac80211/patches/003-build_as_modules.patch
package/acx-mac80211/patches/004-ratelimit_compile_fix.patch

index 5b560c0610d6d421e8ba42dd1342471de92eeb8e..46fe7712ce16bca0d40f6bc32539d546bfacd78b 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007-2011 OpenWrt.org
+# Copyright (C) 2007-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,8 +9,8 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=acx-mac80211
-PKG_REV:=09bebfda18d7000bfeaa4d5d49db90ef601f23a3
-PKG_VERSION:=20111030
+PKG_REV:=15bbffeadc1928a21a8a5f6519a5aea13b50678a
+PKG_VERSION:=20120422
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
index 31a6aae6cfd796de0aa86e59f4d45423f20e497d..e0a3fd0e72c08b639c26b2c8d4c7ca73150f48ea 100644 (file)
@@ -1,11 +1,13 @@
---- a/Makefile
-+++ b/Makefile
-@@ -29,7 +29,7 @@ ifneq ($(KERNELRELEASE),)
+Index: acx-mac80211-20120422/Makefile
+===================================================================
+--- acx-mac80211-20120422.orig/Makefile        2012-04-23 17:35:13.000000000 +0200
++++ acx-mac80211-20120422/Makefile     2012-04-23 17:36:55.386257951 +0200
+@@ -30,7 +30,7 @@
        acx-mac80211-obj-$(CONFIG_ACX_MAC80211_PCI) += pci.o
        acx-mac80211-obj-$(CONFIG_ACX_MAC80211_USB) += usb.o
        acx-mac80211-obj-$(CONFIG_ACX_MAC80211_MEM) += mem.o
--      acx-mac80211-objs := common.o $(acx-mac80211-obj-y)
-+      acx-mac80211-objs := common.o $(acx-mac80211-obj-m)
-       
+-      acx-mac80211-objs := common.o $(acx-mac80211-obj-y) merge.o
++      acx-mac80211-objs := common.o $(acx-mac80211-obj-m) merge.o
  else
  # Otherwise we were called directly from the command line: the kernel build
index 34ba08d9b94e7f9be6d5d835ad0efe40d5b01b40..a30e3dc7dc7efff9c6ba7297a01c10965c547655 100644 (file)
@@ -1,6 +1,8 @@
---- a/common.c
-+++ b/common.c
-@@ -31,6 +31,7 @@
+Index: acx-mac80211-20120422/common.c
+===================================================================
+--- acx-mac80211-20120422.orig/common.c        2012-04-23 17:35:13.000000000 +0200
++++ acx-mac80211-20120422/common.c     2012-04-23 17:37:02.818257747 +0200
+@@ -33,6 +33,7 @@
  #include <linux/ethtool.h>
  #include <linux/nl80211.h>
  #include <linux/ieee80211.h>