mt76: Fix compile against glibc
authorHauke Mehrtens <hauke@hauke-m.de>
Thu, 17 Dec 2020 12:58:01 +0000 (13:58 +0100)
committerHauke Mehrtens <hauke@hauke-m.de>
Sat, 19 Dec 2020 22:18:38 +0000 (23:18 +0100)
The mt76 test tools did not compile against glibc.

Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
package/kernel/mt76/Makefile
package/kernel/mt76/patches/100-tools-Set-mode-for-new-file-tmp-mt76-test-s.patch [new file with mode: 0644]

index fd39d7a56149f725befa3149dff037d3bfd4757a..8e971f2ada0b65435c9c5fe4106ddcbfc1a7fdc7 100644 (file)
@@ -1,7 +1,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=mt76
-PKG_RELEASE=2
+PKG_RELEASE=3
 
 PKG_LICENSE:=GPLv2
 PKG_LICENSE_FILES:=
diff --git a/package/kernel/mt76/patches/100-tools-Set-mode-for-new-file-tmp-mt76-test-s.patch b/package/kernel/mt76/patches/100-tools-Set-mode-for-new-file-tmp-mt76-test-s.patch
new file mode 100644 (file)
index 0000000..71b43a1
--- /dev/null
@@ -0,0 +1,25 @@
+From fe89f9bc4055fd6055ce8792a715a40a6c75ba44 Mon Sep 17 00:00:00 2001
+From: Hauke Mehrtens <hauke@hauke-m.de>
+Date: Thu, 17 Dec 2020 13:54:04 +0100
+Subject: [PATCH] tools: Set mode for new file /tmp/mt76-test-%s
+
+Set the file system mode for the newly created file /tmp/mt76-test-%s,
+this is mandatory according to the man page and fixes a compile error
+with glibc.
+
+Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
+---
+ tools/eeprom.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+--- a/tools/eeprom.c
++++ b/tools/eeprom.c
+@@ -77,7 +77,7 @@ mt76_eeprom_create_file(void)
+               return -1;
+       }
+-      fd = open(eeprom_file, O_RDWR | O_CREAT | O_EXCL);
++      fd = open(eeprom_file, O_RDWR | O_CREAT | O_EXCL, 00644);
+       if (fd < 0)
+               goto out;