make the buildroot-ng sdk compatible with the old packages
authorFelix Fietkau <nbd@openwrt.org>
Tue, 18 Jul 2006 20:17:05 +0000 (20:17 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Tue, 18 Jul 2006 20:17:05 +0000 (20:17 +0000)
SVN-Revision: 4158

openwrt/include/package.mk
openwrt/target/sdk/Makefile
openwrt/target/sdk/files/Makefile [new file with mode: 0644]
openwrt/target/sdk/files/Makefile.sdk [deleted file]
openwrt/target/sdk/files/package/depend.mk [new file with mode: 0644]
openwrt/target/sdk/files/package/rules.mk [new file with mode: 0644]

index 2784cc888175d20fc0adb102d1fc1669a775fd46..ce07640eeda5d47573a34d4034669a41accbb044 100644 (file)
@@ -41,6 +41,7 @@ define Build/DefaultTargets
        touch $$@
 
   $(STAGING_DIR)/stampfiles/.$(PKG_NAME)-installed: $(PKG_BUILD_DIR)/.built
+       mkdir -p $(STAGING_DIR)/stampfiles
        $(call Build/InstallDev)
        touch $$@
        
index 25d2acc57cf71f2f1dd998da49258569babe0493..0552b0aaa81f204cef6dd40e283bf67edd429847 100644 (file)
@@ -28,8 +28,9 @@ $(BIN_DIR)/$(SDK_NAME).tar.bz2:
        $(CP) $(STAGING_DIR) $(INCLUDE_DIR) $(SCRIPT_DIR) $(TOPDIR)/docs $(SDK_BUILD_DIR)/
        $(CP) $(TOPDIR)/rules.mk $(TOPDIR)/.config $(SDK_BUILD_DIR)/
        $(CP) $(TOPDIR)/package/Makefile $(SDK_BUILD_DIR)/package/
-       $(CP) ./files/Makefile.sdk $(SDK_BUILD_DIR)/Makefile
+       $(CP) ./files/Makefile $(SDK_BUILD_DIR)/
        $(CP) ./files/README.SDK $(SDK_BUILD_DIR)/
+       $(CP) ./files/package/rules.mk $(SDK_BUILD_DIR)/package/
        echo OPENWRTVERSION:=$(OPENWRTVERSION) > $(SDK_BUILD_DIR)/.version.mk
        find $(SDK_BUILD_DIR) -name .svn | xargs rm -rf 
        find $(SDK_BUILD_DIR) -name CVS | xargs rm -rf 
diff --git a/openwrt/target/sdk/files/Makefile b/openwrt/target/sdk/files/Makefile
new file mode 100644 (file)
index 0000000..ba488e3
--- /dev/null
@@ -0,0 +1,69 @@
+# Makefile for OpenWrt
+#
+# Copyright (C) 2006 by Felix Fietkau <openwrt@nbd.name>
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+#
+
+RELEASE:=Kamikaze
+#VERSION:=2.0 # uncomment for final release
+
+#--------------------------------------------------------------
+# Just run 'make menuconfig', configure stuff, then run 'make'.
+# You shouldn't need to mess with anything beyond this point...
+#--------------------------------------------------------------
+TOPDIR=${shell pwd}
+export TOPDIR
+
+DEVELOPER=1
+export DEVELOPER
+
+all: world
+
+.pkginfo: FORCE
+ifneq ($(shell ./scripts/timestamp.pl -p .pkginfo package Makefile),.pkginfo)
+       @echo Collecting package info...
+       @-for dir in package/*/; do \
+               echo Source-Makefile: $${dir}Makefile; \
+               $(MAKE) --no-print-dir DUMP=1 -C $$dir 2>&- || true; \
+       done > $@
+endif
+
+pkginfo-clean: FORCE
+       -rm -f .pkginfo .config.in
+
+package/%: .pkginfo FORCE
+       $(MAKE) -C package $(patsubst package/%,%,$@) SDK=1
+
+download: FORCE
+       $(MAKE) package/download
+
+world: FORCE
+       $(MAKE) package/compile
+       -( \
+               cd package; \
+               find . -maxdepth 2 -name Config.in | \
+                       sed -e 's,/Config.in,,g' | \
+                       xargs -r -n1 make compile -C; \
+       )
+
+clean: FORCE
+       rm -rf build_* bin
+
+distclean: clean
+       rm -rf dl .pkg*
+
+.PHONY: FORCE
+FORCE:
diff --git a/openwrt/target/sdk/files/Makefile.sdk b/openwrt/target/sdk/files/Makefile.sdk
deleted file mode 100644 (file)
index 5072323..0000000
+++ /dev/null
@@ -1,66 +0,0 @@
-# Makefile for OpenWrt
-#
-# Copyright (C) 2006 by Felix Fietkau <openwrt@nbd.name>
-#
-# This program is free software; you can redistribute it and/or modify
-# it under the terms of the GNU General Public License as published by
-# the Free Software Foundation; either version 2 of the License, or
-# (at your option) any later version.
-#
-# This program is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
-# General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with this program; if not, write to the Free Software
-# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
-#
-
-RELEASE:=Kamikaze
-#VERSION:=2.0 # uncomment for final release
-
-#--------------------------------------------------------------
-# Just run 'make menuconfig', configure stuff, then run 'make'.
-# You shouldn't need to mess with anything beyond this point...
-#--------------------------------------------------------------
-TOPDIR=${shell pwd}
-export TOPDIR
-
-include $(TOPDIR)/.version.mk
-export OPENWRTVERSION
-
-DEVELOPER=1
-export DEVELOPER
-
-all: world
-
-.pkginfo: FORCE
-ifneq ($(shell ./scripts/timestamp.pl -p .pkginfo package Makefile),.pkginfo)
-       @echo Collecting package info...
-       @-for dir in package/*/; do \
-               echo Source-Makefile: $${dir}Makefile; \
-               $(MAKE) --no-print-dir DUMP=1 -C $$dir 2>&- || true; \
-       done > $@
-endif
-
-pkginfo-clean: FORCE
-       -rm -f .pkginfo .config.in
-
-package/%: .pkginfo FORCE
-       $(MAKE) -C package $(patsubst package/%,%,$@) SDK=1
-
-download: FORCE
-       $(MAKE) package/download
-
-world: FORCE
-       $(MAKE) package/compile
-
-clean: FORCE
-       rm -rf build_* bin
-
-distclean: clean
-       rm -rf dl .pkg*
-
-.PHONY: FORCE
-FORCE:
diff --git a/openwrt/target/sdk/files/package/depend.mk b/openwrt/target/sdk/files/package/depend.mk
new file mode 100644 (file)
index 0000000..d7b844d
--- /dev/null
@@ -0,0 +1,6 @@
+# You can put your package dependencies in here
+# Example (make openvpn depend on openssl):
+#      openvpn-compile: openssl-compile
+#
+# Note: This file is not present in the full buildroot. There you
+# have to put your package dependencies in buildroot/package/Makefile
diff --git a/openwrt/target/sdk/files/package/rules.mk b/openwrt/target/sdk/files/package/rules.mk
new file mode 100644 (file)
index 0000000..b3f4cdb
--- /dev/null
@@ -0,0 +1,89 @@
+# invoke ipkg with configuration in $(STAGING_DIR)/etc/ipkg.conf 
+IPKG := IPKG_INSTROOT=$(TARGET_DIR) IPKG_CONF_DIR=$(IPKG_CONF) $(SCRIPT_DIR)/ipkg -force-defaults -force-depends
+IPKG_STATE_DIR := $(TARGET_DIR)/usr/lib/ipkg
+
+ifneq ($(DUMP),)
+dump:
+.PHONY: dump
+endif
+
+define PKG_template
+IPKG_$(1):=$(PACKAGE_DIR)/$(2)_$(3)_$(4).ipk
+IDIR_$(1):=$(PKG_BUILD_DIR)/ipkg/$(2)
+INFO_$(1):=$(IPKG_STATE_DIR)/info/$(2).list
+
+ifneq ($(BR2_PACKAGE_$(1)),)
+compile-targets: $$(IPKG_$(1))
+endif
+ifneq ($(DEVELOPER),)
+compile-targets: $$(IPKG_$(1))
+endif
+ifeq ($(BR2_PACKAGE_$(1)),y)
+install-targets: $$(INFO_$(1))
+endif
+
+IDEPEND_$(1):=$$(strip $(5))
+
+$$(IDIR_$(1))/CONTROL/control: $(PKG_BUILD_DIR)/.prepared
+       $(SCRIPT_DIR)/make-ipkg-dir.sh $$(IDIR_$(1)) ./ipkg/$(2).control $(3) $(4)
+       if [ "$$(IDEPEND_$(1))" != "" ]; then echo "Depends: $$(IDEPEND_$(1))" >> $$(IDIR_$(1))/CONTROL/control; fi
+       for file in conffiles preinst postinst prerm postrm; do \
+               [ -f ./ipkg/$(2).$$$$file ] && cp ./ipkg/$(2).$$$$file $$(IDIR_$(1))/CONTROL/$$$$file || true; \
+       done
+
+$$(IPKG_$(1)): $$(IDIR_$(1))/CONTROL/control $(PKG_BUILD_DIR)/.built $(PACKAGE_DIR)
+
+$$(INFO_$(1)): $$(IPKG_$(1))
+       $(IPKG) install $$(IPKG_$(1))
+
+$(2)-clean:
+       rm -f $$(IPKG_$(1))
+clean-targets: $(2)-clean
+endef
+
+ifeq ($(DUMP),)
+ifneq ($(strip $(PKG_SOURCE)),)
+$(DL_DIR)/$(PKG_SOURCE):
+       $(SCRIPT_DIR)/download.pl "$(DL_DIR)" "$(PKG_SOURCE)" "$(PKG_MD5SUM)" $(PKG_SOURCE_URL)
+endif
+
+ifneq ($(strip $(PKG_CAT)),)
+$(PKG_BUILD_DIR)/.prepared: $(DL_DIR)/$(PKG_SOURCE)
+       rm -rf $(PKG_BUILD_DIR)
+       mkdir -p $(PKG_BUILD_DIR)
+       $(PKG_CAT) $(DL_DIR)/$(PKG_SOURCE) | tar -C $(PKG_BUILD_DIR)/.. $(TAR_OPTIONS) -
+       if [ -d ./patches ]; then \
+               $(PATCH) $(PKG_BUILD_DIR) ./patches ; \
+       fi
+       touch $(PKG_BUILD_DIR)/.prepared
+endif
+
+all: compile
+
+compile-targets:
+install-targets:
+clean-targets:
+
+source: $(DL_DIR)/$(PKG_SOURCE)
+prepare: $(PKG_BUILD_DIR)/.prepared
+compile: compile-targets
+install: install-targets
+mostlyclean:
+rebuild:
+       -$(MAKE) mostlyclean
+       if [ -f $(PKG_BUILD_DIR)/.built ]; then \
+               $(MAKE) clean; \
+       fi
+       $(MAKE) compile
+
+$(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.prepared
+$(PKG_BUILD_DIR)/.built: $(PKG_BUILD_DIR)/.configured
+
+$(PACKAGE_DIR):
+       mkdir -p $@
+
+clean: clean-targets
+       rm -rf $(PKG_BUILD_DIR)
+
+.PHONY: all source prepare compile install clean
+endif