6in4: bypass uci state when reading local IPv4 addr, specify TTL during tunnel creati...
authorJo-Philipp Wich <jow@openwrt.org>
Thu, 19 Aug 2010 00:59:05 +0000 (00:59 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Thu, 19 Aug 2010 00:59:05 +0000 (00:59 +0000)
SVN-Revision: 22708

package/6in4/Makefile
package/6in4/files/6in4.sh

index 289d28ee3f32234ec53ee6a5f69873097bb403ed..c56b9c57ce37953fe24c5ca8a7d9f985c391f73d 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=6in4
-PKG_VERSION:=4
+PKG_VERSION:=5
 PKG_RELEASE:=1
 
 include $(INCLUDE_DIR)/package.mk
index a119138d0f78cd899239bd7778336ed649834177..bea2e82ea36e93a709df2a2b9c15fd81ae56d206 100755 (executable)
@@ -28,8 +28,7 @@ setup_interface_6in4() {
        local cfg="$2"
        local link="6in4-$cfg"
 
-       local local4
-       config_get local4 "$cfg" ipaddr
+       local local4=$(uci_get network "$cfg" local4)
 
        local remote4
        config_get remote4 "$cfg" peeraddr
@@ -62,10 +61,9 @@ setup_interface_6in4() {
                uci_set_state network "$cfg" ifname $link
                uci_set_state network "$cfg" auto 0
 
-               ip tunnel add $link mode sit remote $remote4 local $local4 ttl 255
+               ip tunnel add $link mode sit remote $remote4 local $local4 ttl ${ttl:-64}
                ip link set $link up
                ip link set mtu ${mtu:-1280} dev $link
-               ip tunnel change $link ttl ${ttl:-64}
                ip addr add $local6 dev $link
 
                uci_set_state network "$cfg" ipaddr $local4