toolchain/gdb: Update to 7.11
authorJohn Crispin <john@openwrt.org>
Thu, 10 Mar 2016 19:11:41 +0000 (19:11 +0000)
committerJohn Crispin <john@openwrt.org>
Thu, 10 Mar 2016 19:11:41 +0000 (19:11 +0000)
Update gdb to version 7.11

Signed-off-by: Hannu Nyman <hannu.nyman@iki.fi>
SVN-Revision: 48989

toolchain/gdb/Makefile
toolchain/gdb/patches/7.10.1/100-no_extern_inline.patch [deleted file]
toolchain/gdb/patches/7.10.1/110-no_testsuite.patch [deleted file]
toolchain/gdb/patches/7.10.1/120-fix-compile-flag-mismatch.patch [deleted file]
toolchain/gdb/patches/7.11/100-no_extern_inline.patch [new file with mode: 0644]
toolchain/gdb/patches/7.11/110-no_testsuite.patch [new file with mode: 0644]
toolchain/gdb/patches/7.11/120-fix-compile-flag-mismatch.patch [new file with mode: 0644]

index 19f49311591f99232478d0a7c48e1234863385e4..0e1b0a27bce199a02ced791e5fc872c2a186a3a3 100644 (file)
@@ -16,11 +16,11 @@ PKG_SOURCE_URL:=https://github.com/foss-for-synopsys-dwc-arc-processors/binutils
 PKG_MD5SUM:=d318829bfd2ed62714817f0d25706825
 GDB_DIR:=binutils-$(PKG_NAME)-$(PKG_VERSION)
 else
-PKG_VERSION:=7.10.1
+PKG_VERSION:=7.11
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@GNU/gdb
-PKG_MD5SUM:=39e654460c9cdd80200a29ac020cfe11
+PKG_MD5SUM:=b5c784685e1cde65ba135feea86b6d75
 GDB_DIR:=$(PKG_NAME)-$(PKG_VERSION)
 endif
 
diff --git a/toolchain/gdb/patches/7.10.1/100-no_extern_inline.patch b/toolchain/gdb/patches/7.10.1/100-no_extern_inline.patch
deleted file mode 100644 (file)
index 8c18c6e..0000000
+++ /dev/null
@@ -1,32 +0,0 @@
---- a/sim/common/sim-arange.c
-+++ b/sim/common/sim-arange.c
-@@ -280,11 +280,7 @@ sim_addr_range_delete (ADDR_RANGE *ar, a
-   build_search_tree (ar);
- }
--#endif /* DEFINE_NON_INLINE_P */
--
--#if DEFINE_INLINE_P
--
--SIM_ARANGE_INLINE int
-+int
- sim_addr_range_hit_p (ADDR_RANGE *ar, address_word addr)
- {
-   ADDR_RANGE_TREE *t = ar->range_tree;
-@@ -301,4 +297,4 @@ sim_addr_range_hit_p (ADDR_RANGE *ar, ad
-   return 0;
- }
--#endif /* DEFINE_INLINE_P */
-+#endif /* DEFINE_NON_INLINE_P */
---- a/sim/common/sim-arange.h
-+++ b/sim/common/sim-arange.h
-@@ -73,7 +73,7 @@ extern void sim_addr_range_delete (ADDR_
- /* Return non-zero if ADDR is in range AR, traversing the entire tree.
-    If no range is specified, that is defined to mean "everything".  */
--SIM_ARANGE_INLINE int
-+extern int
- sim_addr_range_hit_p (ADDR_RANGE * /*ar*/, address_word /*addr*/);
- #define ADDR_RANGE_HIT_P(ar, addr) \
-   ((ar)->range_tree == NULL || sim_addr_range_hit_p ((ar), (addr)))
diff --git a/toolchain/gdb/patches/7.10.1/110-no_testsuite.patch b/toolchain/gdb/patches/7.10.1/110-no_testsuite.patch
deleted file mode 100644 (file)
index 1b284ea..0000000
+++ /dev/null
@@ -1,21 +0,0 @@
---- a/gdb/configure
-+++ b/gdb/configure
-@@ -870,8 +870,7 @@ MAKEINFOFLAGS
- YACC
- YFLAGS
- XMKMF'
--ac_subdirs_all='testsuite
--gdbtk
-+ac_subdirs_all='gdbtk
- multi-ice
- gdbserver'
-@@ -5610,7 +5610,7 @@ $as_echo "$with_auto_load_safe_path" >&6
--subdirs="$subdirs testsuite"
-+subdirs="$subdirs"
- # Check whether to support alternative target configurations
diff --git a/toolchain/gdb/patches/7.10.1/120-fix-compile-flag-mismatch.patch b/toolchain/gdb/patches/7.10.1/120-fix-compile-flag-mismatch.patch
deleted file mode 100644 (file)
index c8b41f2..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/gdb/gdbserver/configure
-+++ b/gdb/gdbserver/configure
-@@ -2468,7 +2468,7 @@ $as_echo "$as_me: error: \`$ac_var' was
-       ac_cache_corrupted=: ;;
-     ,);;
-     *)
--      if test "x$ac_old_val" != "x$ac_new_val"; then
-+      if test "`echo x$ac_old_val`" != "`echo x$ac_new_val`"; then
-       # differences in whitespace do not lead to failure.
-       ac_old_val_w=`echo x $ac_old_val`
-       ac_new_val_w=`echo x $ac_new_val`
diff --git a/toolchain/gdb/patches/7.11/100-no_extern_inline.patch b/toolchain/gdb/patches/7.11/100-no_extern_inline.patch
new file mode 100644 (file)
index 0000000..8c18c6e
--- /dev/null
@@ -0,0 +1,32 @@
+--- a/sim/common/sim-arange.c
++++ b/sim/common/sim-arange.c
+@@ -280,11 +280,7 @@ sim_addr_range_delete (ADDR_RANGE *ar, a
+   build_search_tree (ar);
+ }
+-#endif /* DEFINE_NON_INLINE_P */
+-
+-#if DEFINE_INLINE_P
+-
+-SIM_ARANGE_INLINE int
++int
+ sim_addr_range_hit_p (ADDR_RANGE *ar, address_word addr)
+ {
+   ADDR_RANGE_TREE *t = ar->range_tree;
+@@ -301,4 +297,4 @@ sim_addr_range_hit_p (ADDR_RANGE *ar, ad
+   return 0;
+ }
+-#endif /* DEFINE_INLINE_P */
++#endif /* DEFINE_NON_INLINE_P */
+--- a/sim/common/sim-arange.h
++++ b/sim/common/sim-arange.h
+@@ -73,7 +73,7 @@ extern void sim_addr_range_delete (ADDR_
+ /* Return non-zero if ADDR is in range AR, traversing the entire tree.
+    If no range is specified, that is defined to mean "everything".  */
+-SIM_ARANGE_INLINE int
++extern int
+ sim_addr_range_hit_p (ADDR_RANGE * /*ar*/, address_word /*addr*/);
+ #define ADDR_RANGE_HIT_P(ar, addr) \
+   ((ar)->range_tree == NULL || sim_addr_range_hit_p ((ar), (addr)))
diff --git a/toolchain/gdb/patches/7.11/110-no_testsuite.patch b/toolchain/gdb/patches/7.11/110-no_testsuite.patch
new file mode 100644 (file)
index 0000000..3a9c1e7
--- /dev/null
@@ -0,0 +1,21 @@
+--- a/gdb/configure
++++ b/gdb/configure
+@@ -873,8 +873,7 @@ MAKEINFOFLAGS
+ YACC
+ YFLAGS
+ XMKMF'
+-ac_subdirs_all='testsuite
+-gdbtk
++ac_subdirs_all='gdbtk
+ multi-ice
+ gdbserver'
+@@ -5660,7 +5660,7 @@ $as_echo "$with_auto_load_safe_path" >&6
+-subdirs="$subdirs testsuite"
++subdirs="$subdirs"
+ # Check whether to support alternative target configurations
diff --git a/toolchain/gdb/patches/7.11/120-fix-compile-flag-mismatch.patch b/toolchain/gdb/patches/7.11/120-fix-compile-flag-mismatch.patch
new file mode 100644 (file)
index 0000000..d7c8df4
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/gdb/gdbserver/configure
++++ b/gdb/gdbserver/configure
+@@ -2520,7 +2520,7 @@ $as_echo "$as_me: error: \`$ac_var' was
+       ac_cache_corrupted=: ;;
+     ,);;
+     *)
+-      if test "x$ac_old_val" != "x$ac_new_val"; then
++      if test "`echo x$ac_old_val`" != "`echo x$ac_new_val`"; then
+       # differences in whitespace do not lead to failure.
+       ac_old_val_w=`echo x $ac_old_val`
+       ac_new_val_w=`echo x $ac_new_val`