fix ipset bitops not working
authorTim Yardley <lst@openwrt.org>
Thu, 7 Jun 2007 17:43:50 +0000 (17:43 +0000)
committerTim Yardley <lst@openwrt.org>
Thu, 7 Jun 2007 17:43:50 +0000 (17:43 +0000)
SVN-Revision: 7520

package/ipset/Makefile
package/ipset/patches/001-kernel_26.patch

index f3b451d624d2bb49ae3ba87bbf8d0d9eda909c88..b06a727f10b15d10505e2310e1033f126ab6a71b 100644 (file)
@@ -29,6 +29,7 @@ define Build/Compile
        $(call Build/Compile/Default, \
                COPT_FLAGS="$(TARGET_CFLAGS)" \
                KERNEL_DIR="$(LINUX_DIR)" \
        $(call Build/Compile/Default, \
                COPT_FLAGS="$(TARGET_CFLAGS)" \
                KERNEL_DIR="$(LINUX_DIR)" \
+               PREFIX="/usr" \
        )
 endef
 
        )
 endef
 
index 4101f46bf9182780870778b92a4e51f314118c84..e8c0be9bba9c4161cef1448d800d27c20655325c 100644 (file)
@@ -1,72 +1,72 @@
-Index: ipset-2.2.3/ipset.c
-===================================================================
---- ipset-2.2.3.orig/ipset.c   2007-06-04 13:22:37.544147704 +0200
-+++ ipset-2.2.3/ipset.c        2007-06-04 13:22:37.644132504 +0200
-@@ -21,7 +21,6 @@
+diff -ruN ipset-2.2.3/ipset.c ipset-2.2.3.new/ipset.c
+--- ipset-2.2.3/ipset.c        2005-04-05 02:56:02.000000000 -0500
++++ ipset-2.2.3.new/ipset.c    2007-05-31 14:05:13.763087750 -0500
+@@ -21,7 +21,7 @@
  #include <stdarg.h>
  #include <netdb.h>
  #include <dlfcn.h>
 -#include <asm/bitops.h>
  #include <stdarg.h>
  #include <netdb.h>
  #include <dlfcn.h>
 -#include <asm/bitops.h>
++#include <linux/bitops.h>
  
  #include "ipset.h"
  
  
  #include "ipset.h"
  
-Index: ipset-2.2.3/ipset_iphash.c
-===================================================================
---- ipset-2.2.3.orig/ipset_iphash.c    2007-06-04 13:22:37.550146792 +0200
-+++ ipset-2.2.3/ipset_iphash.c 2007-06-04 13:22:37.644132504 +0200
-@@ -25,7 +25,6 @@
+diff -ruN ipset-2.2.3/ipset_iphash.c ipset-2.2.3.new/ipset_iphash.c
+--- ipset-2.2.3/ipset_iphash.c 2005-01-19 07:38:57.000000000 -0600
++++ ipset-2.2.3.new/ipset_iphash.c     2007-05-31 14:05:32.212240750 -0500
+@@ -25,7 +25,7 @@
  #include <sys/types.h>
  #include <netinet/in.h>
  #include <arpa/inet.h>
 -#include <asm/bitops.h>
  #include <sys/types.h>
  #include <netinet/in.h>
  #include <arpa/inet.h>
 -#include <asm/bitops.h>
++#include <linux/bitops.h>
  #include <asm/types.h>
  
  #include <linux/netfilter_ipv4/ip_set_iphash.h>
  #include <asm/types.h>
  
  #include <linux/netfilter_ipv4/ip_set_iphash.h>
-Index: ipset-2.2.3/ipset_ipmap.c
-===================================================================
---- ipset-2.2.3.orig/ipset_ipmap.c     2007-06-04 13:22:37.556145880 +0200
-+++ ipset-2.2.3/ipset_ipmap.c  2007-06-04 13:22:37.644132504 +0200
-@@ -22,7 +22,6 @@
+diff -ruN ipset-2.2.3/ipset_ipmap.c ipset-2.2.3.new/ipset_ipmap.c
+--- ipset-2.2.3/ipset_ipmap.c  2005-01-19 07:38:57.000000000 -0600
++++ ipset-2.2.3.new/ipset_ipmap.c      2007-05-31 14:05:47.969225500 -0500
+@@ -22,7 +22,7 @@
  #include <sys/socket.h>
  #include <netinet/in.h>
  #include <arpa/inet.h>
 -#include <asm/bitops.h>
  #include <sys/socket.h>
  #include <netinet/in.h>
  #include <arpa/inet.h>
 -#include <asm/bitops.h>
++#include <linux/bitops.h>
  
  #include <linux/netfilter_ipv4/ip_set_ipmap.h>
  #include "ipset.h"
  
  #include <linux/netfilter_ipv4/ip_set_ipmap.h>
  #include "ipset.h"
-Index: ipset-2.2.3/ipset_macipmap.c
-===================================================================
---- ipset-2.2.3.orig/ipset_macipmap.c  2007-06-04 13:22:37.561145120 +0200
-+++ ipset-2.2.3/ipset_macipmap.c       2007-06-04 13:22:37.645132352 +0200
-@@ -24,7 +24,6 @@
+diff -ruN ipset-2.2.3/ipset_macipmap.c ipset-2.2.3.new/ipset_macipmap.c
+--- ipset-2.2.3/ipset_macipmap.c       2005-01-19 07:38:57.000000000 -0600
++++ ipset-2.2.3.new/ipset_macipmap.c   2007-05-31 14:06:17.627079000 -0500
+@@ -24,7 +24,7 @@
  #include <sys/socket.h>
  #include <netinet/in.h>
  #include <arpa/inet.h>
 -#include <asm/bitops.h>
  #include <sys/socket.h>
  #include <netinet/in.h>
  #include <arpa/inet.h>
 -#include <asm/bitops.h>
++#include <linux/bitops.h>
  #include <linux/if_ether.h>
  
  #include <linux/netfilter_ipv4/ip_set_macipmap.h>
  #include <linux/if_ether.h>
  
  #include <linux/netfilter_ipv4/ip_set_macipmap.h>
-Index: ipset-2.2.3/ipset_nethash.c
-===================================================================
---- ipset-2.2.3.orig/ipset_nethash.c   2007-06-04 13:22:37.567144208 +0200
-+++ ipset-2.2.3/ipset_nethash.c        2007-06-04 13:22:37.645132352 +0200
-@@ -25,7 +25,6 @@
+diff -ruN ipset-2.2.3/ipset_nethash.c ipset-2.2.3.new/ipset_nethash.c
+--- ipset-2.2.3/ipset_nethash.c        2005-05-09 00:44:25.000000000 -0500
++++ ipset-2.2.3.new/ipset_nethash.c    2007-05-31 14:06:43.392689250 -0500
+@@ -25,7 +25,7 @@
  #include <sys/types.h>
  #include <netinet/in.h>
  #include <arpa/inet.h>
 -#include <asm/bitops.h>
  #include <sys/types.h>
  #include <netinet/in.h>
  #include <arpa/inet.h>
 -#include <asm/bitops.h>
++#include <linux/bitops.h>
  #include <asm/types.h>
  
  #include <linux/netfilter_ipv4/ip_set_nethash.h>
  #include <asm/types.h>
  
  #include <linux/netfilter_ipv4/ip_set_nethash.h>
-Index: ipset-2.2.3/ipset_portmap.c
-===================================================================
---- ipset-2.2.3.orig/ipset_portmap.c   2007-06-04 13:22:37.573143296 +0200
-+++ ipset-2.2.3/ipset_portmap.c        2007-06-04 13:22:37.645132352 +0200
-@@ -21,7 +21,6 @@
+diff -ruN ipset-2.2.3/ipset_portmap.c ipset-2.2.3.new/ipset_portmap.c
+--- ipset-2.2.3/ipset_portmap.c        2005-01-19 07:38:57.000000000 -0600
++++ ipset-2.2.3.new/ipset_portmap.c    2007-05-31 14:06:58.521634750 -0500
+@@ -21,7 +21,7 @@
  #include <sys/socket.h>
  #include <netinet/in.h>
  #include <arpa/inet.h>
 -#include <asm/bitops.h>
  #include <sys/socket.h>
  #include <netinet/in.h>
  #include <arpa/inet.h>
 -#include <asm/bitops.h>
++#include <linux/bitops.h>
  
  #include <linux/netfilter_ipv4/ip_set_portmap.h>
  #include "ipset.h"
  
  #include <linux/netfilter_ipv4/ip_set_portmap.h>
  #include "ipset.h"