package/uhttpd: use new service wrapper
authorNicolas Thill <nico@openwrt.org>
Mon, 7 Nov 2011 22:59:06 +0000 (22:59 +0000)
committerNicolas Thill <nico@openwrt.org>
Mon, 7 Nov 2011 22:59:06 +0000 (22:59 +0000)
SVN-Revision: 28841

package/uhttpd/Makefile
package/uhttpd/files/uhttpd.init

index 6285eab9ac5a4f1735b87b151a37bb2ec71c1524..d8bd33c075c021c0cbd1340ad96503de85ca13a4 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=uhttpd
-PKG_RELEASE:=28
+PKG_RELEASE:=29
 
 PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
 PKG_CONFIG_DEPENDS := \
index 1ec009663b5f5f0217292f51d1d8929545c66a7d..c370f901099b6456ede8d2acb8abbd0e1d40c498 100755 (executable)
@@ -2,10 +2,13 @@
 # Copyright (C) 2010 Jo-Philipp Wich
 
 START=50
+
+SERVICE_DAEMONIZE=1
+SERVICE_WRITE_PID=1
+
 UHTTPD_BIN="/usr/sbin/uhttpd"
 PX5G_BIN="/usr/sbin/px5g"
 
-
 append_arg() {
        local cfg="$1"
        local var="$2"
@@ -103,21 +106,16 @@ start_instance()
                }
        }
 
-       start-stop-daemon -S -x $UHTTPD_BIN \
-               -p /var/run/uhttpd_${cfg}.pid \
-               -m -b -- -f $UHTTPD_ARGS
+       SERVICE_PID_FILE=/var/run/uhttpd_${cfg}.pid
+       service_start $UHTTPD_BIN -f $UHTTPD_ARGS
 }
 
 stop_instance()
 {
        local cfg="$1"
 
-       [ -f /var/run/uhttpd_${cfg}.pid ] && {
-               start-stop-daemon -K -q -n ${UHTTPD_BIN##*/} \
-                       -p /var/run/uhttpd_${cfg}.pid -s TERM
-
-               rm -f /var/run/uhttpd_${cfg}.pid
-       }
+       SERVICE_PID_FILE=/var/run/uhttpd_${cfg}.pid
+       service_stop $UHTTPD_BIN
 }
 
 start() {