fix incorrect quoting in busybox cron init script
authorJo-Philipp Wich <jow@openwrt.org>
Tue, 17 Feb 2009 17:29:17 +0000 (17:29 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Tue, 17 Feb 2009 17:29:17 +0000 (17:29 +0000)
SVN-Revision: 14540

package/busybox/Makefile
package/busybox/files/cron

index ae379045ae8f279bb637a5b334e568f839edf526..b0f0fc8f287078f08befb4fd33859b47af1f30d2 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=busybox
 PKG_VERSION:=1.11.3
-PKG_RELEASE:=3
+PKG_RELEASE:=4
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://www.busybox.net/downloads \
index 9a313927178067409d5c729dce84922f8b24c2b0..f24713060841aaa413da2486595efab234db75cf 100755 (executable)
@@ -3,7 +3,7 @@
 START=50
 
 start () {
-       [ -z $(ls /etc/crontabs/) ] && exit 1
+       [ -z "$(ls /etc/crontabs/)" ] && exit 1
        mkdir -p /var/spool/cron
        [ -L /var/spool/cron/crontabs ] || ln -s /etc/crontabs /var/spool/cron/crontabs
        crond -c /etc/crontabs