* add some compile flags
authorJohn Crispin <john@openwrt.org>
Fri, 11 Mar 2011 08:22:47 +0000 (08:22 +0000)
committerJohn Crispin <john@openwrt.org>
Fri, 11 Mar 2011 08:22:47 +0000 (08:22 +0000)
SVN-Revision: 26025

package/uboot-lantiq/patches/010-fix-mips-flags.patch

index 4c706a78434867b21ee18bb220d9569b074acfaa..6dd7d8f569c3732aef6b41a8dc13d6ba58ed67b3 100644 (file)
@@ -1,6 +1,6 @@
 --- a/cpu/mips/config.mk
 +++ b/cpu/mips/config.mk
-@@ -23,16 +23,18 @@
+@@ -23,17 +23,19 @@
  v=$(shell $(AS) --version | grep 'GNU assembler' | egrep -o '2\.[0-9\.]+' | cut -d. -f2)
  MIPSFLAGS:=$(shell \
  if [ "$v" -lt "14" ]; then \
@@ -19,5 +19,7 @@
  endif
 +endif
  
- MIPSFLAGS += $(ENDIANNESS)
+-MIPSFLAGS += $(ENDIANNESS)
++MIPSFLAGS += $(ENDIANNESS) -fno-schedule-insns -fno-schedule-insns2
  
+ PLATFORM_CPPFLAGS += $(MIPSFLAGS)