move "make symlinks" to "make package/symlinks"
authorMike Baker <mbm@openwrt.org>
Wed, 31 Jan 2007 18:33:04 +0000 (18:33 +0000)
committerMike Baker <mbm@openwrt.org>
Wed, 31 Jan 2007 18:33:04 +0000 (18:33 +0000)
SVN-Revision: 6234

Makefile
package/Makefile
scripts/feeds.sh

index 84c8c51156e7689947287fc0bbe6ea9d599db3ae..35fc2c8884e036ae93e656f9c538ae90acc614c9 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -187,9 +187,6 @@ doc:
 docclean:
        $(MAKE) -C docs/ clean
 
-symlinks:
-       scripts/feeds.sh $(CONFIG_SOURCE_FEEDS) 
-
 .SILENT: clean dirclean distclean config-clean download world
 FORCE: ;
 .PHONY: FORCE help
index cd4304e667a68da332792fb29595fa1f27673989..d21fedf31becb42d4de8d2fedc3a54b54188554d 100644 (file)
@@ -73,6 +73,8 @@ index: $(PACKAGE_DIR)/Packages
 $(PACKAGE_DIR)/Packages: $(PACKAGE_DIR)/*.ipk
        (cd $(PACKAGE_DIR); $(SCRIPT_DIR)/ipkg-make-index.sh . > Packages)
 
+symlinks:
+       ../scripts/feeds.sh $(CONFIG_SOURCE_FEEDS) 
 
 ifeq ($(MAKECMDGOALS),compile-targets)
 MAKEFLAGS:=$(MAKEFLAGS) -j$(CONFIG_JLEVEL)
index a16b212c80d7e2002b3d28ab55c9e6ba87f2442d..351c87c43dd2ca70d8fda03c4b383cc4276f3970 100755 (executable)
@@ -28,16 +28,16 @@ delete_symlinks() {
 setup_symlinks() {
        # We assume that feeds do reproduce the hierarchy : section/package
        # so that we can make this structure be flat in $PACKAGE_DIR
-       for dir in $(ls $2/)
+       for dir in $(ls $1/)
        do
-               ln -s $2/$dir/*/* $1/
+               ln -s $1/$dir/*/* $2/
        done
 }
 
 checkout_feed() {
        # We ensure the feed has not already been checked out, if so, we just update the source feed
        if [ -d $FEEDS_DIR/$2 ]; then
-               svn update $FEEDS_DIR/$2
+               svn up $FEEDS_DIR/$2
                echo "Updated to revision $(LANG=C svn info $FEEDS_DIR/$2 | awk '/^Revision:/ { print $2 }' )";
        # Otherwise, we have to checkout in the $FEEDS_DIR 
        else
@@ -48,7 +48,7 @@ checkout_feed() {
 
 extract_feed_name() {
        # We extract the last name of the URL, maybe we should rename this as domain.tld.repository.name
-       echo "$(echo $1 | awk -F/ '{ print $NF}')"
+       echo "$(echo $1 | sed -e "s/[^A-Za-z\.]\+/_/g")"
 }
 
 # We can delete symlinks every time we start this script, since modifications have been made in the $FEEDS_DIR anyway