tcpdump: explicitly disable libcap-ng support
authorStijn Tintel <stijn@linux-ipv6.be>
Thu, 19 Jul 2018 17:07:38 +0000 (20:07 +0300)
committerStijn Tintel <stijn@linux-ipv6.be>
Tue, 13 Nov 2018 09:45:13 +0000 (11:45 +0200)
If libcap-ng is detected during tcpdump build, support for it is
enabled and the binary is linked against it. Explicitly disable
libcap-ng support to avoid build failing due to a missing depndency.

Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
package/network/utils/tcpdump/Makefile

index 50919819b63f55ce74ac1dc41fd8c3d139892c9e..712617fd25fd5418e33c0673c71e332511f842d3 100644 (file)
@@ -47,6 +47,7 @@ define Package/tcpdump-mini
 endef
 
 CONFIGURE_ARGS += \
+       --without-cap-ng \
        --without-crypto
 
 ifeq ($(CONFIG_IPV6),y)